4 Replies Latest reply on Feb 3, 2010 9:32 AM by blaine67us

    Task Crystal Report


      Hi there,


      I'm trying to create a Task.rpt using the hr_activity table and tps_user table.


      I have the report laid out how I want and have added it to ServiceDesk.


      However, no matter which task I want to print, it picks the same record in the table.


      I think I ran into this before with the Note.rpt, but can't remember how to fix it.


      Any ideas ??

        • 1. Re: Task Crystal Report
          LegoGuy SupportEmployee

          I'm no crystal guru myself but I know that the way the reports work is that they receive a GUID and then they look it up in the database table to get the data.  It sounds like you've hard coded the report so that every time it runs it uses the same GUID.  It isn't reading the one that comes in, it's using the same one each time.  There is a setting in there somewhere where you can change that.


          Sorry that doesn't answer the question but hopefully it'll get you going on the right path.

          • 2. Re: Task Crystal Report

            Hi Nephi, thank you for the reply.  I forgot to set up a parameter for the guid and it was just picking up the first one in the table.


            However, I'm still having a problem.  Since it's a task from the HR module, I don't know which table to base the report off of.


            I switched to the hr_activity_task table, but not getting any content at all, even though I'm using th pm_guid has a selection.


            I've only found the task guid in the hr_assignment_task table.


            Has anybody else successfully created a report off of the task screen in the HR module ??

            • 3. Re: Task Crystal Report
              LegoGuy SupportEmployee

              I haven't worked with these modules before, but it looks like hr_activity is the main module and hr_activity_task is the task module for HR.  I see a pm_guid in hr_activity_task.

              • 4. Re: Task Crystal Report

                I forgot to link the tables using the Database Expert.  I was able to get the report to run.......