10 Replies Latest reply on Mar 3, 2010 12:54 PM by Mach6

    LD9 HII fails right away

    Froggmann Apprentice

      I've been working a day and a half on this now and so far no luck at all.


      I'm trying to image a couple of machines for Monday and decided to try the new HII procedure in LD9. I went through the HII quick start guide verbatim but have yet to have one of these go past the first step. Well I take that back, it does clean the drive, but it fails on mapping to the image folder. Here's the text from the log:



      "LSA402","OK",0,0:00:00,2/19/2010 2:24:20 PM,2/19/2010 2:24:20 PM,"WINPE, TIMEOUT=1800"

      "LSA402","OK",5,0:00:01,2/19/2010 2:24:20 PM,2/19/2010 2:24:21 PM,"diskpart /s X:\LDClient\rmvol.txt"

      "LSA402","ERR_Fail",-1917255678,0:00:00,2/19/2010 2:24:21 PM,2/19/2010 2:24:21 PM,"ldrun drvmap.exe domain\username 20979C61A5A88BD78D8F495A317E37 I: <qt/>\\CORP14.domain.internal\wkimages<qt/>, STATUS FACILITY=3513"

      ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"



      Since OSD Provisioning is now broken for me this is my last line of sanity before I'm having to donate a weekend day to building these machines manually.





      Upgrade your PXE reps.


      To do this you will need to perform these steps:


      1. Identify your PXE Reps. To do this, on the core click Configure> Services> OS Deployment The machines in either column will need to be updated.


      2. Remove the PXE server from each rep. To do this locate the "All other scripts" folder under the OS Images folder on OSD. Highlight and right-click "PXE Represenitive Removal" and select Schedule. Drag your PXE rep machines to the task and start it. Go have some coffee, it takes about 5-10 minutes.


      3. Once done, schedule the "PXE Represenitive Deployment" script and start the task. Go have some more coffee.


      4. Update your PXE reps in the database. To do this right-click your chosen PXE reps and start an inventory task. Wait for this to finish. Go have more coffee.


      5. Update the PXE Reps. Open up the "PXE Boot Menu" panel. If you can hold your hand steady enough through the caffeine jitters, click the "Update" button.


      You are now ready to use OSD.


      Edited to include the full solution.

        • 1. Re: LD9 HII fails right away

          In my experience, this is usually one of two things -- Rights or Name Resolution.


          1. Do the domain\username and password combination you are using have rights to read from the share you are mapping?
          2. From the WinPE, can you ping CORP14.domain.internal by name?  If not, I'd say that's your issue...
          • 2. Re: LD9 HII fails right away
            Froggmann Apprentice

            The account I'm using has full administrative rights to the domain so it can't be that. I did ping the server from the client's PE Console and yes I can get to it. I also changed the path of the server to represent the IP address and it still doesn't work.

            • 3. Re: LD9 HII fails right away

              I would recommend trying the following 2 things:


              1 - Try a net use command for the same share using the same un/pw combination that you use in the drvmap command and let us know the results.


              2 - If it's successful, retype the password in the script to make sure it's stored correctly.


              Also, are other tasks working correctly, or is this a universal problem with all your captures/deployments?

              • 4. Re: LD9 HII fails right away
                Froggmann Apprentice

                No good. I can ping, I can map the drive using net use, I have entered, re-entered and entered again the account information "Domain\username" Nothing works. Always the same error.


                This is an upgraded version of LD9 from LD8.8 SP3. Is it a possibility ldrun or drvmap.exe is corrupt or not the correct version?

                • 5. Re: LD9 HII fails right away
                  EMiranda Expert

                  have you tried fqdn in your username, ie.  CORP14.domain.internal\username


                  also you can test to see if drvmap is working or at least see if it is erroring out.



                  in winpe, open up a command prompt and browse to:


                  cd x:\ldclient


                  syntax would be:


                  drvmap.exe username password driveletter share




                  drvmap.exe CORP14.domain.internal\bigbob  password1 N: \\CORP14.domain.internal\wkimages



                  see if that works and let us know...

                  • 6. Re: LD9 HII fails right away
                    Froggmann Apprentice

                    Thanks for the ideas I'm out sick today so I won't be able to test at all but I should be back tomorrow.

                    • 7. Re: LD9 HII fails right away

                      Not sure if this is resolved yet or not. I had the same problem after upgrading to LD9. Updating the PXE rep resolved the issue. Not sure why, but until I updated it, it would fail when mapping the drive.

                      1 of 1 people found this helpful
                      • 8. Re: LD9 HII fails right away
                        Froggmann Apprentice

                        Great suggestion. Perfect timing as well just got back in the office today and was planning on working on this today. Got done rebuilding the PXE reps about 10 minutes ago and am trying this now.


                        Oooo... pretty background... Oh hey ImageX just kicked on!



                        • 9. Re: LD9 HII fails right away
                          Froggmann Apprentice

                          Zachry Sum had the right answer. Just had to upgrade my PXE server all was fine with the world again. Thanks!

                          • 10. Re: LD9 HII fails right away

                            Nicely done Zachry!


                            Froggmann, glad to hear you've got it going.