10 Replies Latest reply on Jul 15, 2011 9:07 AM by freddykid

    Windows 7 Deployment from DVD source

    Rookie

      I am looking for pointers on Audit mode,I have OS deployment setup from the extracted DVD source.  So my provisioning template is laid out like this

       

      PE-     

           remove all partitions

           Map to image share

           Map to driver/config share

       

      OS Install

            Execute file   %path%\setup.exe /noreboot /unattend:audit.xml  (this uses the installFrom to launch x64bit install.wim)

            File copy WMI_model.exe  to c:\drivers

            File copy oobeunattend to c:\windows\system32\sysprep\

       

      Post OS

           Hardware Indepent Imaging

           CTOS

       

      Upon reboot it launches the rest of the OS configuration settings and does OOBE where I left out computer name in the .xml file so it prompts to name the Computer.  Then it goes in does my first logon commands to configure windows.

       

      My problem is that even though I have an unattend audit it is not installing from the C:\windows\lddriverstore.  the drivers are there but the do not install. if I skip OOBE all together and manaully run sysprep /generalize /oobe /reboot .unattend:oobe.xml it installs the drivers.

       

      Is anyone else using this method to deploy  is it possible to automate?  I assume it is an issue with my unattend but I have literally tried over 100  different unattend files and I can't get it to run smooth.

       

      I will attach my xml files later.  I do not have them handy to attach right now.

       

      I want to have no images to update just configuration files.  I would rather not have to inject driver files in the install.wim.

       

      Message was edited by: freddykid I ended up looking back at my audit.xml and added the pass OOBE reseal to Mode (audit) after that it worked. 

        • 1. Re: Windows 7 Deployment from DVD source
          Apprentice

          Sorry for the incrediblly stupid question here, but I am having major difficulties getting OSD to work with Win7.  I had it working until I added SP1 to my source machine, recreated the source image file and now trying to deploy from OSD.  I get a problem with the Bootmgr.  I know it has something to do with the way I captured the image, and possibly with the deployment, but I am really struggling here.  Can you, in detail, explain how you do it?  What do you use for imaging?  I am using ImageW2, but am willing to use anything at this point.  I have a feeling that my source VM is screwed up.  I have a 100 MB SYS partition and the rest for Win7.  Should I be capturing these seperately?

          • 2. Re: Windows 7 Deployment from DVD source
            Gjstewart Specialist

            Scott when you redeploy your test image do you deploy back onto a VM??

            • 3. Re: Windows 7 Deployment from DVD source
              Apprentice

              Hi Freddy,

               

              I'm using all the time the setup.exe of Microsoft to install the Windows 7 client with LANDesk provisioning. I never use the Audit mode, because for me it's a stupidity to use it, I really don't need / like to do. To have all working as expect, everything you need to understand correctly is how the answer file works to be able to do the driver injection, the update injection and the LIP if you need. Then also have LANDesk provisioning finish correctly the setup and install the needed apps afterwards.

               

              Your PE phase is OK

               

              OS Install:

                   1) Copy first the answer file to C:\unattend.xml

                   2) Copy the drivers using HI or using a WMI script (my prefered method)

                   3) Run the setup.exe /noreboot /unattend:c:\Unattend.xml

               

              PostOS:

                   1) CTOS

               

              The setup will use the answer file to configured correctly the install, using the name (landesk query) and alos installing the drivers because in the XML you inform where the driver are on the disk. Then do not forget the CTOS in the provisioning. One important rule using the setup.exe, when it's started, you cannot change anything, I mean even if you want to add drivers after, like you do, the setup will not use them. The driver must be present BEFORE starting the setup.exe

               

              Voilà. I have many more information if you want, just let me know.

               

              Regards

              Lionel

              • 4. Re: Windows 7 Deployment from DVD source
                Rookie

                Hi Lionel,

                 

                Thanks for the feedback. We are not formating the drive of the XP machines because USMT runs much faster locally pulling user settings from the Windows.old.  In my experience anything that gets copied to the C drive before setup runs will be moved to the Windows.old folder. Are you saying that if the drivers are there before the setup.exe runs they will install beofore they get moved to Windows.old?  I agree Audit mode is stupid but it does have some benefit, you just need to have two unattends.  It's the only way I have found to keep drivers off of the install.wim for this scenario. I use a slightly different method for new installations where I do format the C: drive but it is still closely tied to the format for migration.  I would love to get more info or tips if you have them.

                 

                What WMI Scripts are you using?  I have several that I have used but am always looking for better or more effiicient ways.

                • 5. Re: Windows 7 Deployment from DVD source
                  Apprentice

                  I do my master image in a VM in Audit Mode.  Then boot to PXE, map a drive, and capture the image using ImageW2 (using the defaults given to me by Landesk).  I then attempt to deploy the image using either OSD or Provisioning to a physical pc.  After that it boots and goes into a constant reboot.  I believe it has something to do with the system partition and bootmgr.  I know it is kind of cheating, but can someone tell me their exact steps they us in order to get this to work?  Maybe I should use ImageX instead?

                  • 6. Re: Windows 7 Deployment from DVD source
                    Rookie

                    Hi Scott, I haven't used Imagew that much but when I was testing I got the same bootmgr errors.  I was able to get rid of the errors removing the 100MB partition from the image and formating the drive before I pulled the image.  I would say to play around your config to see if you are placing the bootmgr on the correct partition.  I never really found a way to get it back but we chose to go with the Setup.exe method so we didn't have to keep updating images.

                     

                    Sorry I am not more helpful.

                    • 7. Re: Windows 7 Deployment from DVD source
                      Apprentice

                      hi Freddy,

                       

                      Ok you are using USMT in the hardlink mode, no prob. Good idea I have also done that. When you run setup.exe with an already existing Windows folder, you right everything is copied on the old folder, but you can use it anymore right? What I mean is via the WMI script you copy the drivers on c, the setup will move it to the old folder but in the answer file you put the Windows.old folder for your driver... And at the end you delete the old folder using the provisioning.

                       

                      Regarding the WMI script its a Basic one. I can give you but not for the moment i'm on holiday until first august.

                      Any comments?

                       

                      Lionel with my Windows  Phone 7 :-)

                      • 8. Re: Windows 7 Deployment from DVD source
                        Apprentice

                        @Scott,

                         

                        Freddy is right did you capture the whole disk with imagew? Because Microsoft create by default 2 partitions the first one for bitlocker and the second for the OS. If your are not using the first one you can install windows without it. Bing it to find how to setup windows 7 without 2 parts and it will be more easier. Otherwise use imageX to capture only the os but you should create the boot loader.

                         

                        BTW why do you need to create an image?

                         

                        Regards

                        • 9. Re: Windows 7 Deployment from DVD source
                          Apprentice

                          We wanted to be able to add our '20 items of flare' to the image, among install standard applications and printers.  Seemed easier to do this in the image rather than after the setup.

                          • 10. Re: Windows 7 Deployment from DVD source
                            Rookie

                            Wow, that is awesome!  I completely over-looked that, It just never clicked.   That will make the process much easier.  Thank you!

                             

                            The WMI script I use is basic as well, it checks after the installation for the model, then maps to the driver share and copies all the model's drivers and kicks off a batch file to install them.

                              Enjoy your holiday and agian thank you for that pointer on the windows.old drivers.