4 Replies Latest reply on Oct 27, 2011 5:41 AM by Tom O'Brien

    Inventory Server Did Not Respond

    Tom O'Brien Apprentice

      Having an odd issue. On newly imaged devices (Lenovo x220), we install the Advanced Agent (9.0sp2) via group policy. After the client is installed, scans will not run. We get "the Inventory Server 'Core Server FQDN' did not respond". From the same machine we can ping the core by the FQDN and the core is processing all other scans just fine. The machine is part of a domain (different than the core) and we've tested with the machine not in a domain with the same issues. Even stranger, if we leave the machine(s) on for the day, and come back in the a.m., the scans ALL work, no issues. No change to the device/core, nothing.  The issue is primarily happening on a single image for these x220's, and can't determine what might be blocking communication with the core. The firewall service is disabled on the client. No AV installed on the client at the time. Thinking it's something in the image or that the LANDesk client is not installing properly on this image. However, why it works the day/hours after the client install is still a mystery.


      Additional Info:


      I just tried the inventory scan using the Core Server Name instead of the FQDN and the scan worked.Both the server name and FQDN are resolvable by the client.


      O/S: XP Sp3


      Any thoughts?

        • 1. Re: Inventory Server Did Not Respond

          1] Check LANDesk Inventory service on core server

          2] Test nslookup FQDN name core server

          3] Test access port inventory by Telnet core server 5007

          4]Check GPO policy

          5] On cmd net stop mpssvc

          • 2. Re: Inventory Server Did Not Respond


            Odd Issues are frequently, but not always, the result of some AD GPO kicking in. maybe you device gets some GPO update after a number of Hrs that changes the way it is able to resolve the core server name via DNS?



            • 3. Re: Inventory Server Did Not Respond

              5] On cmd net stop mpssvc "stop firewall"


              is what one of the five tests was a successful and if so, or what?

              please insert your results.


              You can execute command gpresult on your client computer to verify GPO

              • 4. Re: Inventory Server Did Not Respond
                Tom O'Brien Apprentice

                All, name resolution was fine, firewall off/disabled, Inventory Service on the core is ok, telnet worked fine. Still investigating GPO's.


                I ran a wireshark while the Inventory scan was running and could see it contact the core, but almost immediately attempt to contact the Mgmt Gateway..like the Core was not reachable. This client is not setup for the gateway so after a short period of time, I get the did not respond msg. I can ping the core by FDQN without issue at the same time the core is not reachable. The core is processing other scans without issue.  As a test I ran BrokerConfig and changed the setting from 'Dynamically determine connection route' to 'Connect directly to the LDMS core'. After doing so, the Inventory scan works fine using the FQDN. Set it back to 'dynamically', and it fails. Came in this morning and all scans work fine with it set to dymanic using the FQDN.