4 Replies Latest reply on Feb 19, 2012 12:56 PM by DANDesk

    Device monitoring (PING) no longer working


      I'm having an issue with device monitoring.  We've recently set up device monitoring for all our servers, and it worked well for a few weeks, regularly notifying us if a server failed to respond to ping requests etc.  Since about a week ago, it doesn't work anymore at all.  We still get alerts from the agents, but no device monitoring anymore.  I've checked to ensure services are running, read event logs, rebooted the LANDesk server etc but still we continue to experience the problem.


      Has anyone else had this issue?  How did you resolve it?



        • 1. Re: Device monitoring (PING) no longer working


          I would like to know how did you set the PING Alert.

          Can you please brief on this. I am trying to set the same alerts.

          • 2. Re: Device monitoring (PING) no longer working

            I'm having issues with Device Monitoring not working any longer as well. I have it set to Email me in addition to making the default log entry. However, neither of those is occuring, which leads me to believe that Device Monitoring just isn't working at all on my core. I have a case open with support, but it's been 3 months and they have made very little, if any, progress.


            If you were able to resolve this, I would love to know what the resolution was for you.





            • 3. Re: Device monitoring (PING) no longer working

              We had the same issue with our core server, the problem was looked at numerous times by technical support but they could never resolve it. We gave up on device monitoring and just use Nagios a free open source alerting tool.

              • 4. Re: Device monitoring (PING) no longer working
                DANDesk Rookie

                I also lost all remote alerting on one core. This is with SP3 installed. Nothing would post in Tools - Reporting/Monitoring - Logs other than core itself. IF YOU HAVE REMOTE CLIENT ENTRIES IN THIS LOG then you have just an email issue. Went through everything and support thought it wasn't a LANDesk issue. Alerting down for over a month.


                I reloaded the core and everything started working.


                The core rebuild isn't that bad since the LANDesk Software uninstall on the server leaves so many directories behind inlcuding the Keys directory so your original certificate will be there so you can connect back to your same clients without having to redeploy agent.


                The trick is to take remote SQL database offline (may need to reboot core here to get DB offline),uninstall everything LANDesk from server but leave directories that it leaves, reboot, run install and use SQL Express local, activate core, reboot, install SP3 on core, make remote SQL database online, change database info under Configure/Services/General to remote SQL, reboot. Immediately my log was showing alerts from remote devices and emails starting flowing.


                Another big help is adding Installed RuleSet Filename to your Column Set so you can see how many old sets may be in play on each device. I created a task to remove all rulesets for the ones with multiple old sets. Redploy agent to get just the ruleset with your agent and then maybe add a separate set for any extra monitoring (OS log or remote control, etc.).


                Hope this helps.