14 Replies Latest reply on May 15, 2012 8:55 AM by Colin_In_Ottawa

    Power management error


      I have recently attempted to push a new power policy to my client machines.  Most of them worked out ok, but about 10% came back with the error of Result: "Failed to process the power scheme of Windows! Return Code: 2505.  I have searched to see what could be causing the issue but I really could not find any documentation.  I am using LDMS 9.0 sp2 and have recently installed the most recent mcp patches.  Thanks.

        • 1. Re: Power management error
          MarXtar ITSMMVPGroup

          You've probably checked this, but are those client agents also up to date? LANDesk runs a local process to set the power options and it's capabulities vary across the versions.


          Mark McGinn

          MarXtar Ltd


          1 of 1 people found this helpful
          • 2. Re: Power management error
            Catalysttgj Expert

            I'd recommend that you analyze the pwmcfg.log file that should be present in the LDclient directory on the devices in question.

            This log will update any time a power policy is applied, as well any time that pwmcfg.exe executes.

            There will be quite a lot of information in this log, and something in there may clue you into what this error is all about.


            We had one device where the power policy would not set because the specific user profile had some missing registry values on a specific power scheme.

            The log helped with tracking that down.


            Good luck!

            • 3. Re: Power management error

              I will track down the log file.  Thanks for the heads up on the location of the exact file name.  As for the clients I pushed all new clients to the computers that should have packaged all of my updates in it, but it is always good to double check.  I have found the log file but am really unsure of what i am looking at here.  To me it looks as though the power policies have worked, and my scheduled wake up task seems to be confirming this, but I really do not like to shrug my shoulders and say 'oh well'.   Thanks for the help.

              • 4. Re: Power management error
                Catalysttgj Expert

                Time will tell. Your logs do look pretty good there, but i did see the same error that i've seen once or twice on a couple of our test systems. My suspicion is that LANDesk still has some kinks they need to work out with pwmcfg.exe. We've already reported one bug, though it would be very unlikely that anyone else would encounter it, as well a sortie of typos do appear in the logs. Not that this is a functional problem it does show they need to spell check their logging routines in this code.


                At any rate, the error that i'm referring to has to do with when your user "domain\XYZ" was logged on to the system. You'll notice that pwmcfg has trouble reading value '6':


                Failed to call CRegHelper::ReadString(HKEY_USERS, S-1-5-21-2090760695-1161300292-829235722-9090\Control Panel\PowerCfg\PowerPolicies\6, Policies)


                If you go and dig in the registry on that machine, and drill down to this path, I suspect you will find that the key path looks a little barren compared to 1, 2, 3, 4, 5 and even 7, 8, and 9. Keep in mind, this user must be logged on when you go look for this specific registry path. This is a user hive path. If the user is logged off at the time, you won't see this path in the registry, though you could load the specific user hive if you have the means to do so.


                This error is preventing it from setting the "LANDesk Power management" scheme, but it might be only limited to when that "XYZ" user is logged on. Another user might not have the same problem at all. We ran across this on a machine where a specific user profile was missing a specific registry value in a specific power profile. It was thought to be a fluke, but now that i see this happening with one of yours, maybe not a fluke. This could be a more wide spread issue.


                A bug report may need to be logged with LANDesk so that they can fix this. If there are a multitude of user profiles with the same condition of missing specific registry values in specific power policy paths, there could be a lot of missed schedules when users are logged on to devices only.

                • 5. Re: Power management error

                  I did indeed take a look at the reg key as you suggested and you were absolutely correct.  It is very vacant in comparison to the other keys. I also ran an experiment of making sure the users were logged off and then setting the power policy, and had some interesting results.  The power policy took and is working but still posted the same error.  I found it odd and it was not what I expected.  However, it is a work around for the time being.  I believe you ar spot on in a bug report needs to be filed for this and will do it today.  Thanks for everyone's help on this.

                  • 6. Re: Power management error
                    Catalysttgj Expert

                    That's Great! If you wouldn't mind, if you get a Bug report code from landesk for this, please let me know what it is, and we'll get it over to our TAM as well, so that we can get more heat on it for getting it fixed. We know how to reproduce it, so that helps a lot for getting a BR going. If for some reason you don't get a BR in a week or so, We'll try and get one going on this end.



                    • 7. Re: Power management error

                      Well I would like to clarify my previous comment.  Most of the ones posting errors worked I still have about 10% that are not.  Either way i will let you know if I get a bug reported.

                      • 8. Re: Power management error

                        Well dropped a self service request in with no bug report listed.  They are still working on it.  Maybe time to get it going from your side as well.

                        • 9. Re: Power management error
                          Catalysttgj Expert

                          It'll be next week for sure. A little too busy to get it cranked out. Only a few days away though.


                          Thanks for the update!

                          • 10. Re: Power management error

                            So as an update to this issue so that people may know for the future.  I ended up creating a new agent config and including the desired power settings in the agent config.  That seemed to populate all the necessary registry keys and allowed our power config to work. Give that a try if you have the above issues related to pushing your power policy.

                            • 11. Re: Power management error

                              I have over 600 machines with this issue. LANDesk engineers so far have no fix for me. I have had a call open for a few months now. So if anyone has any ideas on how to push a registry poke to the HKEY_USERS Hive to target a fix please let me or LANDesk know.


                              • 12. Re: Power management error

                                What I ended up doing was to push a bat file to the start up folder that calls the reg key from a share.  It worked pretty well.  Post here and I can probably find the file to give you an example.

                                • 13. Re: Power management error

                                  That would be appreciated to see your script. Landesk engineers have advised a fix will not be released until the next full version release and I cannot wait that long to patch 500+ computers.

                                  • 14. Re: Power management error

                                    An update to this. I still have no answer from LANdesk on a fix. in the meantime I upgraded to SP3 and had to redeploy the agent with the power management settings in the agent... This did NOT fix the issue on machines with the failure to write the registry. The issue remains on my 600 machines.