2 Replies Latest reply on May 29, 2008 1:58 PM by Jed

    Brokerconfig has SSL problems





      We have configured the connexion between the core and the neu gateway appliance. We have tried a connexion using brokerconfig from an internet PC to our Landesk environment but have problems with it and do not really know where to look for. Here is what happens when we test a connexion:



      40:21.031   Starting HTTP session with host RBS-W14:80, proxy "", and proxy user ""

      40:23.296   Unable to resolve host RBS-W14 address

      40:23.359   Direct connection failed 6 Name resolution error

      40:23.375   Attempting managment gateway connection at host  and address ldgateway.regent.ch

      40:23.390   Starting HTTPS session with host ldgateway.xxx.xxx, proxy "", and proxy user ""

      40:23.406   Connecting to address xxx.xxx.xxx.xxx

      40:44.375   SSL Connection failed error:00000000:lib(0):func(0):reason(0) 0 40:44.687   Direct connection failed, attempting to find configured proxy

      40:44.718   Looking for autoproxy settings as current user

      40:44.734   Autoproxy settings are enabled, starting search for autoproxy

      40:45.031   Sending DHCP query to determine autoproxy

      40:51.046   Could not determine autoproxy from DHCP query

      40:51.671   Sending DNS queries to determine autoproxy

      40:52       Could not determine autoproxy from DNS queries

      40:52.015   Could not find proxy from autoproxy settings

      40:52.046   Looking for autoproxy settings as current user

      40:52.062   Connection through managment gateway failed 10 SSL Handshake Error


      For us it seems at least that the client knows that it cannot access the core server directly and tries immediatly after to use the gateway, but then the connexion using SSL seems not to work.


      Has anyone an idea, what we should do next ?




        • 1. Re: Brokerconfig has SSL problems





          Meanwhile I just installed a remote PC on the internet with an actual client by using a copy of the LDLOGON directory and the situation has evolved:



          - the client could request a certificate. It seems in fact that the other testing client is probably running an "older" landesk client , that knows nothing about the new configuration, with the gateway.



          - I could start an inventory on my "working" client and it created me a device object.



          - the problem seems now that all functions do not work at this stage: I cannot remote control the client (should I use the "normal" remote control option in the management console or something else ?) and I also tried to install an application. The client recognizes that an application based on policy deployment is available for him, but the installation fails.



          These are the 2 main functions that we'll have to use with our internet clients, so any suggestion of anyone would be very appreciated.
















          • 2. Re: Brokerconfig has SSL problems
            Jed Employee


            It sounds like some configuration on the Gateway itself needs to be performed.  On the setup web page under "Gateway Service" under addtional hostnames make sure everything (IP, Hostname, DNS) that the Gateway can be resolved to has been specified.