10 Replies Latest reply on Oct 4, 2013 1:41 AM by Adam Wilden

    Filter not working in WebAccess

    Adam Wilden Expert



      I'm creating a new change process for my new director and am having problems with a filter in a User collection on my main window.


      Basically, we want it so that we first select the Group, and when you select the user dropdown it only shows members of the previously selected group.


      I've created a filter on the User relationship on the relevant BO and it is working really well in Console.


      But I can't get it to work in WebDesk, where the User list is still listing all users.


      I've tried adding it via Window Designed as well.


      Restarted IIS upmteen times.


      What am I missing?


      Cheers - Adam.

        • 1. Re: Filter not working in WebAccess
          elizabethcombrink Expert

          Adam - Its Sunday today...


          I had no trouble setting this up in Change by using filters on the object.


          The only trouble I have had with filters NOT working in WebAccess as they do in Console is when there is a copy settings involved with the same attribute.

          • 2. Re: Filter not working in WebAccess
            Adam Wilden Expert



            Yeah - I know it's Sunday.  Been working all weekend on this and expect to be into the samll hours...


            But this problem is driving me mad.


            There's no copy rules - both attributes are new.  I've tried using a simpler existing filter and that works OK in WebDesk  - so there must be a problem with my new filters - but they are very standard and why they would still work on Console is beyond me...

            I have a new User attribute called: _ImplementationUser

            And a new Group attribute called: _ImplementationGroup


            The filter, set on the Implementation User object FIlter Selector is the first and only filter on that attibute and has the following condition: "Groups.Group is equal to (_ImplementationGroup)".  This was created for all users, is identical in syntax to loads I've created before and, as stated, works well in Console but is ignored in WebDesk....



            • 3. Re: Filter not working in WebAccess
              elizabethcombrink Expert

              And your WebDesk is running on the same server as your Framework?  so your IIS reset resets both websites?


              Your filter looks right to me.

              • 4. Re: Filter not working in WebAccess
                Adam Wilden Expert



                Yes - but I've restarted IIS on all web servers (several times!) just in case.


                Other Simple filters seem to work OK, e.g. "UserType = Analyst".  I just can't get either the new User or Group attributes filtering against each other in WebAccess....


                Just realised I've now spent almost 3 hours on this!


                Hate it when it doesn't work.  Probably something stupid I've done (or not done) but can't think what!



                • 5. Re: Filter not working in WebAccess
                  Adam Wilden Expert

                  OK - I've done some more testing and I think this is because the filter is running on the main change window before it is first saved.


                  On Console it works fine without being saved first, but on WebDesk it only works after you have first saved the Change, which is kind of too late for what I need


                  Can't really think of a way around this....


                  The user info needs to be on this window, and will eventually be write-once.


                  Time for another cuppa methinks....

                  • 6. Re: Filter not working in WebAccess

                    There is an issue with older versions where filters in webdesk don't work on non-default windows.  So if your window is not the default, but one kicked with with a rule or via a windowless action, this might be a cause.

                    • 7. Re: Filter not working in WebAccess
                      Stu McNeill Employee

                      Hi Adam,


                      I hope you didn't spend too much time on this yesterday!  Dave is absolutely right, there is an issue in some versions of Service Desk whereby filters in Web Access don't work properly before saving a record if the fields in question aren't also present on the window that your default process would use (this might be the default window or might be via a view rule).


                      There were a few separate problem records for this but as long as you aren't filtering a Category dropdown  - fixed in 7.6.1, or use "Lifecycle" in a filter condition rule - still pending, the main one was 5321 which was fixed in 7.5 SP1 and also patched for 7.4.

                      • 8. Re: Filter not working in WebAccess
                        Adam Wilden Expert

                        Thanks Dave, Stu,


                        The new field is on a test window I'm loading via a View rule (abd not on the default window) so looks like this will be the issue..  though I thought we were fully patched on 7.4....


                        Will let you know once I can test on a default window.


                        Now... Remember some years back when a few of us suggested that an online "known issues" log would be a great resource for the community?  


                        Cheers folks - Adam.

                        • 9. Re: Filter not working in WebAccess

                          i have seen this before, but in my situation it only appeared as if problem was related to a non-default window, but it was really the view that was to blame!


                          Before I discovered the view was causing the problem, I suspected it was my current group.  I noticed that the window filters worked great when I was in one group, and not when i switched to another group.  I spent a good amount of time thinking it was my current group.  With the help of support, we realized that it wasn't the current group, but the view that was the problem.  Switching groups meant using different views according to my rules, and one of the views was not behaving.


                          When managing views in 7.5 or eariler, you may notice there are SEVERAL save buttons.  I suspected that hitting the wrong save button was related to the problem.  Sure enough, they removed the save button in the lower-right of the screen in 7.6.


                          If you are using 7.5 or less, TRY this in a test enviromnent.


                          1. Make a new view, and be sure to only use the lower-right save button.  DO NOT use the save button (disk icon) at the top, and DO NOT use File > Save. (7.5 or less only)

                          2. Add your window to the view, save with lower-right button.

                          3. add a view rule so the view will apply to you, lower-right save.


                          I deleted the old view, can't trust it anymore.


                          That fixed it for me, good luck.


                          *** To clarify, this was a non-default window, where the filters worked in one view, but the filters failed on the exact same window, in another view.

                          • 10. Re: Filter not working in WebAccess
                            Adam Wilden Expert

                            Thanks everyone.


                            We went live this week and the problem resolved itself once we stopped using the view and made the new window default.


                            We use a lot of views so think it's time to go through them all and check them!


                            Cheers - Adam.