4 Replies Latest reply on Mar 10, 2014 9:33 AM by HC

    Windows 7 Software Install Problem




      I'm hoping somebody can help me please?


      I've created a script to install some software, so that it can be deployed through our LANDesk Suite. We are using LANDesk Management Suite


      The script works successfully and installs the software on Windows XP desktops, but will not install the software on Windows 7 desktops. The script will only run on a Windows 7 desktop if you manually log on to the desktop, run a command prompt as the administrator and then run the script from there. It seems like the Windows 7 user access control is preventing the script from running as it doesn't work from a non elevated command prompt.


      Is there a way to run a script with elevated administrator rights on Windows 7? I've tried running the LANDesk job using alternative credentials with admin rights but it still won't run. I've also tried using the runas command, but it doesn't seem to work.


      Any help would be much appreciated.