4 Replies Latest reply on Mar 29, 2010 9:07 AM by radnor

    Problem with exporting packages on LD 8.8 SP3

    Apprentice

      Our Landesk server isn't behaving very well so instead of upgrading to ver 9 I decided to wipe it and install new version from scratch. Exporting software distribution tasks returns this error message:

       

       

      H:\Landesk\LD88-SP3-Core\LD88-SP3-Core\image>package.porter.exe export /file=c:\
      packages.xml
      System.IO.FileNotFoundException: Could not load file or assembly 'LANDesk.Manage
      mentSuite.Data, Version=8.80.0.249, Culture=neutral, PublicKeyToken=null' or one
      of its dependencies. The system cannot find the file specified.
      File name: 'LANDesk.ManagementSuite.Data, Version=8.80.0.249, Culture=neutral, P
      ublicKeyToken=null'
         at LANDesk.SWD.Package.Data.Package..ctor(String connectionString)
         at LANDesk.ManagementSuite.SoftwareDistribution.Business.PackageTypes.GetType
      s(String connectionString, Boolean serverManager, Boolean sorted)
         at LANDesk.ManagementSuite.SoftwareDistribution.Business.ImportExport.Package
      Porter.GetAllPublicPackages(String connectionString)
         at package.porter.PackagePorterApp.ExportPackages(String path)

       

      === Pre-bind state information ===
      LOG: User = CHEVIOT\budzk
      LOG: DisplayName = LANDesk.ManagementSuite.Data, Version=8.80.0.249, Culture=neu
      tral, PublicKeyToken=null
      (Fully-specified)
      LOG: Appbase = file:///H:/Landesk/LD88-SP3-Core/LD88-SP3-Core/image/
      LOG: Initial PrivatePath = NULL
      Calling assembly : package.data, Version=8.80.2.2, Culture=neutral, PublicKeyTok
      en=null.
      ===
      LOG: This bind starts in default load context.
      LOG: No application configuration file found.
      LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2
      .0.50727\config\machine.config.
      LOG: Policy not being applied to reference at this time (private, custom, partia
      l, or location-based assembly bind).
      LOG: Attempting download of new URL file:///H:/Landesk/LD88-SP3-Core/LD88-SP3-Co
      re/image/LANDesk.ManagementSuite.Data.DLL.
      LOG: Attempting download of new URL file:///H:/Landesk/LD88-SP3-Core/LD88-SP3-Co
      re/image/LANDesk.ManagementSuite.Data/LANDesk.ManagementSuite.Data.DLL.
      LOG: Attempting download of new URL file:///H:/Landesk/LD88-SP3-Core/LD88-SP3-Co
      re/image/LANDesk.ManagementSuite.Data.EXE.
      LOG: Attempting download of new URL file:///H:/Landesk/LD88-SP3-Core/LD88-SP3-Co
      re/image/LANDesk.ManagementSuite.Data/LANDesk.ManagementSuite.Data.EXE.

       

       

       

      Searching previous discussions didn't help much, so what am I doing wrong? I tried to lauch package.porter.exe from both 8.8 SP3 and SP2 versions, same error. Also there is no Method.Porter.exe file in none of these folders.