4 Replies Latest reply on Apr 13, 2010 4:49 AM by regentag

    Local boot is sometimes not longer the default option

    Rookie

      Hello,

       

      In a Landesk 9 environment, I had to disable some options in the PXE start menu in order to be able to access this menu on a new HP EliteBook 8740w. I disabled the Linux Options of the menu in the Registry of the Landesk Server and was then able to access the menu on the new machine (as already mentioned in different articles on that forum).

       

      My problem is now that for an unknown reason, some of my PCs do no longer have the default "Local Boot" option set but start the "Managed Windows PE" option instead. This is a problem because our PCs are set to boot using the NIC first and therefore our users see a Landesk environment instead of their Windows XP logon screen.

      This problem only seems to affect some PCs, so I do not understand what I should check for in other to repair it.

       

      Any idea ?

       

      Regards

      Nicolas

        • 1. Re: Local boot is sometimes not longer the default option
          Jared Barneck SupportEmployee

          The only reason Local Boot is not the default options is because the device or devices are in the PXE holding queue.

           

          You can get into the PXE holding queue three ways:

           

          1. In the Network View a device is dragged manually to the PXE Holding queue.  The device will boot to Managed Boot (I can't remember if the device is removed automatically from the holding queue upon successfully booting to Managed Boot or not.)
          2. In the Configure | Services | OSD a PXE Rep is added to the PXE holding queue (I am certain that every device that boots to this PXE Rep should boot to Managed boot successfully only once.  To get it to happen again, you have to reset the PXE Rep in the holding queue.)
          3. The device is part of an OSD task that has failed.

           

          There may be a fourth provisioning way now that I may be overlooking.

          • 2. Re: Local boot is sometimes not longer the default option
            Jack.rotherham Specialist

            You may also have a task thats been deleted but the PXE boot instructions are still stuck on your PXE Reps. To check and delete these do the following:

             

             

            1. Make note of the computers MAC address.
            2. Remote Control PXE Rep
            3. Open the following file: %program files%\landesk\pxe\system\pxeconfig.xml
            4. Delete the machine from the file.
            5. Restart PXE Service

             

            the PXEConfig.xml file will look along the lines of this:

             

             

            - <PXECONFIG>
            - <Lease>
            <<macaddr>XX:XX:XX:XX:XX:XX</macaddr>
            <<zone />
            <<bootimage>x86pc/undi/provwin/startrom.0</bootimage>
            <<tftphost>128.xxx.xxx.xxx</tftphost>
            <<config>XX:XX:XX:XX:XX:XX</config>
            </Lease>
            - <Lease>
            <<macaddr>XX:XX:XX:XX:XX:XX</macaddr>
            <<zone />
            <<bootimage>x86pc/undi/provwin/startrom.0</bootimage>
            <<tftphost>128.xxx.xxx.xxx</tftphost>
            <<config>XX:XX:XX:XX:XX:XX</config>
            </Lease>
            Just delete the PC information between the <lease> </lease> tags.
            • 3. Re: Local boot is sometimes not longer the default option
              Jared Barneck SupportEmployee

              Thanks Jack. That is the provisioning method that is the fourth way that I couldn't remember off the top of my head.

              • 4. Re: Local boot is sometimes not longer the default option
                Rookie

                It was number 1...

                 

                The funny thing: these machines were probably there for a long time but did only react like that since I deleted the pxe menu entries.

                 

                Thanks a lot