4 Replies Latest reply on Dec 18, 2007 1:53 AM by phoffmann

    Multiple Reboots in WINPE

    Apprentice

       

      Is there a way without using provisioning to have Multiple reboots during a WINPE OSD Script? There was a way with DOS OSD scripts by typing PXEqueue=Pending.. Does this still apply?

       

       

       

      Thanks in Advance!

       

       

       

       

       

       

       

       

        • 1. Re: Multiple Reboots in WINPE
          phoffmann SupportEmployee

          The "PXEQUEUE=PENDING" command still exists, but it exclusively works for DOS - I've tried to get things into a WinPE thing, but not figured it out yet (but that was just something I did 'for the heck of it' when 8.7 came out). I.E. if you use the PXEQUEUE... stuff, you'll automatically get thrown into a "Managed DOS"-boot (which would most likely break your WinPE script.

           

          Since there's  actually someone interested in this sort of feature, I'd suggest logging a case with your region's LANDesk Support, and logging this as an Enhancement Request (it is a good one after all).

           

          Indicate what you want to do / are trying to accomplish, so that we understand the context. I've never "needed" this to-date, as WinPE does not suffer from the plethora of limitations that DOS does, so understanding context will be important to us in order to get the enhancement logged properly.

           

          Regards,

           

          - Paul Hoffmann

          LANDesk Technical Lead EMEA

          • 2. Re: Multiple Reboots in WINPE
            Jared Barneck SupportEmployee

            I tested this and in 8.7 SP4 it works great for me.  I have never tested this before. 

             

            Here is what I did.

             

            1. Open the LANDesk Console on the Core Server.

             

            2. Go to Tools | Distribution | OS Deployment

             

            3. Click on the third icon: Validate licenses.

            NOTE: I am not going to have you try to validate the licenses; instead for some reason this is where you setup your default PE environment.

             

            4.  Make sure the default PE environement is set to WinPE. (Mine was already set to WinPE.

            Note: If you don't see this setting, maybe you need a later service pack?

             

            5. Here is my test script starting with the BEGINWINPE=TRUE

             

            BEGINWINPE=TRUE
            REMPING21=WINPE, TIMEOUT=1800
            REMEXEC22=drvmap.exe Domain\user 102F1285DEAB77577E04F627A31 I: <qt/>\\server\share<qt/>, STATUS FACILITY=3513
            REMEXEC23=drvmap.exe Domain\user 102F1285DEAB77577E04F627A31 H: <qt/>\\server\share<qt/>, STATUS FACILITY=3513
            REMEXEC24=diskpart /s X:\LDClient\wipeDisk0.txt
            PXEQUEUE25=PENDING
            REMEXEC26=cmd /c format /Y /FS:NTFS /Q /V:C-DRIVE c:
            REMEXEC27=reboot
            REMPING28=WINPE, TIMEOUT=1800
            PXEQUEUE29=OUT
            REMEXEC30=drvmap.exe Domain\user 102F1285DEAB77577E04F627A31 I: <qt/>\\server\share<qt/>, STATUS FACILITY=3513
            REMEXEC31=drvmap.exe Domain\user 102F1285DEAB77577E04F627A31 H: <qt/>\\server\share<qt/>, STATUS FACILITY=3513
            REMEXEC42=reboot, timeout=2 
            

             

             

            Anyway, that worked for me

            • 3. Re: Multiple Reboots in WINPE
              Apprentice

               

              Thanks guys for your answers.

               

               

              I will try out the WINPE script.. Im going to look  torwards Provisioning anyways.. Im sure in the future this will replace OS Deployment anyways..

               

               

                 

               

               

              • 4. Re: Multiple Reboots in WINPE
                phoffmann SupportEmployee

                Yes, that would explain why it would not work for me - my default is usually set to DOS. (I was also trying fancy stuff like DosPE -&gt; WinPE -&gt; DosPE -&gt; Linux at the time)"Doh" as the artist would say.

                 

                Since there's only a single "in/out" flag (so to speak), it'll always boot (or - respectively not boot) the client into the default PE-environment you chose. The fine detail I'd overlooked many months ago. Good catch rhyous :).

                 

                So - while you can't "hop" between the PE-environments, setting the default PE behaviour is what will allow this trick to happen.

                 

                Paul Hoffmann

                LANDesk EMEA Technical Lead