2 Replies Latest reply on Apr 26, 2010 10:33 AM by raypaton

    IIS 7 Configuration / LDMS 9

    Rookie

      We currently host 11,000 laptops in our educational institution and utilize LANDesk to deploy our software.  For the last 4 years we have used UNC shares but as we now have a new server and will be setting up LDMS 9 on it, we would like to use HTTP shares.  The problem is, since students are accessing the software we cannot enable "Anonymous Access" in IIS 7 for the package share as this would open our software up to everyone.

       

      We currently have 1 Core server, 1 SQL Server, and a dedicated Software Server that hosts the packages and nothing else.  I have Windows Authentication enabled but anonymous access disabled and when I try to create a Distribution Package, it fails with the 401 authentication error.  When Anonymous Access is enabled everything works fine.

       

      Any assistance would be greatly appreciated on this.

        • 1. Re: IIS 7 Configuration / LDMS 9
          zman Master

          Use preferred server and configure the share to let the preferred server account have read access. Make sure you test credentials. I think this may work.

          1 of 1 people found this helpful
          • 2. Re: IIS 7 Configuration / LDMS 9
            Rookie

            That allowed me to access the directory through the LANDesk console and setup a distribution task but once it was scheduled and I tried to install it on the client it fails due to "Failed to download all additional files for a package".  When I try to go back into the Distribution Package I once again get the 401 authorization error and have to close the console and reopen to get access again to the package share.  That really makes me wonder what is going on because I'm not changing anything to do with permissions and all of a sudden I'm blocked.

             

            This is a test package for a FileZilla msi so there are no additional files to be downloaded either.