14 Replies Latest reply on Jun 21, 2010 10:22 AM by kunkim

    deploying mpkg.zip

    Apprentice

      Hi all,

       

      i have Landesk V9 installed.

      Now Im trying to deploy a packge to a 10.5 mac.

      I recieve allway the error code 105, the files can't be downloaded.

      So try to open a browser on the target system and download the files by hand without any problem. That is also the same path in the distribution package.

       

      Can anyone help me please?

       

      thanks in advance

        • 1. Re: deploying mpkg.zip
          SupportEmployee

          What version of the Mac agent are you using? Do you have the feb mini rollup and mac rollup installed? Is the agent the latest version? What kind of SWD task are you doing (Policy/Push)? Is the package location open to everyone? Is any part of the file being downloaded (check ../LANDesk/sdcache). Does the landesk.log show any errors?

          • 2. Re: deploying mpkg.zip
            JBnCO Apprentice

            Homermg,

             

            I have been getting the same error except on a 10.6 Mac.  I have not seen this on my 10.5 clients.  It occurs as soon as the agent is deployed and doesn't correct itself unless you redeploy the agent to the client, even after a reboot

             

            Snowman,

             

            Here are the patches/rollups I have installed:

             

            LD-90-Mac-Rollup-02-10

            LD-90-Rollup-02-10

            CR42522 - UserManagement.Business.dll

            CR44271 - Datamart.xml

            CR43638 - _DiscDll.dll (UDD scann patch)

             

            Type of push:

             

            Push: I get return code 105 - Error downloading package

            Policy - I get return code 16386 - Failed to install package

             

            Everyone has access to the http share.  The same package works on other machines or the same machine after a reinstall of the agent

             

            The file does get downloaded but when I try to open the extracted mpkg file, I get an error "Couldn't open "*.mpkg"."

             

            LANDesk.log has the following errors after the "CheckSpaceForInstall is ok!" statement:  sdclient : execute: '/usr/sbin/installer - allow -pkg '/%path to package%' -target "/" ' result =1

            sdclient Final result = 1

            • 3. Re: deploying mpkg.zip
              JBnCO Apprentice

              Just a follow up to previous post.  It appears to install the mpkg correctly.  The two files that get layed down are present even though LANDesk is reporting a failure.

              • 4. Re: deploying mpkg.zip
                Apprentice

                Hi Snowman,

                 

                Mac agent version: 9.0.1

                what is feb rollup?

                it is the latest version

                im trying with push and policy

                 

                Landesk.log:

                execute: '/usr/sbin/installer -allow -pkg '/Library/Application Support/LANDesk/sdcache/Sophos Anti-Virus.mpkg' -target "/"' result=1

                 

                thanks in advance

                • 5. Re: deploying mpkg.zip
                  SupportEmployee

                  How are you packaging your mpkg? Keep in mind that windows machines see pkg and mpkg files as folders and so they mess up their permissions so they need to be packaged (zip, dmg, etc) before putting them on a windows box.

                   

                  I just went out to the web and grabbed a mpkg file (I try to use different packages whenever I can). The first one I found was lightwright 5. I put the mpkg in a zip file and deployed it to 10.5 from my LD9 core without error. Is this happening to you with all your mpkg files or just one in particular?

                  • 6. Re: deploying mpkg.zip
                    Apprentice

                    Good morning Snowman

                     

                    The file was packged in a zip file.

                     

                    one thing seems to be strange if i open the cashe folder the file seems to have not enough rights. see the attachment.

                    The agnet is downloading the file, unpack the file and then is nothging happens.

                     

                    I have to say, we have severel sites(subnets). So the core is on subnet A und the clients where I trying to deploy the mpkg is on the subnet B.

                    We have installed a preferred server on subnet B and prepared the core to use it.

                    My fist step was to deploy a msi to win clients in this subnet.(I also used the direct path to the preferred server in the packge wizzard on landesk core, just for first testings). This step was successful.

                    The next step i wanted to do is deploying to a mac client.

                    For both steps I'm using a http path.

                     

                    Any idea?

                    • 7. Re: deploying mpkg.zip
                      SupportEmployee

                      From your screenshot it looks like your mpkg is messed up as it has a folder icon and the folder name has .mpkg in the name. It should have the same icon as the pkg file in your picture. If you download it manually to the client via http and unzip it does it look like a pkg file or does it still show up as a folder? Usually when mpkg files show up by folders it is because they were on a windows machine and had the permissions messed up.

                      • 8. Re: deploying mpkg.zip
                        SupportEmployee

                        I just downloaded Sohpos Endpoint Security and Control for Mac 7.1 Stand Alone and Network Edition. They both came down as DMG files that have the mpkg inside them probably so if you download them on a windows machine the mpkg file doesn't get messed up. I threw the dmg on a perferred server and deployed it via policy and it installed without error. I think you really need to look at your mpkg file. Maybe download the dmg from Sophos again and deploy it in the dmg.

                        • 9. Re: deploying mpkg.zip
                          Apprentice

                          Hi Snowman,

                           

                          unfortunately i have still the same issue: Error downloading package: Return Code 105

                          Today i see nothing in in sdcache :-(

                          nothing is downloaded by the agent on mac.

                           

                          Now i have tried some other apps like cyberduck.zip und Stuffit11Deluxe.dmg.

                           

                          Any idea how i can find out where the problem is?

                          • 10. Re: deploying mpkg.zip
                            Apprentice

                            Now i have installed the software to an other mac and it was installed seccefully.

                            So i hope that is only this client which is failling.

                             

                             

                            Thanks Snowman!

                            • 11. Re: deploying mpkg.zip
                              JBnCO Apprentice

                              Homermg,

                               

                              I saw the same thing yesterday.  On my Snow Leopard machine, it failed each time with 105 - error downloading package with a push and 16386 - failed to install package with a policy or policy supported push.  When pushed to my Leopard machine, the install completes without error.

                              • 12. Re: deploying mpkg.zip
                                Apprentice

                                JbnCO,

                                 

                                now i have reinstalled the agent on this mac and now everything works fine!

                                So try to install the agent again.

                                • 13. Re: deploying mpkg.zip
                                  JBnCO Apprentice

                                  Homermg,

                                   

                                  Thanks for the info.  I have tried that in the past and it has worked but yesterday I reinstalled the agent (and also wiped the agent off the box and did a fresh install) and still getting errors.  I'm going to try again this morning to see if there is any change.

                                  • 14. Re: deploying mpkg.zip
                                    Rookie

                                    I'm getting the same 105 error on Snow Leopard or constant hash errors even though I didn't change the package settings.