13 Replies Latest reply on Dec 30, 2007 1:24 PM by jbsaxman

    Provisioning task stuck

    Rookie

       

      I have a provisioning task that is stuck on the reboot.  When I go into looking at the results of the provisioning history all of the tasks before the reboot come back with the green checkmark, but the reboot command has a small green box and a computer with a ? next to it.

       

       

      The reboot command is in the post-os installation section.  Basically we are doing an unintended install from the I386 directory and when we tell the machine to reboot into the native OS so that we can get to the system configuration stage, the reboot never sends back a status and so it just sits there waiting for a reply.  Meanwhile the OS has completely installed and is booted up ready to continue.

       

       

      I have a case open with LANDesk but was curious if anybody else saw this behavior?  I am hoping that when the scripted install is fixed with version 8.8 that we won't have these issues, because in order to get the OS to install we had to use the execute a file command and I am not sure if that is where our problems are coming from.

       

       

      Any help would be appreciated.

       

       

      BTW this is for a Windows 2003 server on a Dell 2650.

       

       

        • 1. Re: Provisioning task stuck
          Jared Barneck SupportEmployee

           

          After the reboot it should go to WinPE to start the unattended installation, unless you are somehow starting it while in windows.

           

           

          As soon as it hits WinPE the reboot should be done.  

           

           

          Is this how you are doing it?

           

           

          • 2. Re: Provisioning task stuck
            Jared Barneck SupportEmployee

            The reboot command is in the post-os installation section.

             

            I misread...the reboot is in the WinPE section (Post-OS).

             

            So are you running the "Configure Target OS" action before the reboot.  Otherwise, the target OS won't be configured to use the provisioning agent when it boots up.

            • 3. Re: Provisioning task stuck
              Rookie

              I have tried it many different ways and no matter where I put the reboot statement it always comes back as waiting for a response.

              • 4. Re: Provisioning task stuck
                Tracy Expert

                 

                When the OS comes back up and is just waiting..... can you browse the filesystem and verify that the Provisioning agent was copied (I forget the actual location. I think it is LDProvision or something). If that is not there, you need to properly configure the CTOS (configure target OS) as Rhyous said. If that is not done, the machine can't continue after reboot because it has no Provisioning agent and doesn't know it is supposed to do anything else.

                 

                 

                 

                 

                 

                -Tracy

                 

                 

                • 5. Re: Provisioning task stuck
                  Rookie

                  I just kicked off another OS deployment, when it is done I will log on and check to see if the provisioning  agent was copied over or not.  In the meantime is there anything else I can provide that may help in troubleshooting?  Screenshots of my template or the XML file?

                  • 6. Re: Provisioning task stuck
                    Rookie

                     

                    I have a provisioning folder under c:\windows - but there are no files inside the provisioning folder just a subfolder called schemas with a bunch of.XDR files.  Is there some other place that I should be looking?

                     

                     

                    Attached is a screenshot of the results.

                     

                     

                     

                     

                     

                    • 7. Re: Provisioning task stuck
                      Tracy Expert

                       

                      Hmmm. Not really sure. It has been a while since I did anything with Provisioning. That folder should get cleaned up (deleted) after the task has completed. So either way, it is missing files and preventing the task from completing, or it thinks it completed and did not properly clean up the Provisioning files. What I would try next is to run the job and not have it reboot. That way you can see if all the files were copied as part of the "configure target os" before the reboot. If you still have no files except for the subdir, then we can look at that.

                       

                       

                      -Tracy

                       

                       

                      • 8. Re: Provisioning task stuck
                        Rookie

                         

                        This is what I get when I take the reboot out :

                         

                         

                         

                         

                         

                        error 80001806H

                         

                         

                        The next template action cannot run in the pre-boot environment reboot the device into the target operating system to continue running the template or edit template to reposition the action

                         

                         

                        That comes up after the configure os part (completed successfully)

                         

                         

                        • 9. Re: Provisioning task stuck
                          Tracy Expert

                           

                          Are you by chance deploying Vista? http://forum.landesk.com/showthread.php?t=11340

                           

                           

                           

                           

                           

                          -Tracy

                           

                           

                          • 10. Re: Provisioning task stuck
                            Rookie

                            Nope, Windows 2003 server on a Dell 2650.

                            • 11. Re: Provisioning task stuck
                              Jared Barneck SupportEmployee

                              While it says that the "Configure Target OS" action completed successfully, are all the files there.  It seems to me that it is breaking at this point by saying successful even though it is not properly configuring the target OS.

                               

                              At this point in WinPE, after the "Configure Target OS" action, do you have all your provisioning files on the new drive where they should be?

                              • 12. Re: Provisioning task stuck
                                Rookie

                                 

                                I am not sure because there is no operating system installed.  This error message actually occurs inside of the Windows PE environment, in the dos box.  It basically copied over all of the installation files but did not perform the reboot to do the actual Windows install. 

                                 

                                 

                                • 13. Re: Provisioning task stuck
                                  Employee

                                   

                                  The installation of Windows should automatically call the reboot.  You shouldn't need to have an action that calls the reboot.  Are you copying over the i386 directory and then calling 'Winnt32.exe /syspart:c: /unattend:c:\unattend.txt'?