1 2 Previous Next 15 Replies Latest reply on Jan 8, 2008 4:34 PM by ryse

    PXE Boot - Force WINPE Menu - On Timeout

    Apprentice

      Hi guys..

       

       

       

       

       

      How can I force the PXE rep to select WINPE MENU instead of local boot on a time out.. I saw some registry settings on the PXE rep to take away menu options but nothing on how to select which menu item is the default. We are working on a migration and would like to set this as default for the duration of the migration. Right now we are pressing F8 every time.

       

       

       

       

       

       

       

      In case anyone was wondering we are not using the holding que for a reason.. These are laptop carts.. 30 per cart.

       

       

       

       

       

       

       

      Thanks in advance!!

        • 1. Re: PXE Boot - Force WINPE Menu - On Timeout
          Employee

          To my knowledge there is not a way to force the client to boot to the network on all machines. I think the boot ROM, in general, is hard coded to default back to local boot.

           

          After doing a bit of research, I do know that some Dell machines have an option in the BIOS to tell it to only boot from network, but whereas LANDesk uses several Boot menu items, I would imagine that it would make it difficult to force it to boot to one menu over another.  I have poured over the PXEConfig.exe utility and can't see any way to change the order in which the menu items are displayed.

          • 2. Re: PXE Boot - Force WINPE Menu - On Timeout
            Jared Barneck SupportEmployee

             

            It takes a HACK but it can be done.

             

             

            1. Use the PXE Holding Queue.  (I know that it only works with WinPE managed boot, I will get to how to bypass that.)

             

             

            To do this, put the PXE Rep in the Holding queue.

             

             

            Now each device will be told to boot to Managed WinPE.  This only really happens once for each device and then subsequent boots will not do this unless you reset the holding queue.

             

             

            2.  On the PXE Rep change the WinPE Managed boot to actually bring up the menu.  This is so easy to do.  Just copy the winnt.sif from the wpemenu folder to the winpe folder on the PXE Rep.  The difference between WinPE Menu and Managed WinPE is nothing more than this file.

             

             

            Copy this file:

             

             

            c:\program files\LANDesk\PXE\System\Images\X86PC\Undi\wpemenu\winnt.sif

             

             

            to this location:

             

             

            C:\program files\LANDesk\PXE\System\Images\X86PC\Undi\winpe\winnt.sif

             

             

            Now the WinPE managed boot will actually bring up the Menu.

             

             

            So now you have hacked the PXE Rep to have each machine boot one time to the Managed WinPE (which actually now brings up the menu)

             

             

            • 3. Re: PXE Boot - Force WINPE Menu - On Timeout
              Employee

              Good call.  I didn't even think about it from that perspective.

               

              I just tested it and it seems to work like a champ in my lab.

              • 4. Re: PXE Boot - Force WINPE Menu - On Timeout
                Apprentice

                 

                Thanks for the replies! Im going to try that out now.. The only other issue we are having is when multiple machines are hitting the PXEREP at one time we get the peboot.img error which i think is due to packet loss.. Jared I know you mentioned that a different TFTP server might help.. Are there any settings which can be changed on the LANDesk PXE rep which will help the TFTP transfers??

                 

                 

                 

                 

                 

                I saw this article you posted a while back..  http://www.droppedpackets.org/Members/rhyous/osd/pxe-representative/disabling-the-built-in-tftp-server/

                 

                 

                Although im to to sure how to proceed.. I downloaded solorwinds tftp server and I was going to mess with that.  How exactly does the new TFTP server know which image to transfer based on what a user selects??

                 

                 

                Thanks. 

                 

                 

                • 5. Re: PXE Boot - Force WINPE Menu - On Timeout
                  Jared Barneck SupportEmployee

                  The TFTP server doesn't have to know more than one thing:  What is the root TFTP directory.

                   

                  The Root TFTP directory should be this directory:

                  c:\program files\landesk\pxe\system\images

                  Everything should be taken care of automagically.

                   

                  So run PXEConfig.exe and check the box to disable the built-in TFTP server.

                   

                  Add any other TFTP server you want to try but just make sure that the root directory is correct.

                  • 6. Re: PXE Boot - Force WINPE Menu - On Timeout
                    Apprentice

                     

                    Thanks alot! The holding que idea worked great!!

                     

                     

                     

                     

                     

                    Im going to change the TFTP server and Try and boot all 30 machines at one time again and see if I recieve the same error. I'll post with an update.

                     

                     

                     

                     

                     

                    • 7. Re: PXE Boot - Force WINPE Menu - On Timeout
                      Jared Barneck SupportEmployee

                      I had a Partner who had to get 30 machines to PXE boot simultaneously but couldn't with our TFTP server or any free ones we tried.

                       

                      I think he ended up buying the customer a copy of a TFTP server.  The said that TFTPD32 and other free ones they tried didn't work.  I think they bought one from WinAgents, but I don't remember.

                      • 8. Re: PXE Boot - Force WINPE Menu - On Timeout
                        Apprentice

                        I didn't see your last reply.. Well if we pace our selves during the pxe boot process it works fine.. Its when doing it all at once..

                         

                         

                         

                         

                         

                         

                         

                         

                         

                        The TFTP download is failing with the new TFTP server..  It says could not find NTLDR its looking for this file in the images directory which it does not exist. Shouldnt the PXEconfig forward the request to the correct undi folder?

                         

                         

                         

                         

                         

                         

                         

                        Thanks..

                        • 9. Re: PXE Boot - Force WINPE Menu - On Timeout
                          Jared Barneck SupportEmployee

                          It should be requesting the file from the same folder that the Startrom.0 file is in.

                           

                          From the TFTP root, the path is:

                           

                          x86pc\Undi\winpe\NTLDR

                           

                          I just tried this with TFTPD32 (with only one client) and it works and the log shows the request for the NTLDR using the correct path:

                           

                          x86pc\Undi\winpe\NTLDR

                          • 10. Re: PXE Boot - Force WINPE Menu - On Timeout
                            Jared Barneck SupportEmployee

                            Also, check the log file.  Are you seeing the request for the file using the correct path.

                             

                            I am not sure where the log of you TFTP server is, I haven't really used it.

                            • 11. Re: PXE Boot - Force WINPE Menu - On Timeout
                              Apprentice

                              The TFTPD32 program worked well.. I guess it was the TFTP software I was using.. I wonder is there a registry key for the stop TFTP check box in the PXECONFIG. prog.. Im thinking on how to build a custom pxe package which will install TFTPD32 as part of the pxe rep..

                               

                              All 30 worked fine.. The Download slows down but that was expected..

                               

                               

                               

                              Thanks for the recommendation.

                              • 12. Re: PXE Boot - Force WINPE Menu - On Timeout
                                Apprentice

                                The problem im seeing with the pxe rep being in the holding que is after the imaging test some of them are booting local boot and the other half are going to managed boot.. It seems as if it does not send an update to the core in time.. Is there an SDCLIENT command or something that we need to send to the core to tell it to take a machine out of the holding que?

                                 

                                Is there a pxerepconfig.XML file  that the core looks at to keep track of which machines should and should not be in the holding que?

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                 

                                Thanks for your help =)

                                • 13. Re: PXE Boot - Force WINPE Menu - On Timeout
                                  Jared Barneck SupportEmployee

                                  There is a registry key for that.

                                   

                                  HKLM\Software\Intel\PXE\ProxyDHCP\StopTftp

                                   

                                  However, you can do it better than changing the registry key after the install.  Change it during the install.  Simply edit the OSDRep.msi with Orca and change that to off, and generate a transform.  Then create a PXE Representative deployment script that uses the transform file.

                                  • 14. Re: PXE Boot - Force WINPE Menu - On Timeout
                                    Jared Barneck SupportEmployee

                                    By the way, good to know that TFTPD32 now works.

                                     

                                    We tried it way back when (about 1.5 years ago) and it failed on just over 20 clients, but TFTPD32 has been through a lot of updates since then and maybe it is more stable now.

                                    1 2 Previous Next