10 Replies Latest reply on Jul 13, 2013 9:20 AM by JSMCPN

    WinPE: Could not resolve core server name

    Apprentice

      I'm attempting to Provision a machine here in our new LDMS9 environment and I'm having an issue with resolving our core server name. Any suggestions on this?

        • 1. Re: WinPE: Could not resolve core server name
          EMiranda Expert

          can you ping the core from WinPE when it is trying to provision or in the OS when it is trying to provision...

           

          try using FQDN?

          • 2. Re: WinPE: Could not resolve core server name
            Apprentice

            I'm not even getting to the Provisioning GUI. The boot.wim is loaded and the PE Environment begins to load. It attempts to contact the core and fails.

             

            I did try a few pings at this point.

             

            1) To the Core Server Name - No luck

             

            2) To the IP of the Server - Success

             

            3) To the FQDN - Success

            • 3. Re: WinPE: Could not resolve core server name
              Rookie

              I apologize if this is posted somewhere obvious and I'm missing it but where is this setting changed?

               

              We are experiencing similar issues (WinPE loads but presents no template selection screen) and I want to verify we are using the FQDN.

              • 4. Re: WinPE: Could not resolve core server name
                Apprentice

                Here is a little bit of what I know from all my testing and learning of DNS structure.

                 

                From within the WinPE environment a ping is made out to your core's hostname. (Host name only)  This will get resolved if your core is within the same DNS Search Suffix as what is assigned to the DHCP Scope you are on. In my case, our core server has a different DNS Search Suffix than what my DHCP scope in the PXE environment was giving out. Because of that, I couldn't resolve hostnames in that domain. Another issue is that DHCP Scope options only allow you to assign one DNS Search Suffix per scope. With that said, I needed to open up the boot.wim image and edit the host file to have entries for my core server. After that, resolution was flawless.

                 

                I hope this helps and isn't too confusing.

                • 5. Re: WinPE: Could not resolve core server name
                  EMiranda Expert

                  to add, if indeed you need FQDN to access the core.

                   

                  Modifying hostfile will work as Paul stated and you can also modify the ALL.Reg which stores your core server name and just add the FQDN to it.

                   

                  when you open the ALL.Reg (Windows\System32) modify this part:

                   

                  Windows Registry Editor Version 5.00

                  [HKEY_LOCAL_MACHINE\SOFTWARE\Intel\LANDesk\LDWM]
                  "CoreServer"="Corename.fqdn.com"
                  "InventoryServerPort"="5007"
                  • 6. Re: WinPE: Could not resolve core server name
                    Rookie

                    I have been having the same problem. I have edited the ALL.REG located in "C:\Program Files (x86)\LANDesk\ManagementSuite\landesk\vboot" to show the FQDN. However, it appears that when I schedule the upload of an image, it is still using the "old" file which did NOT have the FQDN.

                     

                    We are not using any PXE Representitives as far as I know (any way to view if there are any setup?). How can I force the Core server to push down the most updated versions of the files in that directory?

                     

                    P.S. - I have not edited the boot.wim yet.

                     

                    Any help is appreciated!

                     

                    Thanks!

                    • 7. Re: WinPE: Could not resolve core server name
                      EMiranda Expert

                      when you schedule an upload of the image, it is still loading boot.wim.  You will need to open up the boot.wim and modify the all.reg that is in .wim file for the changes to the FQDN to go through in WinPE when it is starting to image.

                      • 8. Re: WinPE: Could not resolve core server name
                        Apprentice

                        Stoj

                        The problem is WinPE's paired down network solution does not properly walk the DNS like a full blown Windows build. So even if you do put the FQDN in there it is still not always going to findthe device that you are looking for. In fact I was unable to use provisioning in release 9.5 because my hybrid DNS solution cannot be seen by the default settings in WinPE.

                        So... the fix: Best to do this on the core (IMHO)

                        1) Go to your operating System Deployment window and click on the "Manage the Windows Drivers in the PE" icon

                        2) Once that thing opens you will need to open the run command in the Start menu and type in %temp% and hit enter

                        3) Drill down to the IMGTMP folder and then further down to the Windows folder.

                           - Location is C:\Users\<YerNameHere>\AppData\Local\Temp\imgtmp\Apply\Windows\System32

                        4) Look for a file called ALL.REG

                        5) Edit that file -Notepad I my fave

                        6) Add the following below what is already there

                        [HKEY_Local_Machine\System\CurrentControlSet\Services\TCPIP\Parameters]

                        "SearchList" = "YourDomain.com,Internal.YourDomain.com,SomeOtherPlace.com"

                        NOTE: You need to substitute in the real names that you use for those bogus names I made above

                        7) Save the file and close the Windows Exploder so that nothing relating to that folder is open

                        8) Add a driver of some kind to the Manage Windows Driver window and name it Bogus Driver

                        9) Save that by clicking Finish

                        10) Once all of that is saved you need to go back in and open the "Manage the Windows Drivers in the PE" window again so that you can REMOVE that bogus driver.

                        ** NOTE ** The reason to add the bogus driver is that unless you add something your changes will not be saved out to your WIM file

                        11) Close the window and finish once you have removed the bogus driver

                        12) Redeploy the PXE server(s) as needed

                        You now have the ability to ping the server name without FQDN and you can find things in all of your DNS search domains.

                        Enjoy...

                        • 9. Re: WinPE: Could not resolve core server name
                          Apprentice

                          Whenever you edit the BOOT.WIM on the core you need to remember - You are on the core".

                           

                             Your devices are booting their WIM from the PXE reps - ALWAYS redeploy PXE reps after maintaining the core BOOT. WIM.

                           

                              WARNING: Send it to one and test it first. It really bites to deploy a WIM file out that is not correct.

                          • 10. Re: WinPE: Could not resolve core server name
                            JSMCPN Expert

                            That's a great tip!