5 Replies Latest reply on Jun 17, 2010 8:41 AM by brandonhyde

    Provisioning - Stuck in WinPE after CTOS Runs (v9)


      Hey everyone,


      I have a very strange issue going on with provisioning in LANDesk 9 that I'm trying to figure out.  Basically what's happening is some machines are getting stuck in WinPE after CTOS runs.  CTOS will run and reboot the machine...and instead of the machine booting into Windows and starting sysprep, the machine will boot back into WinPE (via PXE) and then set there because there aren't any actions left to complete.  I'd say this happens on 40-60% of the machines I try to provision at any given time.


      Any help would be great.



        • 1. Re: Provisioning - Stuck in WinPE after CTOS Runs (v9)

          This indicates that there is a problem with the PXE reps getting an updated list of who needs to be in WinPE and who needs to be in Windows for a provisioning task.  Do you have a lot of PXE reps in your environment, because that definitely makes this problem worse.


          The good news is that the behavior that causes this problem is totally changed in SP1.  It will mimic the behavior used by OSD to know who to PXE Boot.  It's a lot more scalable and stable, so in essence SP1 should make this whole problem go away.


          In the meantime you can delete the file pxeconfig.xml from the PXE reps to clear their status.  The next time a provisioning task is run it will be recreated, so there's not any real problem doing that.

          1 of 1 people found this helpful
          • 2. Re: Provisioning - Stuck in WinPE after CTOS Runs (v9)

            Thanks for the quick reply!


            We're using one PXE rep per subnet.  I'll give your idea a shot and let you know if it helps.  The only thing I'm a little concerned about is that this is happening now even though we just start playing around with Provisioning.  Am I going to have to delete that file before every Provisioning task I run?  That would not be cool!

            • 3. Re: Provisioning - Stuck in WinPE after CTOS Runs (v9)

              If there is a legitimate long term problem getting that file correctly updated from the core then we would want to spend some time tracking down why it's a problem and get it fixed.  However, since SP1 will make any troubleshooting we do a total loss, because it won't even act remotely the same, I would recommend simply removing the xml for now, and see if you can get it going for the couple of weeks until SP1 releases.


              This change is one of the improvements I'm most looking forward to in SP1.  It, and a few other tweaks to provisioning, will make it a lot more robust, as well as improve speed and scalability.  All in all it's a great change.  Of course, that doesn't help you now, but hopefully it gives you a light at the end of the tunnel.


              Let me know if the problem returns fairly quickly, or if it seems to gradually grow over time.  I guess it's even possible it was simply a bad state you were in and now it will be gone, but I think that's pretty unlikely with how many devices you had doing that.

              • 4. Re: Provisioning - Stuck in WinPE after CTOS Runs (v9)

                I really appreciate the info.  I didn't realize SP1 was so close.  Odds are we'll still be in the testing phase by the time it comes out, so we should be good to go.


                Thanks again!

                • 5. Re: Provisioning - Stuck in WinPE after CTOS Runs (v9)

                  Unfortunately, this didn't work.  I deleted the file on all of my PXE reps and then tried to provision 4 machines.  2 of the 4 got stuck in WinPE after rebooting from CTOS.  One of them I rebooted and then it started sysprep.  The other kept going into WinPE no matter how many times I rebooted.