1 Reply Latest reply on Jun 30, 2010 7:05 AM by jelmerj

    ldpatch not working when noone is logged in

    Rookie

      Hello,

       

      I was trying to install Mac OS X 10.6.4 on some machines. I tried to fire up the security scanning progress from the LANDesk console, and for some reason a few machines did not turn up in the list of macs that needed the patch.

      So I logged in with ssh and tried to fire up ldpatch manually. That resulted in a stack trace unfortunately. Google showed that people with a similar error were all developing some kind of GUI elements, so I started trying some things....and it turns out that ldpatch won't run without a user logged in!

      Can anyone confirm this? Is this a known issue? And above all: is there a solution?

       

      For completeness I'll add the stack trace below.

      Regards,

       

      Jelmer Jaarsma

       

       

       

      2010-06-17 17:06:31.231 ldpatch[675:903] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Error (1002) creating CGSWindow'
      *** Call stack at first throw:
      (
              0   CoreFoundation                      0x995e4bda __raiseError + 410
              1   libobjc.A.dylib                     0x95086509 objc_exception_throw + 56
              2   CoreFoundation                      0x995e4908 +[NSException raise:format:arguments:] + 136
              3   CoreFoundation                      0x995e487a +[NSException raise:format:] + 58
              4   AppKit                              0x974f833e _NSCreateWindowWithOpaqueShape2 + 519
              5   AppKit                              0x9747d256 -[NSWindow _commonAwake] + 1624
              6   AppKit                              0x97479f16 -[NSWindow _commonInitFrame:styleMask:backing:defer:] + 1524
              7   AppKit                              0x97478b65 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1568
              8   AppKit                              0x9747853f -[NSWindow initWithContentRect:styleMask:backing:defer:] + 71
              9   AppKit                              0x974f71c2 -[NSWindowTemplate nibInstantiate] + 588
              10  AppKit                              0x974683f4 -[NSIBObjectData instantiateObject:] + 253
              11  AppKit                              0x974676fa -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 336
              12  AppKit                              0x97465ba0 loadNib + 257
              13  AppKit                              0x974651f4 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 831
              14  AppKit                              0x97464eaa +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 158
              15  AppKit                              0x97464df5 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 383
              16  AppKit                              0x97461bf9 NSApplicationMain + 434
              17  ldpatch                             0x0001345e main + 52
              18  ldpatch                             0x000022d2 _start + 216
              19  ldpatch                             0x000021f9 start + 41
      )
      ./ldpatch: line 3:   675 Trace/BPT trap          /Library/Application\ Support/LANDesk/bin/ldpatch.app/Contents/MacOS/ldpatch $@

        • 1. Re: ldpatch not working when noone is logged in
          Rookie

          In the meanwhile we've received an official answer from LANDesk about this:

           

          Unfortunately patching on a Mac at this time must take place while a user is logged in. I completely understand this is not ideal as it prevents you from being able to patch at night, etc.

          I do know that the Mac agent is slated to be rebuilt in our next major release and currently removing the logged on dependency is a story being evaluated, but I cannot guarantee it will or will not make it in.

           

          Our support partner for LANDesk has created an enhancement request to improve on this: http://community.landesk.com/support/message/46920#46920