10 Replies Latest reply on Aug 30, 2011 2:37 PM by dgaines

    WinPE SATA driver for Lenovo M90

    Rookie

      We recently got a Lenovo M90 Machine Type: 5474 Model: B3G
      The WinPE doesn't automatically detect the SATA Driver for this type of machine so I always get a bluescreen at the startup.
      So I downloaded the following driver http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-74565 for "Intel Matrix Storage RAID driver for Windows XP - ThinkCentre M90, M90p / ThinkStation E20" from the Lenovo.com homepage.
      I tried to include both inf files iaahci.inf and iastor.inf but I still get a bluescreen in the winpe. The downloaded driver is for Windows Vista.

      I also tried to include the "Intel Matrix Storage Manager (Windows Interface Console) driver for Windows Vista (32-bit and 64-bit), XP (32-bit and 64-bit) - ThinkCentre M90, M90p / ThinkStation E20" http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-74688 but there is no *.inf file included.

       

      After including the drivers to the WinPE I redeployed the pxe image.

       

      The settings for the Bios are
      External SATA Port: enabled
      SATA Controller: enabled
      Configure SATA as: AHCI
      Hard Disk Pre-delay: disabled

       

      Also when I try to disable AHCI mode and configure as IDE I get a bluescreen in the WinPE.

       

      Has anybody such a problem before?

        • 1. Re: WinPE SATA driver for Lenovo M90
          Employee

          What error code does the bluescreen give?  WinPE shouldn't blue screen if it can't find the hard drive controller, it should tell you it can't find the hard drive.

           

          Knowing the blue screen error code would help a lot to find out what is going on.

          • 2. Re: WinPE SATA driver for Lenovo M90
            Rookie

            attached you'll find the picture of the bluescreen and the last message shown in the cmd before the bluescreen appers. I tried to change the video settings in the bios and also to make a bios update with lenovo system updater but there is no newer bios version available. Bios Date is 02/26/2010.

            Disable Bios memory options as mentioned in the message is also not possible because such a menu doesn't exist.

            • 3. Re: WinPE SATA driver for Lenovo M90
              Employee

              This issue is actually a known issue right now involving a file used to detect if the device is vPro capable, and if so to optionally use the AMT GUID as a device identifier for bare metal provisioning.

               

              I've never seen anyone actually use the AMT GUID for bare metal provisioning, so in every case I've seen it is not needed for provisioning to function.  The problem is that the new Lenovo hardware (and possibly others) are incompatible with our detection driver.  The driver is being updated to account for the new hardware.  In the meantime the workaround is to simply rename the driver so it won't be used.  It is on the core server in the ldlogon share and is called cismbios.sys.  If you rename that file to cismbios.bak, or anything else, then provisioning will function as designed, unless you are manually entering your devices as bare metal imports using the AMT GUID as the identifier.

               

              Try renaming that file and rerun your provisioning task.  This should allow your provisioning tasks to function while the driver is being updated.

               

              Let me know if this helps!

              • 4. Re: WinPE SATA driver for Lenovo M90
                Rookie

                Renaming the cismbios.sys file in the ldlogon directory was the solution. We are using MAC address identifier for bare metal provisioning, but in the bios Intel AMT Control is enabled on default.

                • 5. Re: WinPE SATA driver for Lenovo M90
                  Employee

                  Just a quick follow up on this:

                   

                  For LANDesk provisioning whether AMT/vPro is enabled or not doesn't matter for this workaround.  The issue is the same, and the workaround is the same regardless.  It doesn't have any impact at all.

                   

                  Also, for other people who run across this solution later, this is simply a workaround while the actual file (cismbios.sys) is being updated.  Once it's updated, there will be no need for the workaround.

                   

                   

                  Also, glad to hear it worked for you!

                  • 6. Re: WinPE SATA driver for Lenovo M90
                    Rookie

                    Mach6,

                         I am getting the blue screen upon LD client install. I have traced this back to the same file, that you have been talking to other users about. I get a blue screen message before the LDclient installation finishes. I assume this is attributed to the fact that the LD services spin up as they become available during the client installation process. Like you referenced in your post this is affecting the newer machines with the newer chipsets. We have intel vPro enabled chipsets(Lenovo M90p 3269-A6u ThinkCenter), which get hit with the BSOD as soon as the Landesk AMT detection driver is activated. When I rename the "offending" file as you suggest on the LD core server, I can not run a LDclient deployment task because it fails with the following error message: "Failed to build the agent installation package". Based on that error message the answer file that LDcore uses to build and push the LDclient seems to be compling based on specific file names. Any ideas how I can work around this until LanDesk comes out with a driver patch? Thanks for answering their posts, and any information you can provide would be greatly appreciated. Thanks

                     

                     

                    Cheers,

                         humbleme

                    • 7. Re: WinPE SATA driver for Lenovo M90
                      Rookie

                      I use Windows XP Pro with the last NVidia NVS              3100M driver (version 6.14.11.8955).

                      The problem persists.

                      • 8. Re: WinPE SATA driver for Lenovo M90
                        Rookie

                        Have you tried to rename the cismbios.sys file? This works fine for me.

                        • 9. Re: WinPE SATA driver for Lenovo M90
                          Rookie

                          I've try to rename cismbios.sys and then provisioning work fine

                          • 10. Re: WinPE SATA driver for Lenovo M90
                            dgaines Apprentice

                            Have there been any patches or anyrthing for this issue?