1 2 Previous Next 19 Replies Latest reply on Nov 16, 2011 9:28 AM by Fnurgg

    troubleshooting CTOS with Win7


      I am referencing the following document as I try to troubleshoot why my my image deployment provisioning template is hanging/failing at CTOS.


      Troubleshooting Configure Target OS action in Provisioning template


      found here:





      calling out some language in the document:


      "Files are injected to the root of the OS drive (C:\ldprovision) and commands are added to the appropriate files such that they are run during the mini-setup just prior to booting into the target OS."


      "The unattend.xml is modified and commands are added to call ldprovisioning.cmd from the C:\ldprovisioning directory"


      "Sections are added to the unattend.xml in the Specialize section. This is a special section of the unattend.xml that can also be used for things like setting the home page for Internet Explorer, etc. In this section, RunSynchronousCommand action is added calling ldprovisioning.cmd from C:\ldprovisioning\."



      This all leads me to believe that the CTOS part of the template will make ALL necessary changes to affect the launching of the provisioning agent once the system has booted into the new OS.  Said another way, I should not have to change anything-I just need to confirm that CTOS is in the template at the end of the Post-OS Installation portion of the template.  <- Please confirm this assumption.



      It also describes the CTOS action as this:



      When run, ldprovisioning.cmd installs the basic LANDesk CBA agent in C:\Program Files\LANDesk\LDClient and configures it as a service to start on OS boot. It also modifies the actions.ini file in C:\Program Files\LANDesk\Shared Files\cbaroot to contain a line pointing to C:\ldprovision\ldprovision.exe with the needed command line options. The actions.ini file is used by the LANDesk CBA agent as instructions when starting, so the commands contained therein are run when the service starts




      I have verified the presence of the ACTIONS.INI file in the appropriate folder, however the references to C:\LDPROVISION do not exist in the INI file.



      In further troubleshooting actions, the document suggests 3 things for Windows 7


      Windows Vista/2008/7

      1. Change to C:\ldprovisioning directory. Verify the ldprovisioning.cmd is in the folder and the folder is populated. It should contain over 20 files.
      2. Verify that the unattend.xml exists in C:\Windows\Panther
      3. Verify that the commands calling ldprovisioning.cmd exist in the unattend.xml for the platform (x86, amd64, ia64) you have deployed.


      These are supposed to be done in WinPE, but my machine has booted into WIn7 already.


      #1 can't be validated because the directory doesn't exist after Win7 boots; I can't say if it existed in WinPE

      #2 is validated

      #3 is validated, sort of; the command is in the unattend.xml doc, but it appears in the middle of the doc rather than towards the end as I expected.


      -Any thoughts on where the break down is?

        • 1. Re: troubleshooting CTOS with Win7

          using LDMS 9.0 and a copy of the Win7 provisioning template found here:



          • 2. Re: troubleshooting CTOS with Win7

            anyone with some pointers on CTOS failure with Win7???



            I'm still timing out on this part of my provisioning template and can go no further with my troubleshooting without some additional direction.

            • 3. Re: troubleshooting CTOS with Win7

              Hi there


              I am trying to figure this CTOS with Windows 7 also and seem to have simialr issue that you are having.


              Did you find a solution?



              • 4. Re: troubleshooting CTOS with Win7

                nope, never got an answer.  You are the first person to post on this thread, so no surprise there.  About half of my questions remain unanswered.  Right now I am not really using this product so this problem is pretty much being ignored.



                I have managed to get my provisioning templates to move beyond the CTOS step where some subsequent actions successfully complete, but not once have I ever seen the CTOS step complete with a green check mark.  I'm still puzzled by this.


                I hope you figure things out; I can't be of any help to you, however.


                good luck

                • 5. Re: troubleshooting CTOS with Win7



                  I have had some luck but very inconsistent. I can get CTOS to add the code into the unattend.xml but the problem seems to be that it adds it to the Specialize section at the end of the file rather than in the already existing specialize section.


                  When the computer reboots it seems to then complain that there are repeating sections in the unattend.xml and it cannot pass the unattend.xml.

                  • 6. Re: troubleshooting CTOS with Win7
                    hunter13 Apprentice

                    Has this issue ever been resolved, i'm having the same issue and i'm at a loss.


                    • 7. Re: troubleshooting CTOS with Win7



                      welcome to the community, where answers are only weeks or months away and seldom are either complete or from an actual landesk employee.




                      this was never fully resolved for me; I'm convinced that some of the documentation I referenced in my OP were not accurate for the Win7 environment and were just carried over from previous versions of LDMS and Windows.  I'm at LDMS 9.0 SP2 now and working only with Windows 7.


                      I still have never seen the console report that the CTOS action completes; it always shows a ??? in the icon.  I have not been as troubled by this once I got my templates developed to the point where things were working in my favor.  I was having all sorts of troubles in the beginning to which I could only attribute the CTOS 'failure?' because I wasn't getting any other feedback from the process.  In hindsight I believe that most of my problems were due to having incomplete or improperly formatted UNATTEND.XML files.


                      The only thing that I can say to new users at this point is that you need to be very familiar with the whole windows 7 setup and installation process aside from what is happening in landesk.  If you don't really understand what you are doing, and I was in that camp last Summer, then you're stuck when your LDMS tasks fail.  I've realized that LDMS Provisioning does a very poor job of providing meaningful feedback to inexperienced users and is not much help when it comes to troubleshooting failures.


                      I might go a bit further and suggest that you get full and working copies of someone's entire Win7 Deployment process so that you can pick through it to learn what 'can' be done.  Last Summer I was starting off with templates and documentation which were only the bare minimum needed to get started.  If you would like, I can post a zip file of my process files and you can pick through them to see what a full picture looks like.


                      -let me know, and good luck.

                      • 8. Re: troubleshooting CTOS with Win7
                        hunter13 Apprentice



                        Thank you for the great information, could you please post a zip file with your processes. I think going through the stuff that you have and what i've done will help me out alot.


                        Thanks again for helping out



                        • 9. Re: troubleshooting CTOS with Win7

                          @ hunter,



                          attached is a zip file with a bunch of stuff including a readme file.  Have a look at the readme before you start trying to import the stuff.  Also, make sure you understand the import process from windows explorer to the LDMS console.  not only do you have to import the .XTP as a template, you also have to import all of the other crap as provisioning scripts.   Would be worth reading the help file associated with the console for this.  Go to Operating System Deployment, then click on the INSTALL SCRIPTS button on the toolbar, then at the bottom you can click on help for a description of the process.


                          I have included the related text in my readme but I find it easier to read the text from within the help file.



                          -good luck

                          • 10. Re: troubleshooting CTOS with Win7

                            Hi Aspenskier


                            Sorry to see you have gone so long without getting this resolved.


                            I have had CTOS working off and on now for a few months with ld9sp2.  Haven't really delved into why I have the current problem yet, just getting ready to and doing some research and found this thread.


                            I glances at the files you had in the zip.  That is a lot of complex stuff.  Also getting all the variables set up right is very tedious and easy to mess up from imported scripts.


                            What I have found so far though is:


                            - this OSD/Provitioning stuff is very complex

                            - MDT isn't much better (worse in some ways)

                            - I have decided not to use imagew and go with imagex from Microsoft, mainly because if partitioning issues.

                            - start with short scripts and expand them slowly. 

                            (Right now I am troubleshooting an image someone else made and finding it very frustrating.  On the issue I currently have, I am leaning toward how it was prepared before the image capture.)

                            - HII is not practically workable how it is implemented currently.


                            (sorry if that's a bit jumbled, I just stared typing out thoughts)


                            Anyway, I will let you know what I find in my research of this issue for our environment.

                            • 11. Re: troubleshooting CTOS with Win7

                              thanks TOM,


                              I've not gotten an answer or resolution to the original post and I've moved on at this point.


                              This thread turned into something else by the time of my last post where I added file attachments.  My original problem was realized early on in my provisioning days when I had a very cut and dry provisioning task which didn't have all of the other layers you pointed out as being complex.  That problem is that the CTOS action step which occurs last in the POST-OS INSTALLATION phase of provisioning NEVER ONCE reported back as having completed successfully.  That is to say that it never showed a green check mark to indicate that all was well.


                              When I realized that I wasn't going to get an answer or other relevant imformation about this problem here, I simply ignored it and I must say that it doesn't appear to matter at all.



                              As I said, I moved on and now have a pretty decent provisioning process for my windows 7 machines..  I'm still developing other provisioning tasks as I learn more about this product...its been difficult to do because there isn't as much 9.0 information on this site as there was for earlier versions of the product AND because for most of the past 3 months it has not worked 100% for me due to bugs in the landesk patches.For what its worth your advice sounds reasonable and aligns with the experiences I have had with the product.


                              in any event, thanks for chiming in.  Good day.

                              • 12. Re: troubleshooting CTOS with Win7

                                Just figured out the issue I had, it turned out they were using the wrong unattended.xml onece we resolved that it's working better.  I still have other issues to resolve with it, but ctos now works.


                                If you are not using CTOS how are you getting the landesk client on the machine?

                                • 13. Re: troubleshooting CTOS with Win7

                                  when you say that your CTOS action works, do you mean to say that it reports back with a green check box?


                                  When I go to inspect the results of a provisioning task on a client I will always see the ??? icon, think its blue, associated with my CTOS action.  This is what I was orginally getting at.

                                  • 14. Re: troubleshooting CTOS with Win7

                                    This is what I see:




                                    CTOS stays blue because there is no way for it to really report back.  It modifies the unattend.xml so it will run while the OS is booted the first time.  If the template never completes, it failed, if the template finishes it worked properly. 


                                    I guess I never really questioned why it stayed blue.  Maybe because it wasn't red.


                                    Have a great weekend! .. I'm heading home.

                                    1 2 Previous Next