1 Reply Latest reply on Jul 23, 2010 12:59 PM by Mroche

    Auto Email Notifications Not Sending on Open and Close


      My auto emails have stopped sending on open and closure of calls. Can anyone give me the configuration details of what these settings should typically be for someone using MAPI.


      I have attached two screen shots of the New Call config and Close Call config.


      MAPI settings are correct.





        • 1. Re: Auto Email Notifications Not Sending on Open and Close
          Mroche SupportEmployee

          Hi William,


          There are a number of reasons these emails may have stopped being sent.


          From the screenshots, I can see that you have 'Only process autoemail updates' checked for outbound emails.  This means that emails will only be sent out when an incident is created or closed if it is created or closed by an incoming email.  You will want to uncheck this if you want emails to be sent out when an analyst creates or closes a call in Helpdesk or Helpdesk Internet edition.



          If you only want emails sent out when an email is received in the Autoemail mailbox with Close: or New Call: in the subject then the settings in autoemail config are correct and you will need to troubleshoot this issue.


          The first place to start is checking the HDerror.log which is located in the HDBIN32 folder on the server.  Select the options tab in Autoemail configuration and make sure the 'Generate a log file for any errors' is checked - this will cause Autoemail to write to the log.  If the log is still not being written to check article http://community.landesk.com/support/docs/DOC-11130.


          Check the size of the log file, if it is over 10MB, delete it.  Autoemail will create a new log file after it completes its next poll.  Large log files can cause issues with Autoemail.


          Open the log file and scroll to the bottom of it and work up the file looking for any errors which point to the cause of the issue.


          If there are errors in the log regarding processing reports then the problem is usually that Autoemail cannot locate | Open and run the report it attaches to the email or their is a problem with that report.  To test if the problem is with the report, uncheck the 'Include notification report' for both the inbound and outbound sections of the New Call and Close Call tabs in Autoemail config, Click Ok to save the changes.

          Stop Autoemail and make sure the inbound.exe and outbound.exe processes are no longer running in Task Manager.  Restart autoemail and test.


          If Outbound emails are received then the problem is with the reports and you will need to ensure the reports path on the Options tab in AE config is correct and that you can browse to the report on the New Call and Close call tabs.  You will also need to modify the reports on a workstation which has Crystal reports on it and check that you can run the report manually.


          If outbound emails are not received the issue could be one of the following:


          1.  There are duplicate Autoemail tables in the database with different owners and autoemail is picking up the wong one (the tables would be AUTOEMAILMAPPINGS and AUTOEMAILCONFIG)

          2.  You may have an issue with Queue locks - see article http://community.landesk.com/support/docs/DOC-6972

          3.  The QUEUE_CONFIG_HDW tbale is not configured correctly - see article http://community.landesk.com/support/docs/DOC-6973


          The following link will take you to the Autoemail section on the community which contains articles which may also assist with this issue.