6 Replies Latest reply on May 27, 2010 1:10 PM by rsterling

    PXE proxy IP problem



      Dear all,



      I got a problem of proxy IP.



      I boot PC from ethernet PXE, and the computer captured correct IP address, subnet mask and default gateway, but the proxy IP is wrong.



      I got right proxy IP once from several times, who can tell me the reason? How edit the script and binding the proxy IP?






        • 1. Re: PXE proxy IP problem
          Jared Barneck SupportEmployee

          Are you talking about the BIOS screen, just above where you get prompted to press the F8 menu?


          If you are seeing a different Proxy IP there, then that means that there are multiple PXE Representatives on your network.  There is a PXE representative installed on the machine with that IP address.

          • 2. Re: PXE proxy IP problem


            To go with what rhyous is saying: check your console under the Network View > Core Server > Configuration > PXE Representatives



            See what machines you have as your PXE representatives. You should only have one per subnet. So if you have 2 machines on the network you are seeing this issue on, schedule and run the "pxe represetative removal" script to the duplicate machines.



            • 3. Re: PXE proxy IP problem
              Jared Barneck SupportEmployee

              Just to make sure everyone knows...


              It is ok to have multiple PXE Representatives on a subnet.  There is nothing wrong with that.


              A few things you should be aware of with multiple PXE representatives however:


              1. Troubleshooting is difficult and all but one PXE Representative should be disabled on a subnet when troubleshooting.
              2. The first one that responds is the one the workstation will PXE boot from. There is no real way to guarantee which PXE representative will be the first to respond.
              You have to remember to update them all when you make changes

              • 4. Re: PXE proxy IP problem
                rcronje Apprentice


                Having 2 PXE Representatives on the same subnet can cause issues if they were installed from 2 different core servers. Obviously if you have only one core server then this is not the problem.






                What i have encountered before is certain hardware manufacturers (if I remember correctly Dell is one of them) include certain PXE services in their management services for their servers. This means that if your server network is on the same as your PXE representative then the management software for your servers could be answering the PXE request before the PXE representative can. Check the ip address that is being returned as a proxy and see if it is one of your servers. Then depending on how your network is configured block PXE requests from your workstation network reaching the server network or disable the PXE service that is interfering.



                Alternatively your DHCP server could have the PXE options set and it might be answering the PXE requests. You will have to check out your DHCP server.



                Hope this points you in the right direction.



                1 of 1 people found this helpful
                • 5. Re: PXE proxy IP problem

                  I had this problem intermittently and never figured out what fixed it for me until today.  All looked good except my proxy ip would show up as, and TFTP timeout.  I could ping this address from my workstation (Which is one of the pxe reps), but not from any other workstation.  Beware of a mobile devices such as a cell phone connected via USB to the PXE rep....unplugged the phone from usb and wala.

                  • 6. Re: PXE proxy IP problem

                    RE: Tim's post on the address and the TFTP timeout... I second that!  This just helped me resolve the issue after 30 minutes of troubleshooting time!  Thanks!