8 Replies Latest reply on Aug 13, 2010 5:55 AM by Restec

    Mscomctl.ocx Listview problem

    Rookie

      Hi,

       

      I'm a new user of Virtual app and I got some issues.

       

      I've virutalize the client side of my app.  On some pc it works fine but on some others the listview gets an error.

      (this object does not handle this propety or method)

       

      The only thing that I can see is the MSCOMCTL.OCX installed by other office programs.

       

      I've tested on windows 7 without office 2010 and every thing is OK.

      Tested with office 2010 and got the error.

       

      Tested on XP SP3 without office (even 2000) and it's OK

      Tested on XP SP3 with office and got the error.

       

      The MSCOMCTL.OCX that I need is in my virtualize app  and I was on the impression that if it's virutalize it won't use the one on the PC.

       

      Does someone knows if MSCOMCTL.OCX has dependencies that needs to be virutalize as well?

      Any suggestions would be great

       

      Thanks

       

      René Lafontaine

      Restec Inc.

        • 1. Re: Mscomctl.ocx Listview problem
          Tracy Expert

          Is it possible that there is a mismatch between VB runtimes between machines that work, and don't work? For example, your capture machine had the VB redistributable2008  patches installed before the capture so the cptured build did not include the binaries which would cause it to error out on machines not at that patch level. I see this type of problem with .NET versions all the time. Make sure your capture machine is lowest common denominator (for OS and patches). Also for some good info on capturing Office, check this link http://blogs.vmware.com/thinapp/2008/10/how-to-thinap-2.html (it's for Office 2k3, but the process is pretty much the same for 2k7)

           

          -Tracy

          • 2. Re: Mscomctl.ocx Listview problem
            Rookie

            Thanks for that quick response.

             

            I'll check that link.

             

            Here is a little bit more info on my apps;

            No .Net  it's build on the old VB6

             

            I build it in "virtualbox" running XP SP2 with no updates. Also tried on a clean PC with XP SP2.

             

            René

            • 3. Re: Mscomctl.ocx Listview problem
              Rookie

              Hi,

               

              Still having trouble with it.

               

              Can someone tell me how to add and register manually ActiveX's into a build?

               

              TIA.

               

              René

              • 4. Re: Mscomctl.ocx Listview problem
                Rookie

                So,

                 

                No one on planet landesk can give me a hand?

                • 5. Re: Mscomctl.ocx Listview problem
                  Tracy Expert

                  Rene,

                   

                  You may have to open up a ticket with support. How big is the app? would you be able to let us test it in house? I would need more information on the actual problem to figure this out. My guess is that the MSCOMCTL.OCX is conflicting with the Office version and we will have to set the isolation mode to accomdate the application as far as being run on a machine with Office 2k10 installed.

                   

                  -Tracy

                  • 6. Re: Mscomctl.ocx Listview problem
                    Rookie

                    Tracy,

                     

                    Thanks for the response.

                     

                    I'm new at this,  How do I post a ticket?

                    I'm in the "landesk user community" under my login and I don't see how to post a ticket.

                     

                    As for being able to let you test it in house,  this could be a problem.  My software is client/server base and the server side runs on LInux.

                    To give you some idea of my software:

                     

                    It's a document imaging software, all to the processing of the images are done locally with ActiveX's downloaded when installed. After the processing is done the images are downloaded to the server to be stored.

                     

                    I can give access to my test pc and also I can send you 2 trace file, one where the virtual app is working and one not.  So that you can compare them and may be find something.

                     

                    René

                    • 7. Re: Mscomctl.ocx Listview problem
                      Tracy Expert

                      When logged in, you should see "Smart Self-Service Portal" in the all communities. Clicking on that should allow you to open a case. I will look at the traces and see what I can see.

                       

                      -Tracy

                      • 8. Re: Mscomctl.ocx Listview problem
                        Rookie

                        I tried to open a ticket but it seems that I only have "base" support so I can't open one.