6 Replies Latest reply on Jul 23, 2010 9:47 AM by adenewton

    PXE Rep install script keeps failing


      I am attempting to install a new PXE rep.


      FYI Core server has landesk 9 installed and SP1.


      When we had landesk in a while ago (back when we were on 8.8 SP3) we had them demo imaging to us and we had the pxe rep setup on the core. Obviously we don't want to do this, so i ran the uninstall script as a scheduled task on the server and that seemed to run ok. I have rebooted the server since.


      On the new machine I am setting up as the pxe rep which is a bog standard XP machine, the install keeps failing. However I don't understand why. the log file seems to indicate everything has gone ok, yet it still fails. I can see the files on the potenetial rep machine, so they have copied across.


      Any ideas anyone? see the log file below:



      "DT-P03752","OK",1605,0:00:01,22/07/2010 15:53:21,22/07/2010 15:53:22,"MsiExec.exe /q /X{F238CE99-6614-4072-9D20-1D2FA7ED951A}"
      "DT-P03752","OK",0,0:00:01,22/07/2010 15:53:23,22/07/2010 15:53:24,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\ldlinux.img, C:\Program Files\LANDesk\LDClient\ldlinux.img, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:24,22/07/2010 15:53:24,"C:\Program Files\LANDesk\ManagementSuite\landesk\files\bootmenu.1, C:\Program Files\LANDesk\LDClient\bootmenu.1, TOREMOTE"
      "DT-P03752","OK",0,0:00:02,22/07/2010 15:53:24,22/07/2010 15:53:26,"C:\Program Files\LANDesk\ManagementSuite\landesk\files\bstrap.0, C:\Program Files\LANDesk\LDClient\bstrap.0, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:26,22/07/2010 15:53:26,"C:\Program Files\LANDesk\ManagementSuite\landesk\files\dosundi.1, C:\Program Files\LANDesk\LDClient\dosundi.1, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:26,22/07/2010 15:53:26,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bootmenu.0, C:\Program Files\LANDesk\LDClient\bootmenu.0, TOREMOTE"
      "DT-P03752","OK",0,0:00:01,22/07/2010 15:53:26,22/07/2010 15:53:27,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\dosundi.0, C:\Program Files\LANDesk\LDClient\dosundi.0, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:27,22/07/2010 15:53:27,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bzImage, C:\Program Files\LANDesk\LDClient\bzImage, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:27,22/07/2010 15:53:27,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\pxelinux.0, C:\Program Files\LANDesk\LDClient\pxelinux.0, TOREMOTE"
      "DT-P03752","OK",0,0:00:01,22/07/2010 15:53:27,22/07/2010 15:53:28,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\default.boot, C:\Program Files\LANDesk\LDClient\default.boot, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:28,22/07/2010 15:53:28,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\default.menu, C:\Program Files\LANDesk\LDClient\default.menu, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:28,22/07/2010 15:53:28,"\\\ldlogon\provisioning\linux\linuxpe.default.cfg, C:\Program Files\LANDesk\LDClient\linuxpe.default.cfg, TOREMOTE"
      "DT-P03752","OK",0,0:00:01,22/07/2010 15:53:28,22/07/2010 15:53:29,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bcd, C:\Program Files\LANDesk\LDClient\bcd, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:29,22/07/2010 15:53:29,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\boot.sdi, C:\Program Files\LANDesk\LDClient\boot.sdi, TOREMOTE"
      "DT-P03752","OK",0,0:00:01,22/07/2010 15:53:29,22/07/2010 15:53:30,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\boot.wim, C:\Program Files\LANDesk\LDClient\boot.wim, TOREMOTE"
      "DT-P03752","OK",0,0:00:01,22/07/2010 15:53:30,22/07/2010 15:53:31,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bootmgr.exe, C:\Program Files\LANDesk\LDClient\bootmgr.exe, TOREMOTE"
      "DT-P03752","OK",0,0:00:00,22/07/2010 15:53:31,22/07/2010 15:53:31,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\pxeboot.0, C:\Program Files\LANDesk\LDClient\startrom.0, TOREMOTE"
      "DT-P03752","OK",-2147467259,0:01:07,22/07/2010 15:53:31,22/07/2010 15:54:38,"<qt/>C:\Program Files\LANDesk\LDClient\sdclient.exe<qt/> /p="" /msi /N /An /Ac /g="{F238CE99-6614-4072-9D20-1D2FA7ED951A}""
      "DT-P03752","OK",0,0:00:13,22/07/2010 15:54:38,22/07/2010 15:54:51,"<qt/>C:\Program Files\LANDesk\LDClient\LDISCN32.EXE<qt/> /NTT= /S="" /F /SYNC /NOUI"
      ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"
        • 1. Re: PXE Rep install script keeps failing
          Jared Barneck SupportEmployee

          According to your log, every line is OK.  So I don't see why it failed.


          You do have two lines with non-zero exit codes:



          "DT-P03752","OK",1605,0:00:01,22/07/2010  15:53:21,22/07/2010 15:53:22,"MsiExec.exe /q  /X{F238CE99-6614-4072-9D20-1D2FA7ED951A}"


          "DT-P03752","OK",-2147467259,0:01:07,22/07/2010  15:53:31,22/07/2010 15:54:38,"<qt/>C:\Program  Files\LANDesk\LDClient\sdclient.exe<qt/> /p=""  /msi /N /An /Ac /g="{F238CE99-6614-4072-9D20-1D2FA7ED951A}""


          The 1605 is fine, it is just an MSI return code that the product was not found. If the machine doesn't have a PXE Rep installed, this is normal. If the machine does have an old version of the PXE Rep, and you see this error then this is a problem. The MSI GUID we are using to uninstall is probably wrong somehow.


          The second error code doesn't make much sense:


          You can laugh about how our error codes work, but here is what I did to get the actually error code:


          -2147467259 is an integer that holds the Facility and Error in its bits.  You can convert this with LD Error Translator.exe (part of the LANDesk Support Tools).


          Facility: 0



          Schedule   plug in facility, the error codes will be loaded from the resources within   the scheduler application


          Error: 16389


          A 16389 return code is pretty rare. Not many people remember that you have to then convert that 16389 to hex to find out what it is in the error code document.


          Error: 0x4005


          Then you have to look at the LDMS_Error_Codes.doc file that support engineers have, not sure if it is on the community somewhere.


          (   0x4005)



          So whatever that means.  Sorry that is not exactly clear.


          So now that I have looked the error up for you, I still have no exact idea what to suggest.


          However, I notice that the log doesn't exactly mark this as an error.  It says that it is OK.


          So the first question I have is this:

          1. Is the PXE Rep really installed and working even though this said it failed?

          • 2. Re: PXE Rep install script keeps failing

            There was no PXE folder in my landesk program files on the target rep machine, so despite the files copying it would seem the installation has not took place which is probably what the error is, although it's not telling us this.


            I manually ran the MSI from the core web share and it seems to have installed and asked me to reboot.


            Rebooted machine and then tried to boot the machine I want to image from PXE.


            This works and I can choose WinPE and it runs through the scripts. However something still seems to be wrong.


            Very difficult for me to do screen grabs from the WinPE environment, but the interesting bit I get after laading device drivers are:


            BootServerReply= 2 smiley faces and a club symbol you'd find on a pack of cards. I assume this is not normal!!


            Then it will either tell me that the controller for the hard drive cannot be found and to inejct the driver (which i doubt is true as it's just a standard IDE drive)


            Sometimes it get's passed this and get's to the waiting for IP address, but just sits there indenfiently and doesn't seem able to obtain an IP address.


            I'm going to try uninstalling the PXE rep now I've managed to get the files on the machine and then re-deploy it. Doubt it will work, so if you or anyone else has any other ideas. Please feel free.

            • 3. Re: PXE Rep install script keeps failing

              Just a bit of running commentary on this, ran the uninstall pxe script from the core onto the target and this ran ok. Double checked on the target machine and the PXE folder has been removed. So that side of thing's seemed to go ok.

              • 4. Re: PXE Rep install script keeps failing

                OK, same problem as in original post.


                I certainly believe the problem line is:


                "DT-P03752","OK",-2147467259,0:01:10,23/07/2010 11:51:26,23/07/2010 11:52:36,"<qt/>C:\Program Files\LANDesk\LDClient\sdclient.exe<qt/> /p="" /msi /N /An /Ac /g="{F238CE99-6614-4072-9D20-1D2FA7ED951A}""


                I don't think the msi or the exe?? whatever it's meant to be, is being executed correctly on the target, as I don't get a PXE folder in my landesk folder on the target machine.


                I will attempt to roll it out to a my machine to see if it's the machine that is the problem rather than the install script. Although probably won't help as my machine has had that many different landesk agent configurations on it i think it's seems to be confusing itself about things, but we'll see.



                "DT-P03752","OK",1605,0:00:00,23/07/2010 11:43:35,23/07/2010 11:43:35,"MsiExec.exe /q /X{F238CE99-6614-4072-9D20-1D2FA7ED951A}"

                "DT-P03752","OK",0,0:02:35,23/07/2010 11:43:38,23/07/2010 11:46:13,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\ldlinux.img, C:\Program Files\LANDesk\LDClient\ldlinux.img, TOREMOTE"

                "DT-P03752","OK",0,0:00:06,23/07/2010 11:46:14,23/07/2010 11:46:20,"C:\Program Files\LANDesk\ManagementSuite\landesk\files\bootmenu.1, C:\Program Files\LANDesk\LDClient\bootmenu.1, TOREMOTE"

                "DT-P03752","OK",0,0:00:01,23/07/2010 11:46:20,23/07/2010 11:46:21,"C:\Program Files\LANDesk\ManagementSuite\landesk\files\bstrap.0, C:\Program Files\LANDesk\LDClient\bstrap.0, TOREMOTE"

                "DT-P03752","OK",0,0:00:02,23/07/2010 11:46:21,23/07/2010 11:46:23,"C:\Program Files\LANDesk\ManagementSuite\landesk\files\dosundi.1, C:\Program Files\LANDesk\LDClient\dosundi.1, TOREMOTE"

                "DT-P03752","OK",0,0:00:02,23/07/2010 11:46:23,23/07/2010 11:46:25,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bootmenu.0, C:\Program Files\LANDesk\LDClient\bootmenu.0, TOREMOTE"

                "DT-P03752","OK",0,0:00:00,23/07/2010 11:46:25,23/07/2010 11:46:25,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\dosundi.0, C:\Program Files\LANDesk\LDClient\dosundi.0, TOREMOTE"

                "DT-P03752","OK",0,0:00:04,23/07/2010 11:46:26,23/07/2010 11:46:30,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bzImage, C:\Program Files\LANDesk\LDClient\bzImage, TOREMOTE"

                "DT-P03752","OK",0,0:00:01,23/07/2010 11:46:30,23/07/2010 11:46:31,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\pxelinux.0, C:\Program Files\LANDesk\LDClient\pxelinux.0, TOREMOTE"

                "DT-P03752","OK",0,0:00:00,23/07/2010 11:46:31,23/07/2010 11:46:31,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\default.boot, C:\Program Files\LANDesk\LDClient\default.boot, TOREMOTE"

                "DT-P03752","OK",0,0:00:00,23/07/2010 11:46:31,23/07/2010 11:46:31,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\default.menu, C:\Program Files\LANDesk\LDClient\default.menu, TOREMOTE"

                "DT-P03752","OK",0,0:00:00,23/07/2010 11:46:32,23/07/2010 11:46:32,"\\\ldlogon\provisioning\linux\linuxpe.default.cfg, C:\Program Files\LANDesk\LDClient\linuxpe.default.cfg, TOREMOTE"

                "DT-P03752","OK",0,0:00:01,23/07/2010 11:46:32,23/07/2010 11:46:33,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bcd, C:\Program Files\LANDesk\LDClient\bcd, TOREMOTE"

                "DT-P03752","OK",0,0:00:06,23/07/2010 11:46:33,23/07/2010 11:46:39,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\boot.sdi, C:\Program Files\LANDesk\LDClient\boot.sdi, TOREMOTE"

                "DT-P03752","OK",0,0:04:45,23/07/2010 11:46:39,23/07/2010 11:51:24,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\boot.wim, C:\Program Files\LANDesk\LDClient\boot.wim, TOREMOTE"

                "DT-P03752","OK",0,0:00:01,23/07/2010 11:51:24,23/07/2010 11:51:25,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\bootmgr.exe, C:\Program Files\LANDesk\LDClient\bootmgr.exe, TOREMOTE"

                "DT-P03752","OK",0,0:00:01,23/07/2010 11:51:25,23/07/2010 11:51:26,"C:\Program Files\LANDesk\ManagementSuite\landesk\vboot\pxeboot.0, C:\Program Files\LANDesk\LDClient\startrom.0, TOREMOTE"

                "DT-P03752","OK",-2147467259,0:01:10,23/07/2010 11:51:26,23/07/2010 11:52:36,"<qt/>C:\Program Files\LANDesk\LDClient\sdclient.exe<qt/> /p="" /msi /N /An /Ac /g="{F238CE99-6614-4072-9D20-1D2FA7ED951A}""

                "DT-P03752","OK",0,0:00:12,23/07/2010 11:52:36,23/07/2010 11:52:48,"<qt/>C:\Program Files\LANDesk\LDClient\LDISCN32.EXE<qt/> /NTT= /S="" /F /SYNC /NOUI"

                ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

                • 5. Re: PXE Rep install script keeps failing

                  Same problem when trying to roll out to another machine also.


                  I'm guessing I've done something wrong somewhere, but god knows what!

                  • 6. Re: PXE Rep install script keeps failing

                    For reference for anyone else, I solved this by following the instructions in this post:




                    As the above doc is for older versions, all i did was add the following line


                    REMCOPY19=%DTMDIR%\landesk\files\osdrep.msi, %LDMS_CLIENT_DIR%\sdmcache\osdrep.msi, TOREMOTE


                    before the first REMEXEC line.


                    Also make sure your REMCOPY and REMEXEC lines are numbered correctly after inserting the line.