5 Replies Latest reply on Aug 3, 2010 4:21 AM by adenewton

    Capture Image Problem

    Apprentice

      I'm trying to capture my first image using Landesk 9, recently updated to SP1.

       

      As far as I can tell everything is configured correctly in regards to my capture script and the PXE rep.

       

      The machine PXE boots fine, detects the hard drive and gets an IP address.

       

      When the PXE Menu comes up I select my Capture script.

       

      This is where I get a problem, a black dos box comes up with the heading of:

       

      X:\ldclient\sdclient.exe

       

      the cursor flashes in the box and after about 30 seconds vanishes.

       

      Nothing happens after this and I have left the machine running for quite a while.

       

      Any ideas where I could be going wrong?

        • 1. Re: Capture Image Problem
          Apprentice

          password and id issues in osd script? path and name resolution issues in osd script?

          • 2. Re: Capture Image Problem
            Apprentice

            I can't see a problem with it, I can access the share with the user and password manually and create and delete files in it.

             

            Here is my script, think i've renamed all my server paths etc.

             

            [VALUES]
            Task=7
            ScriptName=WinXP Gold Via PE Capture
            ScriptDescription=Captures all partitions on the first drive
            FallBackNIC=
            UseFallBackNIC=FALSE
            ImageUserName=landesk
            ImageDomain=domainname
            ImagePassword=encryptedpassword

            ImageToolType=11
            ImageUNC=\\sharecomputer\OSD
            ToolUNC=\\coreserver\ldmain\osd\imagew 2\imagew.exe
            ImageToolCmd=H:\osd\IMAGEW~1\imagew.exe /b /uy /d:0 /rb:0 /max:2GB /f:"""i:\%Computer - Device Name%"""
            [OWNER]
            GUID=76f2a5e7-214f-4a18-836d-19aa3d737a43
            OSDPLUG=TRUE
            DESCRIPTION=Captures all partitions on the first drive
            NAME=WinXP Gold Via PE Capture
            TYPE=WinPE
            [JOBPARAM]
            ABORT_ON_CMD_FAILURE=1
            TASK_COMPLETION_ENABLED=FALSE
            [MACHINES]
            REMEXEC0=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/bootfile.exe"
            REMEXEC1=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr16.dll"
            REMEXEC2=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr32.dll"
            REMEXEC3=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/lddefrag.exe"
            REMEXEC4=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/FlushBuffer.exe"
            REMEXEC5=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cicfgmgr.vxd"
            REMEXEC6=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cindis.vxd"
            REMEXEC7=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/copyfile.exe"
            REMEXEC8=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/boot.img"
            REMEXEC9=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ChangeBCD.exe"
            REMEXEC10=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/BCD"
            REMEXEC11=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/files/bcdedit.exe"
            REMEXEC12=<qt/>%LDMS_CLIENT_DIR%\ChangeBCD<qt/> <qt/>%LDMS_CLIENT_DIR%\bcdedit.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\BCD<qt/>
            REMEXEC13=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="C:\boot.wim" /p="http://%CUSTJOBHOSTIP%/landesk/vboot/boot.wim"
            REMEXEC14=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\boot.img<qt/> <qt/>%LDMS_CLIENT_DIR%\BCD<qt/> \boot\BCD
            REMEXEC15=<qt/>%LDMS_CLIENT_DIR%\lddefrag.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\boot.img<qt/>, STATUS
            REMEXEC16=<qt/>%LDMS_CLIENT_DIR%\FlushBuffer.exe<qt/>, STATUS
            REMEXEC17=<qt/>%LDMS_CLIENT_DIR%\bootfile.exe<qt/> %LDMS_CLIENT_DIR%\boot.img /keep /bootunsafe, ASYNC
            BEGINWINPE=TRUE
            REMPING18=WINPE, TIMEOUT=1800
            REMEXEC19=diskpart /s X:\LDClient\rmvol.txt
            REMEXEC20=drvmap.exe domainname\landesk 107FDFD157086C7E4382B0C3A57 I: <qt/>\\machineshare.domainname.local\OSD<qt/>, STATUS FACILITY=3513
            REMEXEC21=drvmap.exe domainname\landesk 107FDFD157086C7E4382B0C3A57 H: <qt/>\\coreserver.domainname.local\ldmain<qt/>, STATUS FACILITY=3513
            REMEXEC22=ldrun sdclient /f /o /dest="X:\LDClient\assvol.txt" /p="http://%CUSTJOBHOSTIP%/landesk/files/assvol.txt", STATUS
            REMEXEC23=ldrun tokreplw X:\LDClient\assvol.txt partition=1
            REMEXEC24=diskpart /s X:\LDClient\assvol.txt
            REMEXEC25=cmd /c del /f /q C:\boot.wim
            REMEXEC26=ldrun H:\osd\IMAGEW~1\imagew.exe /b /uy /d:0 /rb:0 /max:2GB /f:"""i:\%Computer - Device Name%"""
            REMEXEC27=ldrun reboot, timeout=2

            • 3. Re: Capture Image Problem
              Apprentice

              Here's the log file.

               

               

              "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
              "SourceMachine","OK",0,0:00:06,30/07/2010 13:25:57,30/07/2010 13:26:03,"WINPE, TIMEOUT=1800"
              "SourceMachine","OK",5,0:00:03,30/07/2010 13:26:19,30/07/2010 13:26:22,"diskpart /s X:\LDClient\rmvol.txt"
              "SourceMachine","OK",230227968,0:00:12,30/07/2010 13:26:25,30/07/2010 13:26:37,"drvmap.exe domain\landesk 107FDFD157086C7E4382B0C3A57 I: <qt/>\\imagehost.domain.local\OSD<qt/>, STATUS FACILITY=3513"
              "SourceMachine","OK",230227968,0:00:01,30/07/2010 13:26:40,30/07/2010 13:26:41,"drvmap.exe domain\landesk 107FDFD157086C7E4382B0C3A57 H: <qt/>\\coreserver.domain.local\ldmain<qt/>, STATUS FACILITY=3513"
              "SourceMachine","ERR_Fail",-1,0:00:22,30/07/2010 13:26:42,30/07/2010 13:27:04,"ldrun sdclient /f /o /dest="X:\LDClient\assvol.txt" /p="http://coreserver/landesk/files/assvol.txt", STATUS"
              ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

               

               

              Is there anything I can run from an additional console window to test anything?

              • 4. Re: Capture Image Problem
                EMiranda Expert

                how much RAM is in this machine.  if you just moved to Landesk 9, the RAM requirements increased. According to your error in your log it is trying to save a file to X:\ldclient\.  I have seen times where a machine with minimal RAM like 256mb, sometimes even 512mb (depending on how many additinial drivers you try to install) will bomb out because it runs out of space.

                • 5. Re: Capture Image Problem
                  Apprentice

                  Machine in question had 1.5GB.

                   

                  Just tried it with another with 3GB and get same issue.

                   

                  Here's the new log file:

                   

                  "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
                  "machinename","OK",0,0:00:01,03/08/2010 11:11:29,03/08/2010 11:11:30,"WINPE, TIMEOUT=1800"
                  "machinename","OK",5,0:00:03,03/08/2010 11:11:30,03/08/2010 11:11:33,"diskpart /s X:\LDClient\rmvol.txt"
                  "machinename","OK",230227968,0:00:00,03/08/2010 11:11:33,03/08/2010 11:11:33,"drvmap.exe domainname\landeskuser 107FDFD157086C7E4382B0C3A57 I: <qt/>\\machinetobeusedtohostimages.domain.local\sharename<qt/>, STATUS FACILITY=3513"
                  "machinename","OK",230227968,0:00:00,03/08/2010 11:11:34,03/08/2010 11:11:34,"drvmap.exe domainname\landeskuser 107FDFD157086C7E4382B0C3A57 H: <qt/>\\coreserver.ppdg.local\ldmain<qt/>, STATUS FACILITY=3513"
                  "machinename","ERR_Fail",-1,0:00:22,03/08/2010 11:11:34,03/08/2010 11:11:56,"ldrun sdclient /f /o /dest="X:\LDClient\assvol.txt" /p="http://coreserver/landesk/files/assvol.txt", STATUS"
                  ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

                   

                   

                  Only thing I can think off is it's failing to resolve the core server name in the last line, but don't understand why it would ok beforehand,