7 Replies Latest reply on Jan 22, 2008 2:12 PM by CraigMiddelstadt

    incorrect IPMI errors even after implementing 8.7sp4

    Rookie

       

      At our company we have several Dell servers with Open Manage 5.x installed, we kept getting false IPMI errors (mostly power supply) on several servers. This is a known issue when sp4 is not installed trough this community. My question is, have more organisations seen the same problems occur even when sp4 is implemented.

       

       

      kind regards

       

       

        • 1. Re: incorrect IPMI errors even after implementing 8.7sp4
          Specialist

           

          Hi,

           

           

           

           

           

          You want to try applying LD-IPMI-114027-873 from the LANDesk Patch downloads. This has updates for multiple IPMI drivers which has resolved a similar issue to this for one of our clients. Once applied, you need to re-distribute your agent to the server.

           

           

           

           

           

          Jack

           

           

          • 2. Re: incorrect IPMI errors even after implementing 8.7sp4
            Rookie

             

            thanks for your reply, only we allready implemented the patch prior to installing sp4 but witout any difference

             

             

            • 3. Re: incorrect IPMI errors even after implementing 8.7sp4
              Specialist

              You may want to try re-applying this patch as the one we've seen is actually a post SP4 patch. As mentioned above, re-build your agent then make sure you re-push your agent once applied (Full agent not just an update).

              • 4. Re: incorrect IPMI errors even after implementing 8.7sp4
                Rookie

                 

                even this has allready been done. We had out Landesk gold partner investigate our problem, but till so far no luck. Currently our case is under investigation by Landesk support.

                 

                 

                • 5. Re: incorrect IPMI errors even after implementing 8.7sp4
                  Jed SupportEmployee

                   

                  This is a defect, ensure that you have patch LD-IMPI-114027-873 and the latest Service Pack for LDMS applied to Core and nodes. 

                   

                   

                  What kind of machines and management software (IE, OpenManage) do you have applied? (Please include versions.)

                   

                   

                  • 6. Re: incorrect IPMI errors even after implementing 8.7sp4
                    Specialist

                    Also one thing to make sure of is that you have applied the latest Mini-Rollups for 8.7 SP4 also. I've found if these aren't installed prior to the IPMI patch being installed then the problem remains... Alternativly now SP5 has been release you could always download this and apply this to both core server and clients as this will have SP4 + Mini-Rollups + IPMI patch all included in one install.

                    • 7. Re: incorrect IPMI errors even after implementing 8.7sp4
                      CraigMiddelstadt Master

                      Problems/Symptoms:

                       

                      Additional support for multiple IPMI drivers. This resolves the issues that has been seen with Dell OpenManage 5.x throwing erroneous events in the alert log.

                       

                      Fix:

                       

                      For LANDesk Management Suite 8.7 download and apply the latest Service Pack.

                      Then apply hotfix LDSM-11402787.3-2.

                       

                      An understanding of this patch:

                      1. Clients must be re-installed. If the patch is just applied to the client without re-installing; IPMI will stop functioning.

                      2. SP3 must be applied in the environment, as well as all the latest MiniRollups. (Post SP3 Rollups)

                       

                      IPMI Driver Status                                                       What LANDesk will do on client install

                       

                      Non Dell machine no IPMI driver on system

                      LANDesk will install the OSA Driver.

                      Dell machine with no IPMI driver on system

                      LANDesk will fail on a push and pull, but the pull you will need to run serververify to see the status. (Serververify.exe is located in LDlogon on the core server)

                      Microsoft IPMI installed (W2K3 R2)

                      LANDesk will use the Microsoft IPMI driver.

                      Intel IPMI (imbdrv)

                      LANDesk will use that driver.

                      Dell machine with Open Managed 5.x is installed

                      LANDesk will use the HAPI driver.

                      Skipper BMC

                      LANDesk will install the skipper driver and use it.

                      Dell machine with 8.7 SP3 which has (imbdrv)

                      LANDesk will remove the imbdrv and then fail if the HAPI driver or Microsoft driver is not present.

                      |Non Dell machine with 8.7 SP3 which has (imbdrv)|Non Dell machine no IPMI driver on system LANDesk will install the OSA Driver.|_*

                       

                      A supported patch is now available from LANDesk. This patch is undergoing additional testing. Therefore, if you are not severely affected by this problem, LANDesk recommends waiting for the service pack that contains this patch. To resolve this problem immediately, contact LANDesk Customer Support to obtain the patch.