4 Replies Latest reply on Aug 2, 2010 8:38 AM by Ted.Thomas

    Why do some machines (device ID's) give a blank line for description\user and no inventory scans?

    Rookie

      Have a problem, and have had for some time, some PC's 'disappear' from our list of devices.

       

      The device ID is there (eg Computer name), can ping it etc, but all the other info is missing, eg Device Desc, Full Name etc, and when clicking on them to get their properties, its as if they have never had an inventory scan.

       

      I noticed today that now my own PC has done this..... wierd.....

       

      I have attached a screen shot on the console - you can see blank lines in the list of devices, and I have opened the properties for 2 machines:

       

      Dev ID  = W0T is my own PC - missing info.

      Dev ID = W0P is a PC next to me with full info.

       

      Why does this happen? The info always used to be there.....I have many multiple missing devices now.

       

      I'm beginning not to trust my device list, I have been asked to run a Software Compliance report, and I can see that PC's that definately have certain software installed are mssing from the Compliance report - which makes a mockery of the report - I can't trust it....

       

      I have today set the 'keep inventory reports for' setting back to 0 - I had changed it to 7 at some point in the past, but I right clicked on my (W0T) pc and did a Inventory scan - which did run, as it battered my PC for 15mins, but still hasn't replaced the missing info in Device Manager.....in fact you can see the time it ran on the screenshot if you look closely at W0T. Why has'nt it replaced the missing info?

       

      HELP.

       

      Landesk 8.80.0.249 SP2 Console

       

      PC's have 8.80.2.2 clients installed

       

      Landesk.jpg

        • 1. Re: Why do some machines (device ID's) give a blank line for description\user and no inventory scans?
          phoffmann SupportEmployee

          Traditionally, this is because of one of 2 possible things:

           

          Option 1 - You have devices whoose scans error out (too long strings being the common cause).

           

          You should check your Core's APPLICATION NT-event log, see if you have any error 4100's there from your devices (for the Inventory Service). If yes, then the Core fails to process those scans (again - usually this is because a data field is too long for the database-table to contain it).

           

          This is easily remedied, but I will ask that you contact support with details on the error messages, so that we can ammend things on our side for the future.

           

          - AND/OR -

           

          Option 2 - You have enabled the option "DAYS TO KEEP INVENTORY SCANS = (some non-0 value)" in the "CONFIGURE SERVICES" option (INVENTORY TAB). This option is often used by people first experimenting with it with small values such as "1" or "2" - the logic being that "well, a device should always be sending inventory in...".

           

          Problem being that some devices are off (people go on holiday), unavailable (laptop-users) for the network, or simply broken (/otherwise unavailable). So we recommend that this value always have a value of AT LEAST 90 if you already feel you must use it, and go from there. There's no "magic number" here, as it depends greatly on your processes what the right thing is for you.

           

          The "empty scans" you see are most likely just MINI-scans (device ID + hostname + network information), which will always get processed - and these entries get displayed with what (little) we have for them in the database.

           

          A full inventory scan (run the inventory shortcut adding "/F /SYNC" to the command line) may help out here .

           

          That should sort out 90%+ of such issues .

           

          Does this help?

           

          - Paul Hoffmann

          LANDesk EMEA Technical Lead

          • 3. Re: Why do some machines (device ID's) give a blank line for description\user and no inventory scans?
            Rookie

            Hi Paul,

                 

            Many thanks for the speedy response

             

            Yes I have 10 event ID 4100's from this year so far, most are duplicated though: (Bound adapter PRIMARYDNS I have 4 of these, BACKUPNAME have 5, and just 1 of unmodeled one-to-many relationship)

             

            The most recent are the PRIMARYDNS ones.

             

             

            Event Type: Error
            Event Source: LANDesk Inventory Server
            Event Category: None
            Event ID: 4100
            Date:  02/08/2010
            Time:  12:17:03
            User:  N/A
            Computer: IMGLANDESK
            Description:
            Database exception: SCAFB33.SCN, LDInv.dll
            -2147217887
            Multiple-step operation generated errors. Check each status value.

            Update Table:BoundAdapter Column:PRIMARYDNS PK:0, Thread ID: 24556.

             

            With Event ID: 4110 to go with it:

             

            Event Type: Error
            Event Source: LANDesk Inventory Server
            Event Category: None
            Event ID: 4110
            Date:  02/08/2010
            Time:  12:16:58
            User:  N/A
            Computer: IMGLANDESK
            Description:
            The size of BoundAdapter.PRIMARYDNS is too small. Increase its size by at least 1.

             

            Then multiple:

             

             

            Event Type: Error
            Event Source: LANDesk Inventory Server
            Event Category: None
            Event ID: 4100
            Date:  24/06/2010
            Time:  12:07:41
            User:  N/A
            Computer: IMGLANDESK
            Description:
            Database exception: SCAC39D.SCN, LDInv.dll
            -2147217887
            Non-nullable column cannot be updated to Null.

            Delete Table:ResAndRecoverBck Column:BACKUPNAME PK:5, Thread ID: 14728.

             

             

             

            Event Type: Error
            Event Source: LANDesk Inventory Server
            Event Category: None
            Event ID: 4100
            Date:  27/01/2010
            Time:  13:02:20
            User:  N/A
            Computer: IMGLANDESK
            Description:
            Database exception: SCAD9C9.SCN, LDInv.dll
            -2147467259
            Unspecified error

            Computer.LANDesk Management.Common wSoftware.Package.Attribute System is an unmodeled one-to-many relationship.  This is not supported., Thread ID: 9360.

             

             

            Hope this helps, and thanks again for the swift response

             

            Cheers  TED

            • 4. Re: Why do some machines (device ID's) give a blank line for description\user and no inventory scans?
              Rookie

              Sorry,

               

              Also meant to say that yes I had got the 'Keep Inventory Scans' set to 7 days, without realising the effect this was having.

               

              I have set it back to Zero after finding a Google post on a similar issue.

               

              Cheers  TED