6 Replies Latest reply on Feb 12, 2008 10:30 AM by tsmith

    Remote computer is not managed by...

    Apprentice

      I have at least one PC upon which LD could not install the agent.  I traced this down to a problem in DNS.  This has now been fixed ( two days ago ).  While the agent installation was successful, LD still isn't showing a normal inventory.  Just the computer name and the TCP/IP entry when you insert a computer manually.  I can ping the computer using either its name or address, from the core server.  No problem.  I can access the admin share from the core server, no problem.

       

      -


      Note that this one PC is the "Tablet" version of XP.  It's the only one we currently have.

      -


       

      I tried to connect with the Tablet version PC, but LD said: "The remote computer is not managed by your server.".

       

      We have three (3) other PCs on which the agent is installed, but LD hasn't performed an inventory.  ( no inventory data available )

       

      Any suggestions or just thoughts?

       

      Thanks in advance,

       

      Tom

        • 1. Re: Remote computer is not managed by...
          Employee

           

          Tom,

           

           

          Simple things to try:

           

          1. Are you using a FQDN for your server name? Can you ping the server by name and FQDN from the workstation?

          2. Try running the inventory scan with the /v switch so that you can see if it shows any kind of error. I think it runs this way by default from the start menu.

           

          If neither of those gets you anywhere, I would look in the C:\Program Files\LANDesk\ManagementSuite\ldscan directory on your core server. Look in the ErrorScan and ErrorTrans subdirectories to see if there are any scan files. If there are, you can check to see if they belong to your problem computer. If one of the files is related to the problem computer, you can generally find an entry in the servers application event log that will give you a little more detail about what kind of problem was encountered.

           

           

          If there are not any files in either of those directories, you could try turning off the database processing of the inventory service to see if the scan shows up in the ldscan directory. If it doesn't, you have client/server communication problem. You can turn off database processing from the Configure Services item on the menu from the console running on the core server.

           

           

          Vince

           

           

          1 of 1 people found this helpful
          • 2. Re: Remote computer is not managed by...
            Apprentice

             

            I've seen some similar issues on a few of our clients. I only see a mini scan in the database and even though the push install of the agent says successful, i never get full inventory back. Check to see what services are running on the box, I did not have all the services installed on the machines i was having issues with. The other thing that worked on a few of mine, was to manually delete the registry keys for landesk, delete all the client files by hand, and run Microsofts msizap to remove the installation information for the client. I then created a self contained exe for my client install and used this to install it and it worked. Hope that might help.

             

             

            You can download msizap here http://support.microsoft.com/kb/290301

             

             

            • 3. Re: Remote computer is not managed by...
              SupportEmployee

               

              Tom,

              Judging by the error message itself, it would seem that this is a certificate issue or perhaps the CBA agent is not running properly. From the core server, to connect to the client's CBA server to make sure (http://Client_Name_Or_IP:9595). Try doing a clean re-install of the agent, as previously suggested.

               

               

               

               

               

              Could you also let us know what happens when you manually try to run the client's Inventory Scanner shortcut (Start Menu > Programs > LANDesk Management > Inventory Scan)? Do you get an error message? Does it complete as expected?

               

               

              • 4. Re: Remote computer is not managed by...
                Apprentice

                1.)  I can connect to the CBA server on the errant PC using either its IP or name.  ( I checked this against my own PC just to make sure.  It likewise worked either way. )

                 

                2.)  Clean reinstall?  Yesterday afternoon I used the UninstallWinClient.exe program to uninstall the agent.  I did not remove LanDesk registry entries as was suggested.  I did run msizap.  Then I reinstalled the agent.  ( When I left last night, it was still running. )

                 

                -


                While I have worked in the registry and have both created and deleted keys, this time I felt unsure of what I was doing with the LanDesk entries, so I elected to leave them alone.

                -


                 

                3.)  This morning I checked on this machine.  As before, it was successful. When I checked this PCs inventory, it was still the "mini" inventory.

                 

                4.)  I tried to find a log file about the install and/or scan.  There are some 33 logs associated with LanDesk, and although I did open a few, I don't know which, if any, is the one I want.

                 

                5.)  I tried to perform a manual inventory scan:

                 

                Inventory Scanner

                -


                 

                Communicating with the LDSVR001

                 

                          Hardware:

                 

                    Device Drivers:

                 

                    Software files:

                 

                 

                 

                 

                 

                After about a minute or so, got this in response...

                 

                 

                LANDesk Inventory Scanner

                -


                 

                (X) LDISCN32: The inventory server LDSVR001 did not respond.

                 

                 

                Since I had not yet tried a manual scan on any machine, I tried it on mine.  Same result.

                 

                 

                Note that I can ping the server from either client, using either its ComputerName or IP.  Also note that I can ping either client from the server, using either its ComputerName or IP.

                 

                 

                What should I look at next?

                 

                Thanks in advance,

                 

                Tom

                • 5. Re: Remote computer is not managed by...
                  Employee

                   

                  Tom,

                   

                   

                   

                   

                   

                  I would check the following:

                   

                   

                   

                   

                   

                  1) Stop the inventory server service on the core server.

                   

                   

                  2) Go to the Landesk\ManagementSuite\LDSCAN folder and then the ERRORSCAN folder and delete any entries there.

                   

                   

                  3) In the LDSCAN folder, delete any entries there (not the folders) or move them to another folder somewhere.

                   

                   

                  4) Click StartRun> and run 'IISRESET  ' with no quotes.

                   

                   

                  5) Start the Landesk Inventory Server Service.

                   

                   

                  6) Go into the core server console under "Software License Monitoring" and click the button there labeled 'Make Available to Clients'

                   

                   

                  7) On the CLIENT machine, click startRun&gt; and enter "LDISCN32.EXE /L /I=http://<yourcorename>/LDLOGON/LDAPPL3.LDZ /F /V /SYNC  (change &lt;corename&gt; to your core server name, such as /I=http://CORESERVER01/LDLOGON/LDAPPL3.LDZ)

                   

                   

                  If this completes, check the core to see if the inventory record has updated or changed for that client.

                   

                   

                  If it fails with an entry saying that the core server did not respond, create an entry in the hosts file on the client to point towards the core server and try it again. If that fails, run "LDISCN32.EXE /L /I=http://<yourcorename>/LDLOGON/LDAPPL3.LDZ /F /V  /O=C:\CLIENTSCAN.SCN" -- this will create a CLIENTSCAN.SCN file on the root of C: on that system. Copy this file directly into the LDSCAN folder on the core. If it disappears , the machine record should either update in inventory or go to ErrorScan folder.

                   

                   

                  If the record simply doesn't update in the core console, check the following :

                   

                   

                  1) Look in the Windows application event logs and see if there's an error there.

                   

                   

                  2) Look in the LDSCAN\ERRORSCAN folder for a corresponding scan (SCN) file.

                   

                   

                  If this scan errors out and drops to your ErrorScan folder, we should have a corresponding entry in the App log. It looks to me like you're not even getting the scans back to the core, however.

                   

                   

                  Also, check to make sure you can telnet to port 5007 on the core from that client machine.

                   

                   

                   

                   

                   

                  • 6. Re: Remote computer is not managed by...
                    Apprentice

                    ...UPDATE...

                     

                    I have checked this thread as having been answered.  ( Although I'm not positive exactly what caused my problem to disappear. )

                     

                    Before I got the machine fixed that prompted this thread, I wound up with another.  So I went searching for an answer, once again.  ( Since I was working on this in my..."spare time"...several days may have passed between attempts to remedy my problem. )

                     

                    This time I found a possible solution that worked for me.  It said that I should try telnetting into the server from the client.  And if it didn't work, that I should stop and restart the LD Inventory service on the server.  I did.  And then I could telnet in.  And then I could connect to it, like I should be able to do.  And since this procedure worked for me for the newer client, I used it on the original problem client.  It worked for that one too.

                     

                    I haven't had time to go looking elsewhere, so I'm not sure what the real problem was.  Obviously an incorrect DNS entry doesn't help, so that did indeed need to be fixed.  But after that?  I don't know.  ( One of the suggestions had been to run an inventory scan manually.  But I couldn't.  Then I tried it on my PC, which LD has always been able to see and commnuicate with.  I couldn't on mine either.  Not until, that is, I stopped and restarted the Inventory service.  Go figure. )

                     

                    I'll keep all your suggestions in my docs file to use the next time I have this problem, and perhaps I can find out what the actual cause is.

                     

                    Thanks all for all your help.

                     

                    Tom