1 2 Previous Next 17 Replies Latest reply on Dec 9, 2011 7:39 AM by CenturyMatt

    Error Code 2869

    Employee

      Hi,

      at one of my cusomter place, i am getting the following error while installing LANDesk Service Desk.

       

      Error Code.jpg

       

       

      below are the activities which are followed

      1. Initiated Virtual OS of Windows Server 2008 Enterprise ( trial pack ) in VMWare
      2. Initiated IIS web service
      3. Installed MS SQL SERVER 2008 ( trial )

       

      Please suggest me as to why is this error coming and what should be done to resolve it.

       

       

      Regards

      Mitin

        • 1. Re: Error Code 2869
          masterpetz ITSMMVPGroup

          Hi Mitin,

           

          simple answer, deactivate the UAC on the w2k8 server.

           

          Best regards

          Christian

          1 of 1 people found this helpful
          • 2. Re: Error Code 2869
            Employee

            Hi Christian,

             

            Thanks a Lot

             

             

            Regards

            Mitin

            • 3. Re: Error Code 2869
              Rookie

              Dear Christian

               

              Even though disable UAC, and does all the permission setting, still getting the error 2869

               

              thanks

               

              Philip Lee

              • 4. Re: Error Code 2869
                ITSMMVPGroup

                run a command prompt as administrator and then run the setup.exe/msi file from there.  I find the appearance of a 2869 is quite hard to predict as sometimes the local admin accounts used for installation work just fine and others don't.

                • 5. Re: Error Code 2869
                  Rookie

                  Dear Dave

                   

                  I have tried what you suggested, I still get the 2869 error.

                   

                  By the way is server 2008 R2 64bit supported

                   

                  Thanks

                  • 6. Re: Error Code 2869
                    ITSMMVPGroup

                    I'd log a support call eith your local support eam and let them sort this out for you.  2008 R2 64 bit is supported with 732

                    • 7. Re: Error Code 2869
                      Julian Wigman ITSMMVPGroup

                      Hi,

                       

                      One thing to check here is if any services have been left installed even after you have apperently uninstalled Service Desk correctly. 

                       

                      This can cause that error you mentions as this caught me out too with 2008 R2 server; especially if you've attempted install a few times to get to this position.

                       

                      Now you've fixed the UAC/permission issues, this may be the cause IMHO.

                       

                      If the services atre still installed you can use "sc delete {Service Name}" from the CMD prompt to remove them before trying a re-install.

                       

                      Regards

                       

                      Julian

                      • 8. Re: Error Code 2869
                        Rookie

                        Thanks everyone who have replied, I solved the issue by reinstalling the application server and the iis server.

                        after which it is installed smoothly.

                         

                        One questions - I have a datas in the old database which I intend to use it back it is on ver 7.2.6, anyone can enlighten me how to convert it to

                        the new scheme to be use for ver 7.3.2

                         

                        thanks

                         

                        Philip Lee

                        • 9. Re: Error Code 2869
                          Rookie

                          Hi Phillip

                           

                          Thanks for your post. The solution for me was to ensure the following

                           

                          * logon as local admin, not domain admin

                          * delete the services using the delete sc "service name"

                          * reinstalling the app server roles and IIS

                           

                          This has worked on a wink28 R2 64bit standard running on a hyper-v machine

                           

                          Just trying to get the data imported now...

                          • 10. Re: Error Code 2869
                            Rookie

                            Dear Matt

                             

                            Any success in importing your data.

                            I am trying to convert the 7.2.6 to 7.3.2.

                            By importing or converting.

                             

                            Still struggling to do that.

                             

                            thanks

                             

                            Philip Lee

                            • 11. Re: Error Code 2869
                              Rookie

                              Hi Phillip

                               

                              This is a fresh install for me so there was no conversion required. The database setup wizard was giving me errors every time i tried to browse to the server. I imported the data manually from the sql 2008 management tool and it worked a treat.

                               

                              Next step for me according to the setup guide is setting up the connections.

                               

                              Hope this helps

                              • 12. Re: Error Code 2869
                                Julian Wigman ITSMMVPGroup

                                Are you talking about problems upgrading the database itself;  you are presumably running MDM (Metadata Manager) to perform the database upgrade?  You'll also need to run some individual TPS tools (utilities) too depending of where you are upgrading from.

                                 

                                This is all documented in the "73Upgrade.pdf" document on the documentation CD.  Remembering to backup your database first before you start though!!

                                 

                                Julian

                                • 13. Re: Error Code 2869
                                  Rookie

                                  Dear Julian

                                   

                                   

                                  I did run the TPS Tools and it gives error not matter what options is chosen

                                   

                                  below is the reproduction of the error -

                                   

                                  Unhandled Exception: System.ArgumentNullException: Buffer cannot be null.

                                  Parameter name: buffer

                                  at System.IO.MemoryStream..ctor(Byte[] buffer, Boolean writable)

                                  at Touchpaper.Framework.Data.Metadata.Internal.MetadataImage.ResolveReferences()

                                  at Touchpaper.Framework.Data.Metadata.MetadataCatalogServer.ResolveReferences(IMetadataList listMetadataObjects)

                                  at Touchpaper.Framework.Data.Metadata.MetadataCatalogServer.ResolveReferencesAfterLoad()

                                  at Touchpaper.Framework.Data.Metadata.MetadataCatalogServer.LoadFromDatabase(Boolean isIncremental, DateTime lastLoadTimestamp)

                                  at Touchpaper.Framework.Data.Metadata.MetadataCatalogFactory.LoadFresh()

                                  at Touchpaper.Framework.Data.Metadata.MetadataCatalogFactory.Create()

                                  at Touchpaper.Framework.Data.DataObjectFactory.LookupClassType(String fullClassName, Boolean throwExceptionIfMissing)

                                  at Touchpaper.Framework.Data.DataObjectFactory.CreateReader(IDataObjectContext context, String className)

                                  at Touchpaper.Classes.System.User.GetUser(String username, IDataObjectContext context, Boolean getPassword, Boolean getCurrentGroup, Boolean getUserType, Boolean includeSoftDeleted)

                                  at Touchpaper.Framework.SystemServices.Authenticator.TryExplicitLogon(ITpsCredentials tpsCredentials, ValidatedCredentials& validatedCredentials)

                                  at Touchpaper.Framework.SystemServices.Authenticator.ValidateCredentials(ITpsCredentials tpsCredentials)

                                  at Touchpaper.Framework.SystemServices.Authenticator.AuthenticateLogon(ITpsSession tpsSession, ITpsEnvironment environment, ITpsCredentials tpsCredentials)

                                  at Touchpaper.Framework.SystemServices.Authenticator.Logon(ITpsSession tpsSession, ITpsEnvironment environment, ITpsCredentials tpsCredentials)

                                  at Touchpaper.Framework.SoapClient.Local.LocalClientSession.Logon()

                                  at Touchpaper.Tools.TimeZoneConverter.Program.Logon()

                                  at Touchpaper.Tools.TimeZoneConverter.Program.Main(String[] args)

                                   

                                  Any clue from anyone one

                                   

                                  But looking at the overview to upgrading to V7.3 .x doc -

                                   

                                  it seems that I do not need to run the TPS tools only after the MDM

                                   

                                  correct me if I am wrong - upgrading from 7.2.6.

                                   

                                  thanks

                                   

                                  Philip Lee

                                  • 14. Re: Error Code 2869
                                    ITSMMVPGroup

                                    I'd review the upgrade guide a few times as it is quite a lengthy document and the order of doing this is important.  You run MDM first from a fresh copy of your 726 daabase and you make sure that works.  If it doesn't restore the DB, get help on the error and run MDM again.

                                     

                                    Then run the fixapplications settings TPS tool on it's own to allow it to fix up some potential issues - you need to give this tool your administrators password

                                     

                                    Then login into console, let it do some more parts of the upgrade and apply your new 7.3 key which you will need from your support team

                                     

                                    Then run the other tools in the TPS tools for other parts of the upgrade to complete.

                                     

                                    Then if you have WebDesk run those parts of the upgrade as in the guide.

                                     

                                    As a general guide, we tend to allow 1 day to do the upgrade from 7.2 to 7.3 and we have done a few, trust me!

                                    1 2 Previous Next