7 Replies Latest reply on Sep 1, 2010 8:43 AM by neil_p1000

    Imports from Excel

    neil_p1000 Apprentice

      I am currently trying to do an Import of servers into Landesk CMDB.

       

      The Data Import mappings were set up by a Landesk consultant and seemed to have worked fine, but on inspection not all servers have been loaded. I have checked all the data is in the correct format etc.. but no joy it will not load certain servers.

       

      I have even tried doing a new data Import with new mappings but still seems to only load partial data. When I check the log file it has no mention to these servers not being loaded so stumped.  The strange thing is though that when you test the Import the servers show up but do not load into the system.

       

      Any ideas? 

        • 1. Re: Imports from Excel
          ITSMMVPGroup

          Are you doing your tests on the server that is running data import itself?  I'd also check to see if there is any filter on the data import which is quietly removing certain types of record.

          • 2. Re: Imports from Excel
            Julian Wigman ITSMMVPGroup

            Also I'd suggest:

             

            1) If you havent already done so then setup a log file for the dataimport (bottom right on the Data Import Configuration window) and see if this has any more information it on the particular errors.

             

            2) Depending on your version of Service Desk (and patches applied) there has been issues in the past whereby items are not saved if an attribute wa blank in the source and the destination that attribute was writing to was a related  object (something like that anyway).   I've had this in the past too!

             

            Regards

             

            Julian

            • 3. Re: Imports from Excel
              neil_p1000 Apprentice

              Yes we were running the import from the server but there are no filters on. Just seems to be random what is Imported.

              • 4. Re: Imports from Excel
                neil_p1000 Apprentice

                After further investigation I have seen what the problem is:

                 

                Some of the fields we are importing are blank such as Purchase Date and Refresh Date on servers. I believe that the system is awaiting a date in theis field and thus when there is a blank field it will not Import. I tested this by putting in 01/01/1899 as a date and the the servers imported succsefully.

                 

                Is there a solution to this as not all fields will have a date applied such as a disposal date (not until it is disposed). Can blank field for dates be imported? 

                • 5. Re: Imports from Excel
                  Julian Wigman ITSMMVPGroup

                  Does the "Import Empty Values"  option do anything useful here (ie right-click at root of Target tree).?

                  • 6. Re: Imports from Excel
                    karenpeacock SupportEmployee

                    Hi

                     

                    I've just had a little play around with this.  The "import empty values" doesn't seem to work for me on a date field.  However, formatting the column to be a date format column in excel does seem to do the trick for me.

                     

                    To do this:

                     

                    In excel high-lighting the row(s) in question and selecting Format Cells then selecting Date and select the format required.

                    OR

                    For some reason Excel doesn't always seem to do this properly (haven't worked out why or what versions of Excel etc..).  So if this doesn't work for you try this:

                    • Highlight a single column that contains numbers and select ‘Data, Text to Columns…’
                    • Accept the defaults on the first two pages of the wizard.
                    • In the third, change the column data format to ‘Date’ and click ‘Finish’.
                    • This changes any numbers in that column into date format. 

                     

                    You will need to repeat this for each column that contains NULL dates and save the spreadsheet before trying the import again.  We've seen a similar thing with text fields in the past : http://community.landesk.com/support/docs/DOC-6996

                     

                    Please let me know how this goes and I'll update the community article if it works on dates too. 

                     

                    We have a problem record raised for this issue too which is 3440 so that data import tells you where the error is in the spreadsheet.  If you log this with your support provider we will get your issue linked to the problem id too.

                     

                    Best wishes

                    Karen

                    1 of 1 people found this helpful
                    • 7. Re: Imports from Excel
                      neil_p1000 Apprentice

                      The only way round I have come up with is to add a dummy date (01/01/1900). Obviously not ideal but allows me to add the 9000+ records I need to get into our system.

                       

                      I am going to log this with the LANDesk Support Desk, to see if there is a better solution. Will let you know how I get on