3 Replies Latest reply on Sep 17, 2010 10:08 AM by Terry_Courtney

    Failed to download all additional files for a package (LD9 SP1)

    Apprentice

      I've been getting the above error in package deployments to a particular site. We use a management gateway, and the sites are not necessarily directly connected to our core. For all (4) computers at one site, I get this error for just about all my deployments, including the ones that are 1 liner batch files. Here's an example log:

       

       

      Processing package : UAC ON Full
      Thu, 16 Sep 2010 19:57:21 File (http://<CORE FQDN>/ldlogon/packages/UAC-ON-full.bat) is not in cache
      Thu, 16 Sep 2010 19:57:23 Performing TCP connection with a timeout of -1 milliseconds
      Thu, 16 Sep 2010 19:57:29 ILdDownloading file to C:\Program Files\LANDesk\LDClient\SDMCache\ldlogon\FileLists\taskmanifest.<CORE NAME>.147.54.ini, attempt 0
      Thu, 16 Sep 2010 20:02:31 ILdDownloadFile returned 80004005
      Thu, 16 Sep 2010 20:02:31 ILdDownloading file to C:\Program Files\LANDesk\LDClient\SDMCache\ldlogon\FileLists\taskmanifest.<CORE NAME>.147.54.ini, attempt 1
      Thu, 16 Sep 2010 20:05:03 ILdDownloadFile returned 80004005
      Thu, 16 Sep 2010 20:05:03 ILdDownloading file to C:\Program Files\LANDesk\LDClient\SDMCache\ldlogon\FileLists\taskmanifest.<CORE NAME>.147.54.ini, attempt 2
      Thu, 16 Sep 2010 20:07:35 ILdDownloadFile returned 80004005
      Thu, 16 Sep 2010 20:07:35 ..\AdditionalFiles.cpp(68): (8DAC4026): Failed to download file http://LANDesk.Gateway@<CORE IP>/ldlogon/FileLists/taskmanifest.<CORE NAME>.147.54.ini : (80070002)
      Thu, 16 Sep 2010 20:07:36 processing of package is complete, result -1918091226 (0x8dac4026 - code 16422)

       

       

      If I look at the machines in question, they often have one of the @@@Partial download@@@ files sitting in SDMCache. Any ideas?

        • 1. Re: Failed to download all additional files for a package (LD9 SP1)
          Apprentice

          Hi Ken,

           

          Do the machines at this remote site have gateway certificates for your gateway?

           

          I dont believe that your clients at this site would be able to use the gateway for software distribution if they cant see the core unless they have a management gateway certificate installed.

           

          If you were to look in the C:\Program Files\LANDesk\Shared Files\cbaroot\broker folder on one of these machines, you should see a broker.crt .csr and .key

           

          Of course this may already be the case since you are in a management gateway environment already. But it seemed sensible to ask looking at the error.

           

          On another note, within BrokerConfig.exe located in C:\Program Files\LANDesk\LDClient on the remote site PC, under the Gateway Information tab, is the IP address assigned for the management gateway correct?

           

          Cheers

           

          • 2. Re: Failed to download all additional files for a package (LD9 SP1)
            Apprentice

            Hi Terry,

             

            The machines definitely have the correct gateway config; they can (and do) still send inventory scans, etc. '

             

            Thanks!
            Ken

            • 3. Re: Failed to download all additional files for a package (LD9 SP1)
              Apprentice

              Ok Ken,

               

              Now when the policy is being collected what does the proxyhost.log file say on the client?

               

              Also does the taskmanifest.ini mentioned in the logfile you posted appear in ldlogon\filelists\  ??  (If not either restart the task or create a new one)

               

              Is there a proxy running at the remote site?

               

              Have you tried creating the package again from scratch?

               

              Sorry to ask so many questions, but these ones can be tough cookies to crack!

               

              Cheers