4 Replies Latest reply on Sep 23, 2010 2:45 PM by dmshimself

    Emails with Chinese chars are not importing

    Adam Wilden Expert

      Hi,

       

      A lot of our new students are Chinese or Korean and are sending us emails using non-Western characters in the Sender field.

       

      Mail Manager doesn't import any of these.

       

      Has anyone else seen this or have a fix?

       

      We are unning 7.3.1 on Server 2008 and our mail servers are based on Exchange 2007.

       

      At the moment we are checking the mailbox manually every day but this rather defeats the object.

       

      Many thanks - Adam.

        • 1. Re: Emails with Chinese chars are not importing
          Adam Wilden Expert

          Some more info:

           

          The errors we are getting are Unique constraints:

           

          Failed to create user role for User: XXXX3 Role KU-UnknownUser ORA-00001: unique constraint (LD_BTO.INDEX$TPS_USER$NAME) violated
          Failed to create user role for User: XXXX3 Role KU-UnknownUser ORA-00001: unique constraint (LD_BTO.INDEX$TPS_USER$NAME) violated

           

          (This forum won't allow me to post teh non-western chars above so I have replaced them with X's! - see attached screenshot)

           

          However these users do not exist in the User base.

           

          If I search for any of these you get the same user returned, whose username is "¿¿¿3"

           

          Likewise if you search for just the first 3 chars of either the above you get the same, different, user whose username is "¿¿¿"

           

          It looks like LANDesk can't handle the non-Western chars, is replacing them with "¿" when creating the username (from the mailname?) and thus getting confused with an existing username, so not creating the new user or allowing the call to be logged...

           

          Any help gratefully accepted as this is very important to us - these are potential new customers!

          • 2. Re: Emails with Chinese chars are not importing
            dmshimself ITSMMVPGroup

            Adam, I'm fairly sure the only languages formally supported are English, German and French.  In terms of things to try I'd make sure that MDM has been run to convert all attrubutes, including user ones, to unicode in a test environment.  The character set of choice for the DB is I believe described here :-

             

            http://community.landesk.com/support/docs/DOC-16702

            • 3. Re: Emails with Chinese chars are not importing
              Adam Wilden Expert

              Hi Dave,

               

              We ran MDM when we upgraded to 7.3.1 and are currently set to WE8MSWIN1252.

               

              However all of our other support databases have now been changed to UTF-8 to allow for our international customer base.

               

              I'm assuming we can't just convert to Unicode.

               

              Think I need to log this with support as is a bit of a show stopper for us...

               

              Unless there is a way to force new emails to map the email address to the ID {RaiseUser} field rather than the display name?

               

              Cheers - Adam.

              • 4. Re: Emails with Chinese chars are not importing
                dmshimself ITSMMVPGroup

                Defintely get it with support.  MDM does the unicode 'conversion' but it's easy for the check box in MDM to be missed and there are system and as well as user attributes.  The issue might be one of formal support for Chinese as in the past I've seen issues in portal as well.