3 Replies Latest reply on Oct 21, 2010 9:40 AM by jmac

    Can't modify owner

    Expert

      I have created some provisioning templates and want them to be available in "All public templates". I tried to drag/drop from "All my templates" and it wouldn't move. I then tried to copy/paste and they now appear, but no longer appear under "All my templates". So I tried to move/copy back and now I get "Can't modify owner". Are provisioning templates not like other objects in LDMS that can be moved/copied between My/Public/All folders?

        • 1. Re: Can't modify owner
          Expert

          Anyone else having this problem or am I the lucky one?

          • 2. Re: Can't modify owner
            Apprentice

            I noticed this also.  I just right click the item and "Make a Private Copy" then delete the public one.

            • 3. Re: Can't modify owner
              Expert

              Thanks for your help with this Joe.

               

              The problem with the provisioning templates is that once they are in public as a group of three of them they would need to be unincluded from each other in order to be moved to private.

               

              When a template is private it can include (or be included by) other templates that are privately owned by the same user or any public templates. When they are public they need to be only associated with templates that are public. When you try to go from private to public it is able to individually move each on in the correct order so you don't have any included packages that have a more strict ownership set than the others.

               

              The other direction (public to private) this is not true. If you separate the templates (remove includes) then you can individually move them back and then reinclude them into each other.