2 Replies Latest reply on Oct 19, 2010 2:03 PM by mculmone

    FTR Gold Player packaging problems

    Rookie

      I'm trying to package a simple install shield application.  I have the Unattended Silent install script from the vendor and the command line.  It runs perfect when executing it from the command line manually but if I set up an exe distribution task it fails. I get error: 'User defined status -3 (reboot needed).  The log shows code 65533, a reboot was tried of course but didn't make a difference.  I've tried running it from source and running normally.  The first error is produced if running from source.  When running normally where the files download to sdmcache the download stalls and never completes.  I can run the commands from a command prompt as system as well.  Any help would be great!  Thanks

        • 1. Re: FTR Gold Player packaging problems
          Rookie

          We are attempting to create a package as well and have received the same result, but we do not have the vendor unattend install script. Can you post the script? What version are you trying to install? Also, have you tried creating a batch file using the command line syntax and then create a bat file distribution package?

          • 2. Re: FTR Gold Player packaging problems
            Rookie

            If a reboot is being triggered from the install then you need to pass LANDesk an exit code to tell it that the install is fine and has performed correctly. I've used the following in a batch file in the past.

             

            @echo off

            .\Application.exe

            IF “%ERRORLEVEL%”==”3010” EXIT /B 0
            IF "%ERRORLEVEL%"=="1" EXIT /B 0


            cls

             

            This will run the executable file along with any command line parameters. Exit code 3010 and 1 are classic exit codes from Install Shield installers which indicate a successful install or a reboot required.