3 Replies Latest reply on Jan 31, 2008 5:27 AM by zman

    Capturing/Deploying Image Issues on Netapp?

    Apprentice

      This has happened before once but was resolved because of the wrong domain/administrator account. I have checked this but i cannot get further with the Capturing the Image. On the target machine it shutsdown and boots into a LANDesk white imaging screen. Dos prompt box appears and i see connection cmds going through and then back to the white screen hangs. The scheulde job finally doesnt work. timesout and this below is what i see in the log files.

       

      "TEST-CJ52YU1DJU","OK",0,0:00:11,1/31/2008 7:06:01 PM,1/31/2008 7:06:12 PM,"<qt/>C:\Program Files\LANDesk\LDClient\lddefrag.exe<qt/> <qt/>C:\Program Files\LANDesk\LDClient\ldvpe0.img<qt/>, STATUS"

      "TEST-CJ52YU1DJU","OK",0,0:00:01,1/31/2008 7:06:12 PM,1/31/2008 7:06:13 PM,"<qt/>C:\Program Files\LANDesk\LDClient\bootfile.exe<qt/> C:\Program Files\LANDesk\LDClient\ldvpe0.img /keep /bootunsafe, ASYNC"

      "TEST-CJ52YU1DJU","OK",0,0:01:10,1/31/2008 7:06:13 PM,1/31/2008 7:07:23 PM,"WINPE, TIMEOUT=1800"

      "TEST-CJ52YU1DJU","OK",5,0:00:04,1/31/2008 7:07:23 PM,1/31/2008 7:07:27 PM,"diskpart /s X:\LDClient\rmvol.txt"

      "TEST-CJ52YU1DJU","ERR_Fail",-1917190197,0:02:12,1/31/2008 7:07:27 PM,1/31/2008 7:09:39 PM,"drvmap.exe asiapac\administrator 108A5173F2A0933255D0A30665D I: <qt/>
      hammer\software<qt/>, STATUS FACILITY=3513"

      "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

       

       

      in the scehduled job task window it states under results- Unknown status code (0x8DB9FFCB,3513:65483)

       

       

      Looks like the ASIAPAC\Administrator is failing to map the drive I: to //hammer/software. Last time Zman passed on details that it could be:

       

      +

       

      • Rights issue - account does not have rights to the share * Name resolution issue can't resolve server+
             + otto * I think if drive I: is already mapped it will fail. However im able to access this share via the admin account and write to it, so i dont think its a permissions issue. I can even map a drive to it. The share is on a netapp so im not sure where to go with this.

       

       

       

       

       

      Any advice

       

      +

        • 1. Re: Capturing Image Issues?
          Apprentice

          I just wanted to add, i have tested this image captue to a folder share on a notebook which had full rights to everyone. this worked. So it seems its the NETAPP folder share that is the problem. What i cant work out is, i can connect to the netapp share, write to to it (under the admin account, which the image capture is using) but for some reason im getting the above error in the log file.

           

           

           

           

           

          any ideas what i may need to do on that netapp share?

           

           

          i was able to as mentioned before capture an image to a folder on a windows share with permissions set at full control at everyone. I thought i would copy this image file to the netapp share and it has copied over fine. I tried to deploy this image from this netapp share and i cannot do this. has anyone done this via a netapp share? what do i need to do to make this work?

           

           

          from a windows share it works fine when set to everyone FC.

          • 2. Re: Capturing Image Issues?
            phoffmann SupportEmployee

            Since you're using DISKPART as part of your OSD script, I am assuming you're using WinPE as your OSD environment.

             

            Best way to troubleshoot this is to bring up a command-line interface (I'm assuming you know how to do this?) once PE is loaded, and run through the commands one by one. In WinPE you've got at least useful little things like "ping" and such right out of the box.

             

            Now - one thing I'm curious about - have you tried using a local account for the NetApp share?

             

            Under DOS, historically, I've seen that domain-authentication could sometimes not work for this or that reason (DC didn't feel like responding to DOS, etc.) causing timeout and authentication errors. Back then, I've gotten into the habit of using LOCAL accounts of the file-servers I'm hitting. Doesn't need to be an admin-account (since you only need to hit a share).

             

            Does that work better for you per chance?

             

            Also, you might want to make sure that you don't have name-resolution problems. A little "help" by adding entries into the HOSTS and LMHOSTS files might help out here (I'm assuming that your Netapp has a fixed address)?

             

            Remember, if you're going to use "Net Use" as a testing method, you cannot use IP's. It needs NETBIOS (hence the LMHOSTS).

             

            Hope this helps.

             

            Paul Hoffmann

            LANDesk EMEA Technical Lead.

            • 3. Re: Capturing Image Issues?
              zman Master

               

              Try what Paul has suggested. Netapp filers to my memory emulate Windows 2000. I think there is a way to hack them and do a null session share, but it is something our storage people did not want to pursue. One thing I would try is use a domain username and password to get to that share. Make sure the user has write capabilities to that share instead of  asiapac\administrator