6 Replies Latest reply on Oct 15, 2010 3:10 AM by BlairK

    Multicast Deployment across vlans on Cisco Network

    Apprentice

      We have a core layer 3 switchport 3750 and we have a network of 50+ vlans with Layer 3 Routing.

       

      We want to use Multicast to deploy our images to the deskstops and thus far are having no luck.

       

      We have configured the Layer 3 Switch for what we believe enables Multicasting

       

      Conf t

      ip multicast-routing distributed

       

      Conf t

      int vlan x1

      ip pim sparse-dense-mode

       

      Conf t

      int vlan x2

      ip pim sparse-dense-mode

       

      We run the task using Multicast Download in the options of the OSD however we are watching the task on the sever and when it goese through the multicast election it is not even picking something up and it just fails the whole multicast task.

       

      Please can someone add the missing links or what is happening with the Multicast Reps because I believe this is the first problem.


      Thanks

        • 1. Re: Multicast Deployment across vlans on Cisco Network
          Employee

          Hi Shaun

           

          I do not have any Cisco network appliance in here , so I cannot test your specific scenario. Did you tried to add a ip directed-broadcast command at the interface level ? IMO If your Cisco forward directed UDP broadcasts and there will be Windows clients that can act as multicast domain representatives on the subnet you're deploying to, you should be fine

          • 2. Re: Multicast Deployment across vlans on Cisco Network
            Apprentice

            Still nothing at all, I am pasting the log from the OSD Task for your use.  It is like the Multicast Rep is not going through the process and it is being dropped.

             

            IP Directed Broadcast is on in the Vlan where the Landesk Server is, we also tried it on in the Vlan where the clients are.

             

            Start Task Log --->

             

            "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"

            "002622D6972A","OK",0,0:00:00,14/10/2010 11:42:49 AM,14/10/2010 11:42:49 AM,"WINPE, TIMEOUT=1800"

            "705AB65E99F8","OK",0,0:00:00,14/10/2010 11:42:50 AM,14/10/2010 11:42:50 AM,"WINPE, TIMEOUT=1800"

            "002622D6972A","OK",5,0:00:04,14/10/2010 11:42:49 AM,14/10/2010 11:42:53 AM,"diskpart /s X:\LDClient\RMVOL.TXT"

            "705AB65E99F8","OK",5,0:00:03,14/10/2010 11:42:50 AM,14/10/2010 11:42:53 AM,"diskpart /s X:\LDClient\RMVOL.TXT"

            "002622D6972A","OK",0,0:00:01,14/10/2010 11:42:53 AM,14/10/2010 11:42:54 AM,"diskpart /s X:\LDClient\WIPEDISK0PART1.TXT"

            "705AB65E99F8","OK",0,0:00:03,14/10/2010 11:42:53 AM,14/10/2010 11:42:56 AM,"diskpart /s X:\LDClient\WIPEDISK0PART1.TXT"

            "002622D6972A","OK",0,0:00:05,14/10/2010 11:42:54 AM,14/10/2010 11:42:59 AM,"X:\LDClient\diskinfo new_temp_partition 2921 g NTFS , STATUS"

            "002622D6972A","OK",0,0:00:00,14/10/2010 11:42:59 AM,14/10/2010 11:42:59 AM,"reg add HKLM\SOFTWARE\Intel\LANDesk\LDWM\Distribution\Multicast /f /v <qt/>Cache Directory<qt/> /t REG_SZ /d g:\"

            "002622D6972A","OK",0,0:00:01,14/10/2010 11:42:59 AM,14/10/2010 11:43:00 AM,"X:\ldclient\tmcsvc.exe /no_service, ASYNC"

            "705AB65E99F8","OK",0,0:00:04,14/10/2010 11:42:56 AM,14/10/2010 11:43:00 AM,"X:\LDClient\diskinfo new_temp_partition 2921 g NTFS , STATUS"

            "705AB65E99F8","OK",0,0:00:01,14/10/2010 11:43:00 AM,14/10/2010 11:43:01 AM,"reg add HKLM\SOFTWARE\Intel\LANDesk\LDWM\Distribution\Multicast /f /v <qt/>Cache Directory<qt/> /t REG_SZ /d g:\"

            "705AB65E99F8","OK",0,0:00:00,14/10/2010 11:43:01 AM,14/10/2010 11:43:01 AM,"X:\ldclient\tmcsvc.exe /no_service, ASYNC"

            "002622D6972A","OK",0,0:00:15,14/10/2010 11:43:00 AM,14/10/2010 11:43:15 AM,"SLEEP"

            "705AB65E99F8","OK",0,0:00:15,14/10/2010 11:43:01 AM,14/10/2010 11:43:16 AM,"SLEEP"

            "(FAILED) 705AB65E99F8","FAILED",1306,"0:00:00","14/10/2010 11:43:46 AM","14/10/2010 11:43:46 AM","Targeted Multicast"

            "(FAILED) 002622D6972A","FAILED",1306,"0:00:00","14/10/2010 11:43:46 AM","14/10/2010 11:43:46 AM","Targeted Multicast"

            "(FAILED) 002622D6972A","FAILED",1306,"0:00:00","14/10/2010 11:44:17 AM","14/10/2010 11:44:17 AM","Targeted Multicast"

            "(FAILED) 705AB65E99F8","FAILED",1306,"0:00:00","14/10/2010 11:44:17 AM","14/10/2010 11:44:17 AM","Targeted Multicast"

            ; "Job Complete","0 Done","4 Failed","0 Off","0 Unknown"

             

            End Task Log

             

            That is all the information I have to go with at the moment.

            • 3. Re: Multicast Deployment across vlans on Cisco Network
              Employee

              Hi Shaun ,

               

              Does your image contains multiple partitions ? Is the image bigger than 2 GB ?

              • 4. Re: Multicast Deployment across vlans on Cisco Network
                Apprentice

                Yes the image is 4GB.  Is there a limit to the size of the Image in terms of deployment there is not multiple partitions.

                • 5. Re: Multicast Deployment across vlans on Cisco Network
                  Employee

                  Hi Shaun,

                   

                  Yes OSD Multicast has the follow limitation in 8.8

                  -1   needs to be a single partition image

                  -2   2GB limit for the image size

                  -3   Image must be stored on a UNC share that is a null session share

                   

                  I think this limitation still exist in 9.0  You can try to build an image that is less than 2GB and have a go with it,

                   

                  -If still you get the same error you may consider to have a look at this community doc:

                  http://community.landesk.com/support/docs/DOC-7946

                   

                  -If it works ,and you still want to use multicast ,you may try to split the image in chuks of 2GB as workaround, and raise an Enhancement Request from the relevant section in the portal

                   

                  Hope this helps

                  • 6. Re: Multicast Deployment across vlans on Cisco Network
                    BlairK Apprentice

                    Not withstanding the additional issues with what you are trying to achieve, as Frank's points are valid. But regarding the initial MDR election process, I would advise the following steps:

                     

                    1. Confirm UDP/TCP Port 33354 can transcend between core server VLAN and MDR VLAN.

                    2. Confirm UDP Port 33355 can transcend between MDR and Target Client. (Local Subnet Multicast)

                     

                    PortQry is an example, Microsoft utility that would allow you to test this. There is a GUI version available. See screenshots.

                     

                    3. As a test, what happen's if you manually specify an MDR on the troublesome VLAN. You do this under the Configuration tree within the console network view. Drag the desired MDR to the Multicast Domain Representatives list (Has to be a device with LANDesk agent obviously). Does the job go further?