8 Replies Latest reply on Oct 28, 2010 7:24 PM by rayjen0919

    How to deploy IE8 to WINXP/WIN7

    Apprentice

      Dear all,

       

      Please help to solve this problem.

      I can't deploy IE8 to XP client PC by software distribution.

      Any idea?

      The schedule status shows the client PC was found and connected successfully!

      But nothings gonna happen in that client PC, Please HELP!!!

       

      MANY THANKS!

       

      RAY

        • 1. Re: How to deploy IE8 to WINXP/WIN7
          Expert

          What version of LANDesk are you using and are you using patch manager? What messages are you getting and have you checked the log files?

           

          If your not using patch manager, what method of software distribution are you using. Be sure you have downloaded the stand alone and not the web install. You will also want to check that you have specified the install switches correctly and check to see if there are any messages in the event logs.

          • 2. Re: How to deploy IE8 to WINXP/WIN7
            Apprentice

            Our version should be Landesk 9.0 and target PC is windows XP.

            After I start the deploy schedule, the task manager in target PC shows the processes but CPU usage remains "00".

             

            tasks.JPG

            In schedule tasks windows, it show the schedule status is Active, the result is Machine successfully discovered but nothing is continue to process.

             

            The Log message:

            Fri, 15 Oct 2010 09:14:32 2884: Service Host Started, Host bg-pc-itd10.belle.local:9595, Peer 172.30.34.14, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:14:32 2884: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:14:32 2884: Anonymous connection established
            Fri, 15 Oct 2010 09:14:32 2884: Request Received "GET /allowed/ldping HTTP/1.1"
            Fri, 15 Oct 2010 09:15:03 3468: Service Host Started, Host bg-pc-itd10.belle.local:9594, Peer 172.30.16.8, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:15:03 3468: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:15:03 3468: Cached certificate EXPIRED   cached(0) now(129315789030665189)
            Fri, 15 Oct 2010 09:15:03 3468: Caching newly created certificate
            Fri, 15 Oct 2010 09:15:03 3468: Anonymous connection established
            Fri, 15 Oct 2010 09:15:03 3468: Request Received "HEAD /services/filexfer HTTP/1.1"
            Fri, 15 Oct 2010 09:15:03 3468: Unauthorized client access of "C:\Program Files\LANDesk\Shared Files\cbaroot\services\filexfer.dll" was rejected (level 1, current auth 0).
            Fri, 15 Oct 2010 09:15:03 3468: EOF encountered parsing HTTP headers, client closed connection.
            Fri, 15 Oct 2010 09:15:03 3468: Service host has finished
            Fri, 15 Oct 2010 09:15:03 5068: Service Host Started, Host bg-pc-itd10.belle.local:9594, Peer 172.30.16.8, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:15:03 5068: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:15:03 5068: X509 Authentication via c415b9d5
            Fri, 15 Oct 2010 09:15:03 5068: Request Received "HEAD /services/filexfer HTTP/1.1"
            Fri, 15 Oct 2010 09:15:03 5068: getfile: Processing HEAD request for <C:\Program Files\LANDesk\LDClient\fileversion.exe>
            Fri, 15 Oct 2010 09:15:03 5068: EOF encountered parsing HTTP headers, client closed connection.
            Fri, 15 Oct 2010 09:15:03 5068: Service host has finished
            Fri, 15 Oct 2010 09:15:04 5536: Service Host Started, Host bg-pc-itd10.belle.local:9594, Peer 172.30.16.8, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:15:04 5536: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:15:04 5536: Anonymous connection established
            Fri, 15 Oct 2010 09:15:04 5536: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:04 5536: Unauthorized client access of "C:\Program Files\LANDesk\Shared Files\cbaroot\services\exec.dll" was rejected (level 1, current auth 0).
            Fri, 15 Oct 2010 09:15:04 5536: EOF encountered parsing HTTP headers, client closed connection.
            Fri, 15 Oct 2010 09:15:04 5536: Service host has finished
            Fri, 15 Oct 2010 09:15:04 4220: Service Host Started, Host bg-pc-itd10.belle.local:9594, Peer 172.30.16.8, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:15:04 4220: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:15:04 4220: X509 Authentication via c415b9d5
            Fri, 15 Oct 2010 09:15:04 4220: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:04 4220: Exec: Exec: Launch request <"C:\Program Files\LANDesk\LDClient\fileversion.exe" "C:\Program Files\LANDesk\LDClient\sdclient.exe"> (sync 1, timeout 21600)
            Fri, 15 Oct 2010 09:15:04 4220: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:04 4220: Exec: Exec: GetStatus: returning status 0 for terminated application 1010 (run state 0).
            Fri, 15 Oct 2010 09:15:04 4220: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:04 4220: Exec: Exec: GetStdOut - Returning stdout for application 1010
            Fri, 15 Oct 2010 09:15:04 4220: EOF encountered parsing HTTP headers, client closed connection.
            Fri, 15 Oct 2010 09:15:04 4220: Service host has finished
            Fri, 15 Oct 2010 09:15:04 5564: Service Host Started, Host bg-pc-itd10.belle.local:9594, Peer 172.30.16.8, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:15:05 5564: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:15:06 5564: Anonymous connection established
            Fri, 15 Oct 2010 09:15:06 5564: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:06 5564: Unauthorized client access of "C:\Program Files\LANDesk\Shared Files\cbaroot\services\exec.dll" was rejected (level 1, current auth 0).
            Fri, 15 Oct 2010 09:15:06 5564: EOF encountered parsing HTTP headers, client closed connection.
            Fri, 15 Oct 2010 09:15:06 5564: Service host has finished
            Fri, 15 Oct 2010 09:15:06 5408: Service Host Started, Host bg-pc-itd10.belle.local:9594, Peer 172.30.16.8, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:15:06 5408: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:15:06 5408: X509 Authentication via c415b9d5
            Fri, 15 Oct 2010 09:15:06 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:06 5408: Exec: Exec: Launch request <"C:\Program Files\LANDesk\LDClient\sdclient.exe" /p="http://172.30.16.8/web/Template/IE8-WindowsXP-x86-CHT.exe" /levels=3 /Hash=tqHqI9WcFiGaol/OH/5UTg== /FileListName="taskmanifest.SVMERCURY.108.35.ini" /FileListHash="/AV56L9dYmfkYp5eDLyRNw==" /exe /N /An /wan=50 /lan=75 /taskid=108 /core="SVMERCURY:172.30.16.8" /EnableVirtualAppShortcuts > (sync 1, timeout 21600)
            Fri, 15 Oct 2010 09:15:07 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:22 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:15:22 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:37 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:15:37 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:15:52 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:15:52 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:16:07 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:16:07 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:16:13 2884: EOF encountered parsing HTTP headers, client closed connection.
            Fri, 15 Oct 2010 09:16:13 2884: Service host has finished
            Fri, 15 Oct 2010 09:16:22 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:16:22 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:16:37 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:16:37 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:16:52 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:16:52 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:17:07 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:17:07 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:17:14 3356: Service Host Started, Host bg-pc-itd10.belle.local:9595, Peer 172.30.34.14, IP Address 172.30.34.14
            Fri, 15 Oct 2010 09:17:14 3356: Public key path C:\Program Files\LANDesk\Shared Files\cbaroot\certs
            Fri, 15 Oct 2010 09:17:14 3356: Anonymous connection established
            Fri, 15 Oct 2010 09:17:14 3356: Request Received "GET /allowed/ldping HTTP/1.1"
            Fri, 15 Oct 2010 09:17:22 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:17:22 5408: Request Received "POST /services/exec HTTP/1.1"
            Fri, 15 Oct 2010 09:17:37 5408: Exec: Exec: GetStatus: returning status for running application 588.
            Fri, 15 Oct 2010 09:17:37 5408: Request Received "POST /services/exec HTTP/1.1"

            How Come? Anything done wrong!?

            or I should post this patch via patch and compliance instead of distribution package?

            Many thanks!

             

            Ray

            • 3. Re: How to deploy IE8 to WINXP/WIN7
              Expert

              It looks like its waiting for something. Check the installer and the switches it is using. For it to start and then do nothing, it is most likely waiting for user input. As the app is running as the system account which is not a user, there is no one to provide the input.

              • 4. Re: How to deploy IE8 to WINXP/WIN7
                Apprentice

                Thanks!

                 

                I'll try to make it right!

                • 5. Re: How to deploy IE8 to WINXP/WIN7
                  Apprentice

                  I've create a batch like:

                   

                  start iesetup.exe /passive /norestart

                   

                  But just me PC can install IE8 successfully, other PC got no action.

                  Why?

                  It's very frustrated for me to deploy IE8 now.

                  Please help!!!

                  • 6. Re: How to deploy IE8 to WINXP/WIN7
                    Expert

                    Try /quiet instead of passive. IE8 comes with Win7.

                    • 7. Re: How to deploy IE8 to WINXP/WIN7
                      Expert

                      You might also want to try /update-no.

                      • 8. Re: How to deploy IE8 to WINXP/WIN7
                        Apprentice

                        I've already tried /quiet and /update-no~ the result came out equally.

                        I've try my PC, another PC and one notebook with updated agent and well connection.

                        Only my PC can successfully apply the IE8 upgrade.

                        So strange@