4 Replies Latest reply on May 31, 2011 11:51 AM by esumer

    Unable to use "start" in a batch file when set for Current User's Account after upgrading from 8.8 to 9.0 SP2

    Tom.Phillips Apprentice

      Just recently I have upgraded from 8.8 SP4 to 9.0 SP2 and have found several anomalies. One interesting one is using the "start" command in a batch file when running as the current user's account. This worked perfectly in 8.8 SP4, but now no longer.

       

      I created a very simple batch file:

      ___________________________________

      start %windir%\system32\notepad.exe

      exit /b 0

      ___________________________________

       

       

      and I set the distribution package to use the "Current user's account" to run the package. I use a policy supported push delivery method and even though it will correctly run the batch file and start notepad.exe, landesk still takes the return code as a failure.

       

      It is not a rights issue since it is actually executing the batch file correctly. The console says "Failed to install package" and the Return code is 16386 even though it ran correctly and I even returned a 0 at the end of the batch file using the exit /b 0 command (i have tried it with and without this and got the same results).

       

      I then tried to map the return code of 16386 to "Success" and I applied that to the ditribution package. I ran it and again notepad ran but Landesk still saw it as a failure.

       

      Anyone have any ideas? Is there an easy answer that I am just missing?

       

      Thanks