14 Replies Latest reply on May 5, 2011 1:37 AM by Lionel

    LDMS 9.0 SP2 - HII UNC error

    Apprentice

      Hi,

       

      I'm using the new features of HII, means using the copy driver via an UNC path. The problem is that no driver is copied.

      The HII action run fine, model detection also and on the client the LDDriverStore is created, all folders on it is also correctly created, but empty...

       

      If I run from WinPE, manually the command is always the same, nothing is copied. If I run an simple xcopy command, it's works?

       

      Any idea?

      Regards

      Lionel

        • 1. Re: LDMS 9.0 SP2 - HII UNC error
          Apprentice

          Hi Lionel

           

          Im guessing that Landesk SP2 has done the same to your LANDesk deployment as it did to ours - BROKE IT

           

          The solution to your problem for the time being would be to untick the "use UNC to deliver drivers" option on your HII task and request the patch (see below) when it becomes availible - although if you dont mind i would like to take this opportunity to moan and groan because doing this increased our build time by 20 - 40 minutes as downloading HTTP isnt the fastest.

           

          We were told that by installing SP2 we would be able to solve an issue with our OSD not joining the domain properly.  What it essentially did was stop the HII in our provisioning tasks, gave us errors with software deployments that we have never seen before, and with every client that i do get running cannot be contacted by our server anymore! Joy of Joys.

          (Before anyone add that i should report it - i have, and apparently they are working on a patch that would be availible in the next 2-4 weeks)

           

          Do i think we will be continuing with LANDesk for much longer - hmmmmmm, give me the patch and we shall see.

           

          Groan over, hope the above fixes your provisioning in the short term.

           

          Dave H

          1 of 1 people found this helpful
          • 2. Re: LDMS 9.0 SP2 - HII UNC error
            Expert

            Looking at this, I would have to guess that the problem is that there is a permissions issue with the unc path. There doesn't appear to be an option to specify user credentials. That might explain why HTTP is working and unc is not. Either that or the NIC driver is not installed during the OS installation step. Once the machine is completed, log in and see if the NIC is installed. If not, you need to fix that first.

            • 3. Re: LDMS 9.0 SP2 - HII UNC error
              Expert

              One other thing to look at, although its may not be the problem.

               

              http://community.landesk.com/support/message/39453#39453

              • 4. Re: LDMS 9.0 SP2 - HII UNC error
                Specialist

                My looks into this seem to be a more fundamental issue than it being permissions.

                 

                The HII via UNC copies the folder structure of the required drivers to the client machine however it doesn't actually copy the files.

                 

                Looks like someone screwed up the dll and it is doing a stuctural copy only and not including the sub-directories file contents.

                 

                I haven't raised a case with LANDesk about this yet as I've seen a few other comment on the forum which basically point at UNC HII being broken out of the box, so back to the old school HII copying which is painful when you have preferred servers!

                • 5. Re: LDMS 9.0 SP2 - HII UNC error
                  Apprentice

                  Hi,

                   

                  Jack is right. This is not a permissions issues, because the complete folder structure is created, but empty.

                  This simply doesn't work...

                   

                  @Jack: you mention to have the preferred server with HII. How can I have the ability to get the preferred server information?

                   

                  Many thanks

                  Regards

                  • 6. Re: LDMS 9.0 SP2 - HII UNC error
                    Rookie

                    thanks God, I'am not the only one who has this problem.

                     

                    Same symthoms. The folder structure creates. But no files in the folder. I#am using the old way with http. But I hope landesk or someone else find a solution.

                     

                    junky 

                    • 7. Re: LDMS 9.0 SP2 - HII UNC error
                      Apprentice

                      Hi All,

                       

                      I have opened a case to LANDesk support.

                      The CR00052423 exists and LANDesk is working on it. It's a confirmed bug of HII.

                       

                      Regards

                      Lionel

                      • 8. Re: LDMS 9.0 SP2 - HII UNC error
                        Specialist

                        Lionel, have you recieved a patch for this yet?

                        • 9. Re: LDMS 9.0 SP2 - HII UNC error
                          Specialist

                          Don't know if this would work for other, but I am currently using it in my provisioning template and it seem to work.  Instead of using the build in HII, I manually copy the hiiclient.exe to a share location within the tools share and then execute it manually.

                           

                          Here is what I put in during by Post-OS installation provisioning template

                           

                          Copy HII -

                           

                          source:           %shrTools%\Hiiclient.exe

                          destination:     X:\ldclient\hiiclient.exe

                           

                           

                          Execute HII

                           

                          x:\ldclient\hiiclient.exe /autodetect /ostype="Windows7" /uncpath=\\corename\ldmain\landesk\files\drivers

                           

                           

                          On another side note, have any of you have issue with the new virtual boot on SP2.  Apparently when execute on xp2 or windows 7 64 bit it error out.  I have opened a case about that issue and have since got a ldprovision.exe file patch but it didn't fix the issue.  For the moment I am using the template at http://community.landesk.com/support/docs/DOC-9980 and modify my bootwim for it to detect it is in provisioning however once in winpe it tried to execute bootfile.exe again and throw a false negative error then would continue.

                          • 10. Re: LDMS 9.0 SP2 - HII UNC error
                            Specialist

                            bump for an update....

                             

                            ....looking for an update, that is.

                             

                             

                             

                            We had this same problem with SP2 a while back.  Eventually it was resolved through a series of patches, however it recently stopped working again.

                             

                            Currently the HII phase of provisioning is really slow compared to what it is when it actually works.  Additionally the folder structure is created properly within C:\Windows\LDDriverStore, however every folder is empty.

                             

                            we have not applied the recent MCP for april yet...just wondering who has found a permanent resolution to this problem?

                            • 11. Re: LDMS 9.0 SP2 - HII UNC error
                              Apprentice

                              Hi,

                               

                              Yes I have the update... I will come with the next bunch of MCP patches.--> LD90-SP2-MCP_OSD-2011-0324

                               

                              Follow the web site to be able to get it when available.

                              Regards

                              Lionel

                              • 12. Re: LDMS 9.0 SP2 - HII UNC error
                                Specialist

                                Thanks lionel,

                                 

                                So I have mcp 0217 and OSD 0309 installed, MCP 0324 is in the queue but I have not been able to install it yet.

                                 

                                your post isn't clear to me; do you mean to say that MCP 0324 solves this problem?

                                 

                                OR

                                 

                                do you mean to say that the next MCP for april is 'supposed' to solve it?

                                 

                                thanks

                                • 13. Re: LDMS 9.0 SP2 - HII UNC error
                                  ProServices

                                  Hi,

                                  The HII action run fine, model detection also and on the client the  LDDriverStore is created, all folders on it is also correctly created,  but empty...

                                  Yep.. seen this on a compleatly clean installation of LDMS 9 SP2 Slipstream - and thought I was dealing with a strange permissions problem. Thanks for sharing this. Please report back if you find a patch that fixes it.

                                   

                                  Regards

                                  Ian

                                  • 14. Re: LDMS 9.0 SP2 - HII UNC error
                                    Apprentice

                                    Hi All,

                                     

                                    Sorry to be not so clear

                                     

                                    After applying the 2 patches MCP_OSD_0324 & MCP_SD_0324, HII works fine for me the folder are not anymore empty...

                                     

                                    These patches are not yet public, they should be available soon I hope, otherwise send me a PM.

                                     

                                    Regards

                                    Lionel

                                     

                                    UPDATE: The patches have been published yesterday

                                    http://community.landesk.com/support/docs/DOC-22561