3 Replies Latest reply on Dec 1, 2010 7:57 AM by dynamozappa

    FixUnattend.exe fails error -2147479552

    Apprentice

      I am trying to deply a windows 7 image using the sample windows 7 deployment template that i downloaded from the forums. I get to the point where it executes FixWindows.exe and it fails (see error code below). I am using LDMS 9 SP2. I have imported the FixUnatted and FixWindows scripts but it still fails.

       

      Does anyone know what this error means? -2147479552

       

      I have attached a screen shot of the failed provisioning template.

        • 1. Re: FixWindows.exe fails error -2147479552
          Apprentice

          this should be FixWindows.exe fails error -2147479552....sorry bout that.

           

          The sample template i am referring to is here:

          http://community.landesk.com/support/docs/DOC-9639

          • 2. Re: FixWindows.exe fails error -2147479552
            Apprentice

            So i tried it again to see if i could figure out what that error message means. Looks like it's not finding the fixWindows.exe file. below is the log file:

             

            action index=57963 type=Download_file
            SUCCESS
            action index=57964 type=Execute_file
            FAILED
            error:[80001000H]File x:\cba8\FixWindows.exe not found.
            Execute result:
            return:1
            output:

             

            the file is there but when i try to run it manually it says this:

             

            X:\cba8>fixwindows.exe
            retOS=1 osPartitionID=1 osPartitionDrive=c
            retSystemOS=0 systemPartitionDrive
            %c:\Boot\BCD does not exist

             

            and as you can see the provisioning template shows the download of FixWindows to be successful (image attached)

             

            im stumped.

            • 3. Re: FixWindows.exe fails error -2147479552
              Apprentice

              I guess the LD support team has been busy because i haven't gotten a response to this thread. But that is all good. They have been VERY helpful in the past. And besides, i figured out my problem.

               

              it turns out that i didn't need to use "fixwindows.exe" after all. Maybe you only have to use it when you are using imagew.exe (i use imagex) to capture and deploy your image. I ended up taking the "fixwindows" include in the template out of shear frustration and the image deployed ok. but it wouldn't boot. so a fellow LD user here on campus suggested i use BCDboot.exe, which sets up the partitions. turns out that was the magic tool. it worked. and i did NOT deploy the system partition. I had not found a clear answer before as to whether you had to capture and deploy the system partition. but you don't.....just so you know.

               

              i have attached a screenshot