13 Replies Latest reply on Feb 11, 2008 12:20 PM by someone1

    Trouble Imaging

    Rookie

       

      I created a Windows XP image using image.exe from LANDesk.  I captured this image on a USB Harddrive and then i successfully reimaged computers with this new image from the USB Harddrive using image.exe commands so i know the image is good.  My trouble is with using the LANDesk console to push the image to computer.

       

       

      We have other images on our LANDesk servers and they reimage just fine except this new one that i created.  I placed the image in a folder which i varified has the correct rights since i am able to use one of our older images just fine but not my new one.  I have also verified that the .BAT and .DIM files are not needed since again i was able to use our older image without the .BAT and .DIM files and reimaged computers just fine through the PXE boot menu.

       

       

      This image is in two parts (same as our old image) and i am out of ideas on how to get this to work.  What happens is that i choose it in the PXE Boot Menu and it goes through all the tasks such as Wiping the drive and Starting the imaging software and it flashes the blue screen progress bar and then goes right to WAITING FOR COMMAND.  The old image starts the blue screen progress bar and progresses just fine, this new image just flickers that screen and goes right to waiting for command.  Not sure what is wrong because again i know the new image is good since i reimaged computer just fine from the USB hard drive.  I have used the same folder, same scripting method(through the console to create the deploy script), same rights....everything the same as the older image but just no luck

       

       

      Has anyone run across an issue where is just blips the blue screen progress bar and then goes to Waiting For Command?  If you need more info please post since i am out of ideas and desperate.

       

       

        • 1. Re: Trouble Imaging
          Jared Barneck SupportEmployee

          It looks like you are using DOS based imaging...is that the case.

           

          There are all kinds of problems with it: Memory, network driver support, incompatibility with new features such as Gigibit cards, tcp checksums, etc... That is why we had to develop a WinPE solution.

           

          Also, knowing it is a good image on the USB drive doesn't mean it is good once you copied it.  Please run ImageW.exe on the server where the image is stored and validate the image.

           

          It could easily be that the image is fine but you are getting corruption during the transfer...that was one of the most common DOS issues.

          • 2. Re: Trouble Imaging
            Rookie

             

            Dos based yes.  I am trying to image a computer that is the same model (and parts) as the one i created the image with.  The older image works just fine on this model but mine does not going through LANDesk but the newer image installs just fine with the USB Hard Drive and running the commands manually.

             

             

             

             

             

            I haven't tried ImageW but i used Image.exe to create the IMAGE.EXE to create the image so should i use that to validate it also?

             

             

            I don't think i am getting corruption during the transfer since it really doesn't start it just blips the blue screen progress bar for less then a second, if you blink you miss it.

             

             

            • 3. Re: Trouble Imaging
              Jared Barneck SupportEmployee

              Image.exe and ImageW.exe are the same tool only one is compiled for 32 bit windows and one for 16 bit DOS.  There is also an imagel.elf compiled for Linux.  Any image captured with any of these versions of the same tool is exactly the same and can be deployed with any of the versions of this same tool.

              1 of 1 people found this helpful
              • 4. Re: Trouble Imaging
                Rookie

                Ok, I ran ImageW.EXE and it passed validation. Did you want me to try a restore with IMAGEW.exe and my image? I am almost positive that running this tool manually and entering any necessary commands manually will work just fine just like it images just fine by USB HDD but i just can't deploy this one image through the network.  My other images deploy just fine through the network without any hiccups.  Its odd that it still just blips the blue screen progress bar, you blink and you miss it.

                 

                Also, i haven't mentioned it but it might be worth noting that i am using LANDesk 8.6 SP2.

                • 5. Re: Trouble Imaging
                  Jared Barneck SupportEmployee

                  Yes.  You should use WinPE...but I don't understand why you have to do this manually.  Can't you create a WinPE OS Deployment script?

                   

                  Oh...you are 8.6 Sp2.  Time to upgrade if you want to have OSD to work well and not be a practice in DOS development every time you want to try a new machine.

                  • 6. Re: Trouble Imaging
                    Rookie

                    We haven't had any issue with imaging, we've been using three images now for 2 years with over 60 thousand desktops and laptops of various models without issue. Just trying to update the image since our current image needs about 60 Windows Updates. We will be updating to 8.7 probably around October/November 08 but for now we have to use what we got.

                    • 7. Re: Trouble Imaging
                      Jared Barneck SupportEmployee

                      I understand.

                       

                      It was mostly with newer machines that DOS suddenly becomes difficult.  The new NIC drivers, the different drive controllers (sometimes you have to image with your SATA controller in compatibility mode).

                       

                      My guess is that in this case your image is corrupted on transfer, probably by the DOS NIC driver.  You could try a different driver if there is one.

                       

                      Also, on the server side, make sure TCP Checksum offloading is turned off as DOS drivers cannot handle that.

                      • 8. Re: Trouble Imaging
                        Rookie

                        "My guess is that in this case your image is corrupted on transfer, probably by the DOS NIC driver. You could try a different driver if there is one."

                         

                         

                         

                         

                         

                        Well i did the original capture with a USB HDD for this image so the DOS NIC Driver shouldn't be an issue. To add onto the confusion though i decided to create a capture script and capture the image through the network and i recieve the same result.....it goes through all the tasks and then when it gets to the blue screen progress bar it just blips and then goes to a WAITING FOR COMMAND. This is very confusing. The computer itself is good and so far the image is good, i have reimaged 1 laptop and 1 HP and 1 Dell desktop without issue and they are running great.

                        • 9. Re: Trouble Imaging
                          Tracy Expert

                          Try editing your script and add 'REMEXEC333=command.com' right before the imaging command line. This will cause the imaging task to stop at a DOS prompt. Once there, check for the existence of c:\

                           

                           

                           

                           

                           

                          -Tracy

                          • 10. Re: Trouble Imaging
                            Jared Barneck SupportEmployee

                            Well i did the original capture with a USB HDD for this image so the DOS NIC Driver shouldn't be an issue.

                             

                            Aren't you using DOS to deploy the image?  I meant that during the deployment, the image is downloaded from the server and gets corrupted.  It comes down in a TCP stream in a million packets and has to be reassembled on the DOS environment.  The DOS NIC driver is very involved even if you captured using USB because it is used in the deployment.

                            • 11. Re: Trouble Imaging
                              Rookie

                              "check for the existence of c:\"

                               

                              Tried it and typed C: and it says "Invalid Drive Specification"

                               

                              I know C: is good since i can boot to a BARTPE disc and see and access C: just fine and it is my image (Windows XP SP2) on the C: Drive. I am going to try and capture one of my older images on a different computer with the same script and post back the results. Maybe it is the image somehow :S

                               

                               

                               

                               

                               

                              **EDIT: ok i just tried the capture script with the line edit on a different computer and i tried to access C: and recieved the same message.  I did just enter the commands "Command.com /c backall.bat 0 I:\test" and it went ahead and starting to capture the image on the second computer (with an older image).  I think what i will try is to use the USB HDD and deploy the image to another computer and i won't let it go into sysprep but i will try to capture it that way.  Will post a reply on what i find out.

                              • 12. Re: Trouble Imaging
                                Rookie

                                 

                                ok, so i deployed the image from a USB HDD to a different computer and before this computer went through sysprep and loading Windows i went ahead and restarted it and now i am capturing this image through the network.  I will let it finish and then will try to deploy it. 

                                 

                                 

                                I am still at a slight loss on what the issue was though.  Possibly the image or the computer itself since i couldn't even run a network capture on the Dell but i was successful on running a manual capture on the Dell.  Right now i am running a network capture on an HP...will post back what happens.

                                 

                                 

                                • 13. Re: Trouble Imaging
                                  Rookie

                                  Ok, all is working now.  I have captured through the network successfully and deployed to another computer through the network without issue.  I guess the original Dell computer just didn't want anything to do with the network.  Thanks for all your help, both of you.