2 Replies Latest reply on Nov 29, 2010 2:03 AM by emountaine

    Free text search

    Apprentice

      Version 7.3.2.

      webservers = 2

       

      Hi all,

      Please help . We now have two webservers up and running. They are not load balanced. My query here is around the free text search option in webdesk. On webserver 1 (itbmwebw2k3) it works fine. Webserver 2 however does not even thought the web.config is set to look to the right location. It appears to be an aspnet permission problem and this is where i get lost.

       

      Lucene is installed on webserver 1 (on a seperate logical drive). I have pointed webserver 2 to look to this location but when i run a free text search on webserver 2 i get the error attached. Funny thing is, i have shared out \\itbmwebw2k3\Lucene\index to everyone with full access and still get the error.

       

      The error message suggests to add the appropriate user or group.. can anyone tell me what these are?

       

      Thanks in advance.

      Ed

        • 1. Re: Free text search
          Julian Wigman ITSMMVPGroup

          Hi

           

          My first thought would be to open explorer on web server 2 and see if you can browse to the lucene index folder on web server 1 using the UNC path. If "everyone" does work then you presumably should be able to browse to it.

           

          You say it's shared to everyone;  is that an NT folder share, network share or both?

           

          I believe the account connecting to the share from web server 2 needs to be a domain account.   I'm running my application pools under a specific domain account rather than the default "network service" and I just use that in my network share for the index folder.

           

          Perhap instead of everyone (which i'd have thought should work) you could also try "domain users"?

           

          Just some thoughts on what can be a "black art".

           

          Regards

           

          Julian

          1 of 1 people found this helpful
          • 2. Re: Free text search
            Apprentice

            Hi Julian,

            Many thanks for your reply. I can browse to the share from the server in question so it must be that the service does not have access to the folder.

            Which windows service do i change to run as a domain account for the application pools?

            Found it... You were right all is working now.. the app pool needed to run as a domain account.. below is how it is set

             

            To specify an identity for an application pool

            You can perform this procedure by using the user interface (UI), by running Appcmd.exe commands in a command-line window, by editing configuration files directly, or by writing WMI scripts.

            User Interface

            To use the UI
            1. Open IIS Manager. For information about opening IIS Manager, see Open IIS Manager (IIS 7).


            2. In the Connections pane, expand the server node and click Application Pools.


            3. On the Application Pools page, select the application pool for which you want to specify an identity, and then click Advanced Settings in the Actions pane.


            4. For the Identity property, click the ... button to open the Application Pool Identity dialog box.


            5. If you want to use a built-in account, select the Built-in account option and select an account from the list.


            6. If you want to use a custom identity, select the Custom account option and click Set to open the Set Credentials dialog box. Then type the custom account name in the User name text box, type a password in the Password text box, retype the password in the Confirm password text box, and then click OK.


            7. Click OK to dismiss the Application Pool Identity dialog box.


             

             

            thanks again.

            Ed

             

            Message was edited by: emountaine