9 Replies Latest reply on Sep 13, 2011 1:43 AM by jary.busato

    AMP/vPro very flaky inconsistent

    Apprentice

      I've had a few cracks at making vPro work in different environments and so far I have to say the results have been at best random and at worst completely useless.  My latest attempt today is a perfect example of what I mean and I just thought I'd see if I could get the bottom of it because, on paper at least, LANDesk with vPro integration would be pretty powerful.

       

      This is my test setup:-

      Test device (Dell Optiplex 780) on my desk which supports vPro v5 and has the latest HECI drivers installed

      PID/PPS ID's generated on the Core (LDMS9 SP2)

      The vPro password has been set on the Core

       

      The first task was to get my test device provisioned using the PID/PPS ID.  I entered this information into MEBx and entered the IP of the Core Server in the Provisioning Server section (I don't currently have the provisionserver DNS entry).  When I rebooted the machine I had to wait a while (about 15 minutes) but eventually my device appeared in the UDD tool.

       

      I checked on the test device using Intel AMT driver interface and sure enough it was nowing showing as "configured".  As a further test I connected using a web browser from the Core to http://<devicename>:16992 and was able to connect using the password I had set in LANDesk.  So far so good.

       

      I then wanted to test the right click functionality in LANDesk so I selected 'Intel vPro Summary'.  This hung the console for about 5 minutes before eventually displaying the summary page but with no data in it.  I checked the AMTConfigDLL.log on the Core and noticed a number of HTTP 401 Unauthorised errors and repeated connection attempts.  I waited 5 minutes and tried to do the same thing again - right-click, Intel vPro Summary and guess what - it worked after about 30 seconds!  Immediately after this I tried again and it failed!!

       

      Very frustrating!  Would appreciate any insight.  I've attached two images of the vPro Summary screen - one when it worked and the other when it didn't.

       

      Cheers

      Steve

       

      vPro working.JPG

       

      vPro not working.JPG

        • 1. Re: AMP/vPro very flaky inconsistent
          Apprentice

          For anyone else that runs into similar issues, I seem to be making some progress.  After a few hours of trial and error, it turns out the the problem, on this occasion at least, is with the password I was using.  It seems that my password, although accepted by MEBx and functional when using the web console, gave me very sporadic results when used with LANDesk.  I found that starting from scratch with a new password, un-provisioning my test box and doing it all again yield much better results - dare I say encouraging!

           

          I still have to say that some console functions like vPro summary and boot manager are VERY slow to appear, whereas stuff like power on/off, reboot etc is almost instant.  This wouldn't be so much of an issue if it weren't for the fact the whole 32bit console hangs until whatever vPro is doing has finished and the screen you've been waiting for for several MINUTES is finally displayed!

           

          Still, better than yesterday

           

          Steve

          • 2. Re: AMP/vPro very flaky inconsistent
            Rookie

            Glad to hear that it is going better! There is a configuration guide for Intel vPro & LANDesk. You can find the most current version here: http://communities.intel.com/docs/DOC-1381. And a preparation checklist is here: http://communities.intel.com/docs/DOC-2070

             

            Michele Gartner

            Community Manager

            Intel vPro Expert Center

            • 3. Re: AMP/vPro very flaky inconsistent
              Apprentice

              Yes it seems to be consistent now at least, although I've not gone beyond a single test device in this environment yet.  I'd still like to see some improvement in the way the LANDesk Console behaves when performing vPro functions.  For example, when bringing up the vPro Remote Boot Manager screen, the console will not respond until the screen has appeared - which takes around a minute.  Whether it should take that long or not I'm not sure, it seems to be the same pretty much anywhere I've setup vPro with LANDesk.  However it would be much less of an issue if I could just maintain use of the LANDesk console while I was waiting!

               

              Do you know of any way to reduce the amount of time it takes to bring up this and other vPro dialog boxes from within LANDesk?  Or perhaps someone at LANDesk could explain why performing these actions causes the console to hang temporarily and possible ways around it?

               

              Thanks

               

              Steve

              • 4. Re: AMP/vPro very flaky inconsistent
                Rookie

                Hi! I asked around about this and found out that slowness has been seen in older versions of LANDesk - and that upgrading to the latest and greatest usually fixes the issue - could that be the problem?

                • 5. Re: AMP/vPro very flaky inconsistent
                  Rookie

                  Hi Steve,

                   

                  Have you had any more luck with this?

                   

                  We have the exact same issue with the slowness of some vPro functions.  Are you also using the KVM function that is built into AMT 6 by chance?  The reason I ask is because I'm getting inconsisent results.  It seems that some machines are half provisioning.  Meaning that a machine will have all the functions enabled of vPro, except for the KVM function and yes all the machines support and are on AMT 6 and on LANDesk 9 SP2.

                   

                  Thanks.

                  • 6. Re: AMP/vPro very flaky inconsistent
                    Apprentice

                    I'm afraid I gave up in the end!  The tools and functions offered by vPro could be really useful but their implementation is just not good enough IMO.  My main gripes still stand - once you get consistent behaviour (which is often a case of trial and error), the fact that trying to do ANYTHING with vPro completely hangs the console is a big problem considering we're not just talking about 10 or even 20 seconds - we're talking minutes here!

                     

                    I've worked on many LANDesk implementations and have tried to make vPro work on several occasions in completely different environments - not once have I been able to make the damn thing work properly with acceptable reliability and performance.  This is unacceptable and, as this thread proves, neither LANDesk or Intel are willing/able to do anything about it - a real shame and an opportunity lost.

                     

                    Steve

                    • 7. Re: AMP/vPro very flaky inconsistent
                      Rookie

                      Hi Steve,

                       

                      Thanks for the reply.  We've been getting better results with vPro now.  It seems that after some time, machines will eventually fully provision and we are able to use the KVM function.  I should also note that we are doing the one touch provisioning with USB flash drives.  The slowness of some vPro functions still exists though.  That is the most frustrating.  However, we have now encountered some more weirdness that we cannot figure out.  Once we image a new PC with Windows, get the LANDesk agent installed and vPro KVM function working we go deploy the machine to whom ever needs it on which ever floor of the building. Once we do this it seems to "break" the KVM function.  Everything else still works including remote control through the LANDesk agent and all other vPro functions, just not the KVM.  It must be something to do when the IP address changes since the machine is pulling a new address via DHCP.  I can assure you that this is the only thing that changes.  We do not block any ports on our network between VLANs and subnets so I know the network is not the issue here. We've tried running both a regular LANDesk inventory and a vPro inventory and nothing seems to help.  It is a shame that there isn't any good information on this and no one seems to be able to help...

                      • 8. Re: AMP/vPro very flaky inconsistent
                        MrGadget Expert

                        Welcome to the world of VPro flakyness.

                        I setup Dell GX780'sUSFF and they worked off the bat.

                        I have a GX780 desktop and It worked one day and the next I got a message that I did not have permission to remote. I changed nothing in between. Those used ver 5.x Have not gotten back to this one yet.

                        Now I have E6510 laptops with ver 6.1 AMT and fought for 3 weeks trying to get them to work. The funny thing is I could get the vpro inventory and get into the web side http://ip:16992 but couldn't do anything else and it kept crashing my console. Finally I got it after finding a article on provisioning. (There are many articles out there but not on the version I had). Anyway I ended up unprovisioning it and when going back in giveing it my secure vpro password, I think it was under network and something in the setup, I choose rcvf or something like that and suddenly it all worked.

                        I also have been playing with makeing a iso to use for booting remotely. Today I finally got it working.

                        Does anyone have a iso made for idr booting?

                        • 9. Re: AMP/vPro very flaky inconsistent
                          jary.busato Apprentice

                          Here you'll find a recovery CD creation procedure by Paolo Sparvieri.

                           

                          http://communities.intel.com/servlet/JiveServlet/previewBody/2142-102-2-2989/A%20Windows%20Live-CD%20for%20AMT-VPro%20-%20Part%20I.pdf

                           

                          HTH

                           

                          Jary

                           

                          PS

                          I used vPRO features since LANDesk 8.7 - Their implementation in LDMS (IMO a Copy/Past of Intel DTK code) was always a bottleneck (1 minute/task) but in the latest LD version (9.02) they are unusable (5 minutes/task).