5 Replies Latest reply on Jan 4, 2011 5:55 PM by busbey

    Remote console locking up

    Rookie

      We are having a problem that occurs randomly and at least once a day for users that have various levels of access to the remote consoles. The problem happens at different times of the day and to different people at different times. For example, 'User A' logged to a remote console has the problem and 'User B' at the same site with the same access level may not have the problem at the same time. The fist symptom that usually occurs is they can't drag devices from the device list to a scheduled task. (.avi file attached the shows what happens) After a while the console locks up and the 'crossed circle' icon appears as the mouse pointer. I have tried the following in an attempt get closer to what the problem may be. Installed the console on a clean XP workstation, created virtualised consoles compressed and uncompressed and reset the console layout and column set configuration. I have run the console from the core server for the last few days and it hasn't had the same problem so I can safely say it's only a problem with the remote consoles. As a work around we have to log out then back into the console to get it to work again. On a side note, the problem first happened after we added 2 additional CPU's to the core server to try and resolve a performance problem. The additional CPU's didn't make any difference to the performance problem so we removed them and that when this new problem surfaced. Common sense would suggest this shouldn't cause the console problem but it started happening as soon as we removed the additional CPU's. We are on LDMS 8.8 SP4 and XP SP2 workstations. Database is on a separate server, core and DB is on VM. Would like to remove all servers from VM but unfortunately I don't have any say over it.

        • 1. Re: Remote console locking up
          zman Master

          busbey,

           

          Just for S&Gs try minimizing then maximizing the console. Also, anything in the console log?  Can you right click and copy then paste unto the task? What is the memory usage of the remote console when this happens.

          1 of 1 people found this helpful
          • 2. Re: Remote console locking up
            Rookie

            Thanks Zman,

             

              I tried the minimize / maximize with no luck. Tried the right click copy / paste thing with no luck. The console.exe.log has some recurring entries that say "CustomGroup.LoadCustomGroup: Warning. There is a duplicate entry in the CustomGroup table and the first entry was selected" Console.exe looks to be using about 40mb memory and no CPU.

             

            Any ideas about what that means in the log?

            • 3. Re: Remote console locking up
              zman Master

              I see this in my logs and I don't think it is a big issue and not related to your issue. I've seen this problem a few times and it was with an older version of LANDesk. I would make sure that you have everything up to date (e.g., I would update to SP3 of XP and make sure your video drivers are up to date, etc...) Is this something that happens early on after the console is started or happens after a while? I'm guessing it is after a while. I'm guessing it is a leak somewhere.  Also if you have any post patches for your LANDesk make sure that they are alos on your remote consoles. I would also limit any other running applications to see if it a memory/resource issue (Antivirus, etc...)

              • 4. Re: Remote console locking up
                Rookie

                God point.. Since last post I've tried...

                 

                Rebuilding a new XP SP3 PC with no AV or firewall etc.

                Made sure all MS patches / updates and hardware drivers were the latest from the respective manufacturers.

                Installed remote console with all available patches.

                 

                Unfortunately no difference.

                 

                I've got a separate support request with LANDesk in relation to the following event warning. I don't think they are the direct cause of the console problem because we have been having these events for a couple of months and the console problem has only recently started.

                 

                ISAPI 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll' reported itself as unhealthy for the following reason: 'Deadlock detected'.

                 

                and

                 

                A process serving application pool 'LDAppMain' exceeded time limits during shut down. The process id was '9504'.

                 

                When the consoles lock up none of these errors occur around that time. In fact we get no event, resource or performance indicators at the same time of the console lockups.

                 

                 

                 

                • 5. Re: Remote console locking up
                  Rookie

                  A user on a remote console received the following error when a lock up occured. See attachment called 'COM Class Error.bmp' Hope this provides someone with a hint on what the problem is.