4 Replies Latest reply on Feb 9, 2011 12:12 PM by Zferrini

    AutoIT not running as logged on user


      I am trying to use AutoIT to configure MS HIS 2004 on Windows 7  as the logged on user.  The user is an adminstrator and I have disabled UAC when AutoIT runs. The issue isnt the script not running, it runs but the settings that are configured dont get applied.  If I run AutoIT by hand these settings get applied fust not with LANDesk.  I have used a SWD set to run as the logged on user, same result.  Tried a batch file using the startasuser.exe command, same issue.  Each time if I manually runs the exact same Autoit exe the setting get configured.  Any Ideas?



        • 1. Re: AutoIT not running as logged on user
          rictersmith Specialist

          If I understand your question. You have built a script in autoit and compiled it into an .exe


          If you deploy the script using LANDesk the script fails to work correctly, configuring the changes you are trying to make.


          If you manually launch the same script by running the .exe, then the settings are made.


          IF this is correct, then the issue is probably in your LANDesk deployment settings. 


          This issue occurs when the Distribution Package is set to use tthe 'LocalSystem account' and your .exe must log in as the currently logged in user. This is not nomally used, since most admins take away administrative rights often required by a packge from their end user.


          Open the Distribution Package Properties for the .exe you are trying to deploy.


          Then highlight the 'Accounts' section. Modify the account selection to use the 'Current user's account'.


          NOTE: there are limitations to using this account and they are described in part under the selection.

          1 of 1 people found this helpful
          • 2. Re: AutoIT not running as logged on user

            Thank you for the response.  I will try that as see if this helps.

            • 3. Re: AutoIT not running as logged on user
              rictersmith Specialist

              Did this work for you?

              • 4. Re: AutoIT not running as logged on user

                Even if I try running it as the logged on user, ie I am autologging in the administrator, still has no effect.  I placed the file in the all users startup folder with the same results, nothing.  Odd issue here, if I run the config as a domain user it works fine.  It must be a domain issue as even if I manually run the config under the local administrator account it does not configure the gateway.  Only a user logged into the domain can configure that.  Thank you for the help.