11 Replies Latest reply on May 19, 2015 10:32 AM by rmarroquin

    PXE Boot Menu Scripts not showing


      Hi All,


      I'm pretty new at this, so I've been following the "LANDesk Management Suite 8.7 SP2 OS Deployment of Windows XP Using WinPE Best Known Method" document.  I was able to successfully PXE boot and capture an image, and then able to successfully deploy that same image.  However, when I created a new image, after successfully capturing it, I no longer see any scripts appearing in my PXE boot menu.  I am able to successfully PXE boot my client I want to image, but when the PxeMenu appears, there are no scripts.  I've tried rebuilding all of my scripts to no avail.  Is there something that I'm missing here?  Any help is greatly appreciated.

        • 1. Re: PXE Boot Menu Scripts not showing
          bnelson Employee

          Redeploy your PXE agent.

          • 2. Re: PXE Boot Menu Scripts not showing

            By PXE agent, I assume you mean the PXE representative, correct?  I just gave that a try, and it didn't work.  So then I rebooted, did the PXE representative removal and then did a PXE representative deployment again.  My client still doesn't see any scripts in the PXE Boot Menu.  I have also clicked the Update button on the PXE boot menu in the console just to make sure, but again, no scripts are present after booting.


            Any other ideas?

            • 3. Re: PXE Boot Menu Scripts not showing
              bnelson Employee

              OK, I had that issue one time and took the steps you just took (Updated and then redeployed the rep) and that resolved the issue. The PC's are seeing the PXE rep, getting the boot image, but not seeing any scripts in the menu? Did you apply any updates just prior to the scripts going away? (Microsoft or LANDesk) Otherwise I am a little baffled.

              • 4. Re: PXE Boot Menu Scripts not showing
                Jared Barneck SupportEmployee

                So the PXE Rep has nothing to do with the Script Menu with the script menu.  It may have something to do with the WinPE image you boot to.  If you boot to one without network drivers that is a problem.


                If you boot to WinPE, you are done with the PXE Rep completely before even trying to download the menu.  The menu is between the WinPE device and the Core Server.


                The Menu is a simple text file DOSMENU.CFG that is downloaded from the Core Server.  I would start with the Network Card driver.  Does it load in WinPE?  If so, then I would start trying to download the DOSMENU.CFG.  Look at the x:\i386\system32\StartNet.CMD and files it calls to troubleshoot this.

                • 5. Re: PXE Boot Menu Scripts not showing

                  rhyous -


                  Thanks for the info but I'm not quite sure how to go about trying what you've suggested.  How do I check if the network card driver is loading in WinPE?  I'm not so sure if this is the problem, because I tried to PXE boot the machine I captured the image from (successfully) and am now unable to get the scripts to show with that computer.


                  I was able to open the DOSMENU.CFG file with notepad on a PXE booted machine, and it said the following:



                  Authentication is required because:

                  Access denied due to authentication failure.


                  My question is what authentication has failed?  Is it relevant to my problem (it sure sounds relevant to this newbie!)?  I retyped my credentials in the deploy script and updated it in the PXE boot menu and tried, but it didn't work.  I'm going to try to redeploy the PXE representative again to see if that makes a difference.  For my reference, do I need to redeploy the PXE representative everytime I update the scripts in the PXE boot menu?

                  • 6. Re: PXE Boot Menu Scripts not showing

                    Shucks, I redeployed the PXE representative and that didn't resolve the problem.

                    • 7. Re: PXE Boot Menu Scripts not showing

                      That is definitely not what you should be seeing.


                      On the Core Server, look in the Program Files\LANDesk\ManagementSuite\LANDesk\Files directory.

                      Open DOSMENU.CFG.

                      Now you know what it should look like.


                      Now you are getting an Unathorized.  That means some one has changed your permissions.


                      In IIS is the LANDesk\Files Web Share set to anonymous access, or did somebody change it to Windows Integration?  It should be anonymous access.

                      1 of 1 people found this helpful
                      • 8. Re: PXE Boot Menu Scripts not showing

                        Our network guy just checked the IIS shares, and it looks like everything is set to anonymous.  However, he didn't see a directory called LANDesk\Files Web Share.  A few directories weren't set to anonymous, including Reports & LDSM.  However OSD was set to anonymous.

                        • 9. Re: PXE Boot Menu Scripts not showing
                          Jared Barneck SupportEmployee

                          If you don't have a Landesk\files web share in IIS, some one removed it.


                          Can you doublecheck?


                          You may want to try this:

                          Restore IIS from backup, after which you must do the following:


                          1. Restore the already existing LANDesk server certificate for the

                          default web site.


                          2. Make the following IIS folders web services instead of just folders:





                          3. The LANDesk\ManagementSuite\Core\SSL webservice and it's sub-web

                          services have anonymous access enabled. This must be disabled and

                          windows integrated security should be enabled.


                          4. Create Application Pools as necessary.


                          Do not do that until you are sure that IIS is no longer configured


                          • 10. Re: PXE Boot Menu Scripts not showing

                            Thanks to all who've helped troubleshoot this problem.  I have an open case with LD support and they're looking into it.

                            • 11. Re: PXE Boot Menu Scripts not showing

                              did you ever figure this out?? im having exactly the same problem where I can't get the script to show in the osd deployment script menu