14 Replies Latest reply on Feb 29, 2008 9:27 AM by jrtilson

    OSD - Difficulties "1 off"






      I'm having some difficulty getting OS Deployment working properly. Here's the situation:



      I've got a PXE Rep. setup no problem, and I can PXE boot with the menu and everything. I've followed the BKM OS Deployment with LinuxPE for 8.7, and everything is dandy.



      I managed to capture an image using the LinuxPE Capture Script, but due to the nature of our environment and database I had to employ a major workaround... I work in an educational environment with lots of laptops coming in and out, loaners, replacements, etc... So needless to say the agents get deployed and redeployed quite a bit. The particular laptop I was using to grab the image had an entry in the database from ages ago, and there appeared to be a dupe. So I deleted all records of that computer from the database, booted to WinPE and ran a miniscan. Once completed I booted back into LinuxPE and tried capturing. It worked no problem.



      Now, on a different laptop I'm trying to deploy that freshly captured image with the LinuxPE deployment script, but it won't work. I've taken a look through the database and I found the computer there and deleted it. (The particular laptop I was trying to image would be a loaner, and assigned a hostname base on the person borrowing at some point in the future). When I tried deploying the image the custom job windows popped up with the computer named by its MAC address, them promptly disappeared. Here's the results from the log file:




      "(OFF) 0014D253A23D","OFF","N/A","0:00:00","13/02/2008 4:38:48 PM","13/02/2008 4:38:48 PM","N/A"

      ; "Job Complete","0 Done","0 Failed","1 Off","0 Unknown"




      As far as I can tell, LANDesk thinks the computer is off.. but it got the MAC address right. I'm confused.






        • 1. Re: OSD - Difficulties "1 off"
          zman Master


          Ok when you say you captured the image,  I'm assuming the LANDesk client was not in the image captured? A little hard to follow since you indicated that the PC was already in the DB.  Just to be sure make sure the LANDesk client is not in the image.






          Also when you say you looked through the database and found the computer and deleted it. Are you actually going into the SQL/ORacle DB and whacking the computer or are you deleting the computer via the LANDesk Console. 






          Also, do you have "First Attempt and get use  existing computer name......." in your deployment script?



          • 2. Re: OSD - Difficulties "1 off"


            Thanks for the reply, I should have been more clear.



            The image I managed to capture did not have a client installed, it was a pretty standard stripped own sysprepped image. The computer was already in the DB because it had previously had an agent installed (this particular laptop was a loaner and had been returned for re-imaging - we currently use Symantec Ghost). I set up everything from scratch on this and sysprepped again - no agent. So it was still in the database, as we don't formally remove the agents.



            I should mention, I'm testing out the OSD stuff as a replacement for Ghost.



            Anyways, when I said removed from database, I mean from the console not through MSSQL.



            In my deployment script, I have left out the "First attempt .." just because I don't want the laptop to pick up whatever hostname was inventoried, it will eventually be setup as a loaner for someone else (we name our laptops/desktops based on user - so a loaner would have a hostname like LOANER-JOHNDOE).






            • 3. Re: OSD - Difficulties "1 off"
              zman Master

              Are the two laptops the same in hardware (same nics, etc...)? I've not used LinuxPE before but it sounds like it might be a driver issue.






              BTW thanks for the clarification, I can be a little dense sometimes.

              • 4. Re: OSD - Difficulties "1 off"


                Haha no problem, I share the affliction. To answer your question, yes, both machines are the same - absolutely identical down to the model type. I just find it bizarre that I got that "1 off" result when attempting to deploy. I'm probably missing something really simple, as I'm quite new to this stuff.









                • 5. Re: OSD - Difficulties "1 off"
                  Jared Barneck SupportEmployee

                  Do a query for the MAC address and delete any devices that have the same MAC address. Usually you get a device is off, because there is some entry in the DB with a different IP that is probably not the correct IP for the device currently booted to WinPE.

                  • 6. Re: OSD - Difficulties "1 off"


                    Just tried that, didn't seem to help. After yet another unsuccessful try, I ran the query and it found a new entry under All Devices named the same as the MAC address of the machine I'm trying to image.






                    • 7. Re: OSD - Difficulties "1 off"
                      Jared Barneck SupportEmployee

                      That is what is supposed to happen.


                      The machine boots to WinPE and sends in a Miniscan.  The device should have almost no data in inventory, but it should have the IP Address.


                      Does the device have the IP Address, or is the IP address not there or is it all

                      • 8. Re: OSD - Difficulties "1 off"


                        Figured as much. I'm actually using LinuxPE at the moment, not WinPE.



                        So I've just PXE booted the thing, and I'm at the boot menu, checking on my core I see the miniscan results, and according to the inventory its IP address is all 0's. It also appears that as far as it knows, the machine is off... but I'm staring at it in a perfectly on state...







                        • 9. Re: OSD - Difficulties "1 off"
                          Jared Barneck SupportEmployee

                          All right we have detected the problem...the miniscan is running before the network card has finished with DHCP and your device is reporting all 0s.


                          This is something we have almost completely eradicated in WinPE but in LinuxPE it has never been reported.  You should open a support ticket and ask for a bug to be submitted.


                          Until then maybe we can find where the miniscan is called and add some type of 5 second sleep, to make sure the IP Address is all there.


                          It may also be that the device has two NICs, a wired, and a wireless and it reports the wireless, but that is less likely as there are no wireless drivers in LinuxPE, , though maybe possible.

                          • 10. Re: OSD - Difficulties "1 off"


                            Interesting. That would explain why I was able to capture the image only after running WinPE and manually running a miniscan, then booting back into linuxPE... I'll log a support ticket. Also, the laptop in question does have built in wireless, maybe I'll try disabling it in the BIOS and see if that makes a difference.



                            Adding that pause sounds like a good idea, would that be a simple addition to one of the scripts?






                            • 11. Re: OSD - Difficulties "1 off"
                              Jared Barneck SupportEmployee

                              Boot to LinuxPE, press Alt - F2 (or Alt F(something)) and you get a Linux shell in LinuxPE.


                              Then we have to search probably the /etc/rc files to find where the miniscan is called.


                              If I get time, I will look into how to slow down or delay the miniscan by a few seconds.

                              • 12. Re: OSD - Difficulties "1 off"


                                I can confirm that the following actually gives an ip in the inventory for the miniscan:



                                cd /etc/rc.d/init.d/



                                ./miniscan start






                                • 13. Re: OSD - Difficulties "1 off"
                                  Jared Barneck SupportEmployee

                                  Well, then it is not that you have two NICs or anything then, or it would always happen.


                                  We probably just need to add a delay of some type.  Probably just need a couple seconds...3 second would probably be more than enough.


                                  In WinPE we created a wait4ip.exe but I am not sure what to use for LinuxPE.


                                  The init script is calling




                                  The sleep command works.  We can try that.

                                  • 14. Re: OSD - Difficulties "1 off"


                                    Which files would I need to modify on the core server/PXE rep in order to permanently fix the script?