9 Replies Latest reply on Jan 11, 2011 11:58 PM by steve777

    Install with unattend File Win 7 64 Bit

    Rookie

      I have a problem with installing Win7 64 Bit with Landesk LDMS 9. I know the thread http://community.landesk.com/support/docs/DOC-7556 but it dosn´t work. In the attachment you can see the unattend File from our System for 64 Bit. How can i insert it into provisioning template?   What modifications are necessary?

      Additional i had attached the 32 Bit unattend File, which works fine.

       

      Thanks

        • 1. Re: Install with unattend File Win 7 64 Bit
          ahe Expert

          Hello Stephan,

           

          if you want to use the same Windows PE boot image (32Bit), you've to change the entries to x86 instead of amd64 in tne WinPE section of the XML file:

           

          <settings pass="windowsPE">
                  <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86"

           

          regards

          ahe

          • 2. Re: Install with unattend File Win 7 64 Bit
            Rookie

            Thanks for answer. When i use the unattend File for 64 Bit, i use a other Install Setup.exe (for 64 Bit Installation). Therefore i get a error Message "This version of setup.exe is not compatible with the version of Windows your are running..." when i Start WinPE provisioning Template.

            • 3. Re: Install with unattend File Win 7 64 Bit
              ahe Expert

              Hello,

               

              we use for both systems the same PE image and the same setup.exe but different WIM images and different XML files (it is possible to use only one XML for both, but we don't do it...)

               

              setup.exe /installfrom:<your_path_to_wim>\X64install.wim /m:<your_path_to_oem_files>\$oem$ /unattend:<your_path_to_XML_files>\autounattendX64.xml

               

              Regards

              ahe

              1 of 1 people found this helpful
              • 4. Re: Install with unattend File Win 7 64 Bit
                Rookie

                Thanks again. This is a good answer. I had make this settings but the installations stops at select the image File (screenshot) Do you know why?

                 

                regards

                • 5. Re: Install with unattend File Win 7 64 Bit
                  ahe Expert

                  Some questions:

                   

                  How did you edit the XML file? Did you use the tools from WAIK or did you use the editor of W7? If you use the editor you'll get problems because some hidden letters are included (no problems with Notepad from XP or Notepad++).

                   

                  Did you start the setup.exe in the original directory (with some subdirectories and files...). If not, some dll's are missed...

                   

                  Did you change the Windows PE part of XML only or some parts too?

                   

                  Did you check the logfiles of the installation? Start Windows PE and check the files in the directory %windir%\Panther and %windir%\Panther\UnattendGC

                   

                  Regards

                  ahe

                  • 6. Re: Install with unattend File Win 7 64 Bit
                    Rookie

                    I edit the XML File with an XML Editor, yes. Now i work with notepad, but the same Problem

                     

                    I start the setup.exe from original directory

                     

                    I changed the WinPE Part only

                     

                    The Folder C:\Windows\panther is empty

                    • 7. Re: Install with unattend File Win 7 64 Bit
                      ahe Expert

                      These are our entries for Windows PE:

                       

                       

                      - <settings pass="windowsPE">
                      - <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86"  publicKeyToken="31bf3856ad364e35" language="neutral"  versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                      - <SetupUILanguage>
                        <UILanguage>en-US</UILanguage>
                        </SetupUILanguage>
                        <SystemLocale>en-US</SystemLocale>
                        <UILanguage>en-US</UILanguage>
                        <UILanguageFallback>en-US</UILanguageFallback>
                        </component>
                      - <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35"  language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                      - <ImageInstall>
                      - <OSImage>
                      - <InstallTo>
                        <PartitionID>1</PartitionID>
                        <DiskID>0</DiskID>
                        </InstallTo>
                        <InstallToAvailablePartition>false</InstallToAvailablePartition>
                        <WillShowUI>OnError</WillShowUI>
                        </OSImage>
                        </ImageInstall>
                      - <UserData>
                      - <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                        </ProductKey>
                        <AcceptEula>true</AcceptEula>
                        <Organization>our company</Organization>
                        </UserData>
                        </component>
                        </settings>

                       

                       

                      All other components has the entry amd64 in processorArchitecture.

                       

                      Regards

                      ahe

                       

                      Nachricht geändert durch ahe XML formatting is gone...

                      • 8. Re: Install with unattend File Win 7 64 Bit
                        Rookie

                        Maybe it´s something wrong in the provisioning setting. The parameters of setup.exe are /installfrom:\\mos1s135\software\W7Ex64EN\sources\install.wim /unattend:X:\scripts\unattend.xml /noreboot

                        • 9. Re: Install with unattend File Win 7 64 Bit
                          Rookie

                          it works. I´d copy our script and edit it with notepad. Thanks for your help