10 Replies Latest reply on Jan 13, 2011 8:12 AM by alanblake

    7.4 LDMS Import Connection Fails

    Rookie

      In using this article (http://forum.landesk.com/support/docs/DOC-22027) I have attempted to create an LDMS connection from Service Desk.

      However, when I try theTest Connection it fails.

       

      I have LDMS 9 SP 2 installed.

       

      Here is my connection settings (I am thinking the "instance" value is the problem):

      ldms_connect.jpg

        • 1. Re: 7.4 LDMS Import Connection Fails
          masterpetz ITSMMVPGroup

          Hi Alan,

           

          What happens if you try to login to your SQL server with SQL Management Studio and use the same login values that you use in your ldms connection?

          Is this possible?

           

          Cheers

          Christian

          • 2. Re: 7.4 LDMS Import Connection Fails
            Rookie

            Yes, I am able to connect using SQL mgmt studio on the db server.  I also was able to create a system DSN and connect from the SD server.  So the credentials are working, the connection properties are missing something though...I am thinking it is the fact that we don't have an instance but just took the default instance (MSSQLSERVER) when SQL Server was first installed.

            • 3. Re: 7.4 LDMS Import Connection Fails
              Stu McNeill Employee

              Hi Alan,

               

              You can check the SQL details in Service Desk by creating a data connection under the Generic Data Source branch and selecting SQL Server as the provider.  If this works check this document written today which I have a feeling will catch a lot of people out (and will be added to the document you went through very shortly) - "Could not connect to LanDesk Database" error with integration to LDMS 9 SP2 onwards.

              • 4. Re: 7.4 LDMS Import Connection Fails
                Rookie

                I am able to connect via a Generic Data Source connection as SQL Server.  In reviewing the document you suggested I am unclear as to what I need to do next.  I deployed the remote agent to a laptop and from that machine tried to created this Service Desk LDMS Connection which is still failing.

                 

                I just tried to run the integration.exe and in reviewing the Component Services (this is on the LDSD machine) I don't even see a LANDesk item.

                 

                Service Desk 7.4 Beta 4

                LDMS 9 SP 2

                 

                Message was edited by: Alan Blake

                • 5. Re: 7.4 LDMS Import Connection Fails
                  masterpetz ITSMMVPGroup

                  Hi Alan,

                   

                  as far as i know, there were some problems with LDMS connection and the beta version of LDSD 7.4. Maybe you should get the final 7.4 that was released today and try again.

                   

                  Cheers

                  Christian

                  • 6. Re: 7.4 LDMS Import Connection Fails
                    Rookie

                    I requested the final version yesterday and am still waiting to get the download details.

                    • 7. Re: 7.4 LDMS Import Connection Fails
                      masterpetz ITSMMVPGroup

                      Good luck!

                      • 8. Re: 7.4 LDMS Import Connection Fails
                        Rookie

                        When installing the LDMS Remote Console on my SD server my pre-req fails with:

                         

                        LANDesk requires .NET Framework version 3.5 SP1.

                         

                        I have 4.0 for SD, I guess I have to now install 3.5 for this integration - you would think the 4.0 would satisfy this pre-req.

                        • 9. Re: 7.4 LDMS Import Connection Fails
                          Rookie

                          So I got the 7.4 software and installed on a new VM.  I also got LDMS remote client installed on the same machine.  I ran the integration.exe and got this error in the log:

                           

                           

                           

                          1/12/2011 2:41:41 PM :: Started integration process...
                          1/12/2011 2:41:41 PM :: Is 64 bit OS: True
                          1/12/2011 2:41:41 PM :: Is Console: True
                          1/12/2011 2:41:41 PM :: Product Version: 9.00.0.473
                          1/12/2011 2:41:41 PM :: ServicePack: 2
                          1/12/2011 2:41:41 PM :: Is Valid Version: True
                          1/12/2011 2:41:53 PM :: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
                          1/12/2011 2:41:53 PM :: Integration complete.

                           

                           

                           

                          Where is this access defined?

                          • 10. Re: 7.4 LDMS Import Connection Fails
                            Rookie

                            I had to run the integration.exe with "Run as Administrator" which has generated this log output:

                             

                             

                            1/13/2011 7:22:59 AM :: Started integration process...
                            1/13/2011 7:22:59 AM :: Is 64 bit OS: True
                            1/13/2011 7:22:59 AM :: Is Console: True
                            1/13/2011 7:22:59 AM :: Product Version: 9.00.0.473
                            1/13/2011 7:22:59 AM :: ServicePack: 2
                            1/13/2011 7:22:59 AM :: Is Valid Version: True
                            1/13/2011 7:22:59 AM :: COM+ Application: 'LANDesk' has been created.
                            1/13/2011 7:22:59 AM :: 'CreatorOwner' Role has been added to the 'LANDesk' COM+ Application.
                            1/13/2011 7:22:59 AM :: Found COM+ Application: LANDesk
                            1/13/2011 7:22:59 AM :: Imported component: LANDesk.ManagementSuite.Sdk.Database
                            1/13/2011 7:22:59 AM :: Imported component: LANDesk.ManagementSuite.Sdk.Inventory
                            1/13/2011 7:22:59 AM :: Imported component: LANDesk.ManagementSuite.Sdk.Query
                            1/13/2011 7:22:59 AM :: Imported component: LANDesk.ManagementSuite.Sdk.Schema
                            1/13/2011 7:23:00 AM :: Added User: Everyone to Role: CreatorOwner
                            1/13/2011 7:23:00 AM :: Integration complete.

                             

                             

                            I then created my LDMS connection and the test suceeded!